Difference between revisions of "Tips with Keyboard and Mouse"

From OCAD Wiki - English
Jump to navigation Jump to search
 
(4 intermediate revisions by the same user not shown)
Line 1: Line 1:
This page summarises Tipps and Tricks with Keyboard and Mouse to optimize your drawing and editing skills in OCAD.<br>
+
This page summarises Tips and Tricks with Keyboard and Mouse to optimize your drawing and editing skills in OCAD.<br>
 
Click on the links for each function to learn more and see an animation.
 
Click on the links for each function to learn more and see an animation.
  
Line 35: Line 35:
 
|-
 
|-
 
|Backspace|| Delete last vertex.
 
|Backspace|| Delete last vertex.
 +
|-
 +
|ESC|| Cancel drawing with ESC key.
 +
|-
 +
|Status Bar|| Length and agle of an line objects are shown in the [[Graphical_User_Interface#Status_Bar|Status Bar]].
 
|}
 
|}
 +
 
Visit the '''Drawing and Editing''' Section in the '''[[OCAD_Preferences#Drawing_and_Editing|OCAD Preferences]]''' to choose your favourite settings.
 
Visit the '''Drawing and Editing''' Section in the '''[[OCAD_Preferences#Drawing_and_Editing|OCAD Preferences]]''' to choose your favourite settings.
  
 
==Editing==
 
==Editing==
 
{|
 
{|
|style="width:200px;" |Shift + [[File:Icon SelectAndEditObject.PNG]] or [[File:Icon SelectObjectAndEditVertex.PNG]]|| Object not selected: [[Select#Select_and_Edit_Multiple_Objects|add to the selected objects]]. As an alternative, drag an area with the Left Mouse Button. <br> Selected object: [[Select#Select_and_Edit_Multiple_Objects|remove from selected objects]]. <br> [[Select#Move_Single_Vertices|Keep right angle]] when moving a corner (e.g. building).
+
|style="width:200px;" |[[File:Icon SelectObjectAndEditVertex.PNG]]|| [[Select#Select_Object_and_Edit_Vertex|Move Segments]]
 +
|-
 +
|Shift + [[File:Icon SelectAndEditObject.PNG]] or [[File:Icon SelectObjectAndEditVertex.PNG]]|| Object not selected: [[Select#Select_and_Edit_Multiple_Objects|add to the selected objects]]. As an alternative, drag an area with the Left Mouse Button. <br> Selected object: [[Select#Select_and_Edit_Multiple_Objects|remove from selected objects]]. <br> [[Select#Move_Single_Vertices|Keep right angle]] when moving a corner (e.g. building).
 
|-
 
|-
 
|Ctrl + [[File:Icon SelectObjectAndEditVertex.PNG]]||[[Vertices#Remove_Vertex|Remove Vertex]]
 
|Ctrl + [[File:Icon SelectObjectAndEditVertex.PNG]]||[[Vertices#Remove_Vertex|Remove Vertex]]
Line 47: Line 54:
 
|-
 
|-
 
|Shift + Ctrl + [[File:Icon SelectObjectAndEditVertex.PNG]]||[[Vertices#Add_Normal_Vertex|Add Vertex]]
 
|Shift + Ctrl + [[File:Icon SelectObjectAndEditVertex.PNG]]||[[Vertices#Add_Normal_Vertex|Add Vertex]]
 +
|-
 +
|Ctrl + Space + [[File:Icon SelectObjectAndEditVertex.PNG]]||[[Select#Toggle_between_vertices|Toggle]] between normal-dash-corner or toggle between straight and bezier curve segment.
 
|-
 
|-
 
|Alt + [[File:Icon SelectObjectAndEditVertex.PNG]]||[[Select#Select_an_object_behind_an_object_already_selected|Select an object under a already selected object]].
 
|Alt + [[File:Icon SelectObjectAndEditVertex.PNG]]||[[Select#Select_an_object_behind_an_object_already_selected|Select an object under a already selected object]].

Latest revision as of 17:21, 11 May 2021

This page summarises Tips and Tricks with Keyboard and Mouse to optimize your drawing and editing skills in OCAD.
Click on the links for each function to learn more and see an animation.

Navigation

Space + Mouse Drag Move the view. See also: Icon Pan.PNG Pan Tool
Mouse Wheel Down Pan while holding the mouse wheel down.
Mouse Wheel + Ctrl Zoom in/Zoom out. See also: Icon ZoomIn.PNG Icon ZoomOut.PNG Zoom Tools
Mouse Wheel Move the view vertically.
Mouse Wheel + Shift Move the view horizontally.
F5 Redraw
Window > Tile Fit all opened OCAD projects horizontally or vertically in the OCAD window

There are some Shortcuts by default corresponding to view and navigation functions.

Drawing

Shift + Icon CurveMode.PNG Continue an existing line or expand areas objects. Press the Shift key and click the start or end point of line or area object to be continued.
Shift + Icon CircleMode.PNG Drawing circular objects from the center point.
Ctrl + Icon CurveMode.PNG Following Existing Objects.
Alt + Icon StraightLineMode.PNG Draw horizontal or vertical lines. Press the Alt key while drawing. The line snaps in a vertical or horizontal direction.
Tab Change drawing mode during drawing and editing. Press the Tab key until the desired drawing mode appears to change the drawing mode.
P Press the P key to change to the last used drawing mode.
Backspace Delete last vertex.
ESC Cancel drawing with ESC key.
Status Bar Length and agle of an line objects are shown in the Status Bar.

Visit the Drawing and Editing Section in the OCAD Preferences to choose your favourite settings.

Editing

Icon SelectObjectAndEditVertex.PNG Move Segments
Shift + Icon SelectAndEditObject.PNG or Icon SelectObjectAndEditVertex.PNG Object not selected: add to the selected objects. As an alternative, drag an area with the Left Mouse Button.
Selected object: remove from selected objects.
Keep right angle when moving a corner (e.g. building).
Ctrl + Icon SelectObjectAndEditVertex.PNG Remove Vertex
Ctrl + Icon RemoveVertex.PNG + Mouse Remove Vertex with Mouse Over.
Shift + Ctrl + Icon SelectObjectAndEditVertex.PNG Add Vertex
Ctrl + Space + Icon SelectObjectAndEditVertex.PNG Toggle between normal-dash-corner or toggle between straight and bezier curve segment.
Alt + Icon SelectObjectAndEditVertex.PNG Select an object under a already selected object.
Alt + Icon Cut.PNG or Icon Reshape.PNG Select next object for editing
Arrow Keys Move selected objects (fine tuning)
Arrow Keys Double Click on Vertex and Move Vertex With Arrow Keys.
Tab + Icon SelectObjectAndEditVertex.PNG Move neighboring Segments and congruent Vertices in one single step.
Shift + Arrow Keys Move selected objects (fast)
P Get latest used drawing tool
A Change to the Select Object and Edit Vertex mode.
V Change to the Select and Edit Object mode.

Cutting

Ctrl + Icon Cut.PNG Insert a virtual gap.
Shift + Icon Cut.PNG Dashed line: Insert a gap at the cutting point

Background Map

F9 Adjust a Background Map
F10 Hide all Background Maps

Varia

F2 Normal (Visible and Selectable)
F3 Protect Objects
F4 Hide Objects
File > Open Recently Exported Documents Shortcut to open exported OCAD Files, PDFs, PNG, ...
File > Open Recently Used OCAD Files Shortcut to open an OCAD file which you recently opened.