O-training with OCAD

From OCAD Wiki - English
Jump to: navigation, search

This function is available in OCAD Mapping Solution.This function is available in OCAD Orienteering.This function is available in OCAD Starter.This function is available in OCAD Course Setting.

Lern how to start with an easy Course Setting Project.
Discover new sophisticated o-technical excercises.
Get background information for Course Setting.

Preparation

For a Course Setting Project, you need two OCAD files:

- A [Course Setting File]
This is the file where manage your Course Setting Project, set courses and load a Background Map.
Like map files it has the extension .ocd, but it has a special internal mark to identify it as a course setting file.

- A [Map File]
This is your OCAD map which will be loaded as Background map in your [Course Setting File].
Hint.jpg You can also load a raster image (PNG, JPG, ...) as Background Map. However, for the trainings described below, you need to modify your Background Map, so you need a OCAD file.

Now start a New Coure Setting Project. Make sure the map scale of your [Course Setting File] is the same as your [Map File].

Correct Scale

It sometimes happens, that your course setting project and your background map have different scales without noticing it.
Generally, OCAD checks if the Background Map comes in the same scale as the course setting project and in case the scales are different, there will be an Error Message.
BackgroundMapScale.png

Check the scale of your course setting project under Map>Set Scale and Coodinate System.
Check the scale of your background map under Background Map>Manage. Click on the Information Icon behind the Backgound Map.

To be really sure that the scale is correct:

  • Messure a line in OCAD and Google Maps and compare them.
  • If your background map is georeferenced, you can export your courses in KMZ format and open them in Google Earth (File>Open Recently Exported Documents). There you see if your map corresponds with the terrain.

10'000 and 15'000

In the ISOM 2017, the 1:10'000 map is defined as a 150% magnification of the 1:15'000 map. This applies to all objects including course setting objects (e.g. control circles are 7.5mm for 10'000 and 5mm for 15'000; in the past all control circles were 6mm).
If your [Map File] is 1:15'000, you should start with the Course Setting 15 000 ISCD 2018 - ISOM 2017.ocd symbol set. For a [Map File] in 1:10'000, use the Course Setting 10 000 ISCD 2018 - ISOM 2017.ocd symbol set.

Let's assume our Background Map has the scale 1:10'000:

  • Open the Course Setting 10 000 ISCD 2018 - ISOM 2017.ocd symbol set.
  • When both 1:10'000 and 1:15'000 maps need to be printed, the entire course setting shall be done in a 1:10'000 project and only the print and/or export scale needs to be adjusted.
  • The exact size of the Control Description is not defined according to ISCD 2018. It must be between 5-7mm. If a Control Description is printed on the map, it is recommended to change the size of the Control Description (Course setting>Options) before exporting 1:15'000 maps, e.g. to 7.5mm, which results in 5mm. Otherwise, the Control Description is only 4mm on the 1:15'000 print, as it is set to 6mm for 1:10'000 by default.
The same works, if your [Map File] and your [Course Setting File] have the scale 1:15'000 and you want to export a map in scale 1:10'000. This time, reduce the size of the Control Description (Course setting>Options) before exporting to 4mm. Doing so, the Control Description will be 6mm wide on the 1:10'000 map.
  • If the scale appears on the map (in our assumption 1:10'000), it should of course be changed before exporting 15'000 maps in the [Map File].
Hint.jpg Important: Only change the font and not the scale itself in the [Map File]. Save the [Map File] still in 1:10'000 under a new name and reload it as background map in the [Course Setting File]. Alternatively, simply specify the scale in the [Course Setting File] with a font.

Pimp your Symbol Set

Are you regulary setting courses for your club? Shall all trainings have a common layout, similar to Corporate Identity?
So, why not create your own Symbol Set and save it in the folder C:\Program Files\OCAD\OCAD 2018 Orienteering\Symbol? The Symbol Set will be on the list Load symbol set from:, if you open a new Course setting project for Orienteering.

OCADSymbolSet.png
Example of the OCAD Symbol Set. A4/A3 frames, OCAD Logo, Corridor Symbol, Symbol for Parking, different Text Symbols.

Tipps and Tricks

  • Use the Compose Course tool for fast and easy course setting.
  • Click on Add in the Course box to add a new course.
  • To check your courses, use the Consistency Check Report under Menu>Course Setting>Consistencey Check Report
  • Enter Text into the Text field of the Marked Route and make the Text Control Description smaller.
  • Read here how to export all relay variations to one file.
  • Pay attention to open/save Course Setting Files from OCAD 11 in OCAD 12 and vice versa, as many symbols and colors has changed between these two versions.
  • Press Shift while adding a new contol and you will skip the course object dialog box.
  • Add Conrtol by moving the connection line between two existing controls.
  • When you select controls for courses by double-clicking on them, lock their position beforehand in order not to shift them.

Course Setting functions

See the Course Setting for Orienteering page to get information about all functions of the Course Setting module.

O-trainings

Simple Course

This short video shows you how to start a simple course, using the New Course Setting Project Wizard and the Compose Course tool.

Relay Courses

Learn all about Relays on the Create Relay Courses page.

Sprint Relay

For a Sprint Relay with four different legs, you have to create only one course with different Leg Variation and Team Variation.

  • Open a new [Course Setting File], load your [Map File] as a Background Map.
  • Go to the Course Setting Menu -> Courses and add a new Course. Choose Relay as Course type and enter the number of legs (typically 4 for Sprint Relays).
  • Add controls to your project and choose your Course afterwards in the Course Box.
  • Insert a Team Variation: Each runner of the team gets a different variation, for example for the first control.
  • Insert a Leg Variation: A leg variation means that there is a variation of the legs within the same team. In a Sprint Relay, Women are running typically the 1st and 4th leg, whereas Men are running the 2nd and 3rd leg. To make the Men legs longer, use a Leg Variation.

Learn all about Relays in general on the Create Relay Courses page.

SprintRelay Example.png

SprintRelay Example2.png

Corridor

  • Open a new [Course Setting File] and load your [Map File] as a Background Map.
  • Choose New in the Symbol Menu and create a new Line Symbol.
- In the Mail Line tab, activate Course setting symbol: Marked route.
- In the Double Line tab, choose the desired width of the corridor (e.g. 4mm) and the border lines.

Corridor2.png Corridor1.png

  • Draw your corridor. Each corridor will appear as a Mared Route in the Course Setting Box. Insert the corridors in your course.

Corridor3.png

  • Edit your corridor in a next step.
- If needed, Cut overlapping parts.
- Insert additional vertices in sharp turns.

Corridor8.png

  • Cover the remaining parts with white.
- Use the White background (Symbol 760) to cover the remaining parts of the map.
- Activate Follow existing objects under Options> OCAD Preferences> Drawin and Editing to enable line following for double lines (hold the Ctrl button).
- Instead of using White background (Symbol 760) for covering, first define a new white color (Map>Colors>Add) and then create a new area symbol (Symbol>New>Area Symbol) where you use this color as Fill Color. Like this you can set the Opacity of the white color to e.g. 90%, so you are not completly lost when leaving the corridor.

Create new color and symbol for slightly transpartent background
Corridor with White background (Symbol 760) Corridor with transparent background

Reduce Map

  • Open your [Map File].
  • Select the symbols you want to hide in the Symbol Box and go to Symbol>Hide Object or simply press F4.
  • Save the map, load it as Background Map in your [Course Setting File] and set courses.

ReduceMap.png

Multitechnique

  • Open your [Map File].
  • Use the Crop funtion to differ which symbols you want to crop in which parts of your map. See an Animation how to use the Crop funktionCrop.

Multitechnique1.PNG

In the following example, we used the yellow and green areas as Crop Objects. In the yellow part, all paths and roads were cropped. In the green area, all terrain objects. You can use the Crop funktion as often as you like in the same [Map File].

Multitechnique2.PNG

Multitechnique3.PNG

  • Save the map, load it as Background Map in your [Course Setting File] and set courses.

Island O

  • Open your [Map File].
  • Draw an area object over your map and Cut Holes in it. In this example, we use a green area symbol.

Island1.PNG

  • We select the green area symbol and use the Crop function to crop everything except the holes.

Island2.PNG Island3.PNG

  • Save the map, load it as Background Map in your [Course Setting File] and set courses.

Puzzle O

  • Open a new [Course Setting File], load your [Map File] as a Background Map and set a course.
  • Export your course as a Course Map under Course Setting>Export>Export Course Maps.
  • Reopen your Course Map. Go to File>Open Recently Exported Documents.
  • In a first step remove the Background Map (Background Map>Manage>Remove) and in a second step import the Background Map (File>Import). Import all symbols and colors and Import colors at the bottom of the color table.

ImportOcadMap.png ExportedCourse.PNG

  • Export a Map Extract for each control (Map>Export Part of Map).
  • Open a new [Course Setting File] for the final Layout.
  • Import all Map Extracts one by one in the new [Course Setting File] and place them using the mouse (File>Import). Again, import all symbols and colors and Import colors at the bottom of the color table.
  • Edit each Map Extract manually in the new [Course Setting File].

Hint.jpg The imported symbols are protected by default, so it's not possible to move them after the first placement. Select the symbols in the symbol box and set their status to Normal (F2) to move them around.
Hint.jpg A map flip at every control increases the difficulty. Arrange the Map Extracts in the Layout [Course Setting File] in a way, that you can print the odd numbers on the front and the even numbers on the back side of a map. CourseSettingFileLayout.PNG FileFolderPuzzleO.PNG

Map Change

Let's assume we add only one Map Exchange.

Print Course on two Maps

  • Open a new [Course Setting File], load your [Map File] as a Background Map and set a course.
  • Insert a Map Change into your course. A map exchange can be placed after a control (which is indicated with 0m to the next start in the control description) or after a Marked Route (the length of the marked route appears in the control description). Add a Start symbol after the map exchange.
  • When you print or export your map, two maps will be printed/ exported. The start on the second map is indicated with a Start symbol.

Print Course on one Map

  • Modify your [Map File] first. Crop the part you will use for your course and Duplicate it. Insert a Registration Mark (Symbol 602 in ISOM 2017) into your map before you duplicate it.
  • Save the modified [Map File] under a new name, e.g. [Map File - Layout].
  • Open a new [Course Setting File], load your [Map File - Layout] as a Background Map.
  • Set a course with a Map Change. Only use one map extract for course setting. Put a Registration Mark (Symbol 750 in ISCD 2018) at the same place as the Registartion Mark of your [Map File - Layout].

MapChange1.PNG MapChange3.png

  • Export Course Maps under Course Setting>Export>Export Course Maps.
  • Open both course maps. Copy the course objects from one file and insert them into the other. Use the Registration Marks for adjustment.

MapChange2.png

  • Modify your course where needed and save your [Course Setting File] under a new name, e.g. [Course Setting File -Final].

MapChange4.png

Hint.jpg As a different workaround, you could proceed like in the Puzzle-O above. You don't modify your [Map File], but import it into both Course Maps, where you export Map Extracts for the [Course Setting File -Final].

Score O

See the Score Orienteering page for more information.

ScoreO.PNG