Change to Polyline and Change to Bezier Curve

From OCAD 12 Wiki - English
Revision as of 11:52, 2 December 2016 by KLH (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Change to Polyline Space.PNGThis function is available in OCAD Professional.This function is available in OCAD Orienteering.

change to polyline

You can find this function in the Object menu or by clicking the Icon ChangeToPolyline.png Change to Polyline button in the Edit Functions Toolbar. This function is available when a line, area or line text object is selected.

Choose this function to change a line into a polyline. A polyline is an angular line, this means all Bezier vertices are replaced with regular vertices.


Define the Smooth tolerance in the menu Options - OCAD Preferences - category Drawing and Editing.

Change to Bezier Curve Space.PNGThis function is available in OCAD Professional.This function is available in OCAD Orienteering.This function is available in OCAD Starter.

change to bezier curve

You can find this function in the Object menu or by clicking the Icon ChangeToBezierCurve.PNG Change to Bezier Curve button in the Edit Functions Toolbar. This opens a dialog and is available when a line, area or line text object is selected.

PolylinetoCurve.PNG

Choose this command to convert the selected polylines to Bezier curves. The quality of the Bezier curve depends on the number of vertices of the original polylines and the tangent length factor. If the polyline has only a few vertices the distance from the Bezier curve to the original polyline between the vertices can be much bigger than the tolerance value. The closer the tangent length factor gets to zero, the more points are left and the curve looks more like the polyline.

PolylineTangent length factor = 1Tangent length factor = 0.5

hintThe Convert polyline to curve dialog is not shown if the Shift key is pressed while clicking Change to Bezier Curve button in the toolbar.
hintIf a hole inside an area object is selected, only the border of the hole is converted.



Change To Bezier Example.PNG

Define the Change to Bezier curve tolerance in the menu Options - OCAD Preferences - category Drawing and Editing.


Back to the Edit Object page.