OCAD Preferences

From OCAD 12 Wiki - English
Jump to: navigation, search

This function is available in OCAD Professional.This function is available in OCAD Orienteering.This function is available in OCAD Starter.This function is available in OCAD Course Setting.

Some preferences are not available in the OCAD 12 Starter and OCAD 12 Course Setting editions.

GUI (Graphical User Interface)

Context menu in drawing area

If enabled, the context menu is shown by clicking on the drawing area with the right mouse button.

ContextMenu.png

In the upper part of the Context menu, you can switch between the current Drawing Mode, the Icon SelectAndEditObject.PNG Select and Edit Object mode and the Icon SelectObjectAndEditVertex.PNG Select Object and Edit Vertex mode.
In the lower part of the Context menu, you can change the view either with the Icon Pan.PNG Pan, Icon ZoomIn.PNG Zoom In, Icon ZoomOut.PNG Zoom Out or the Icon ShowEntireMap.PNG Show Entire Map tool.

If disabled, you can switch between the current Drawing Mode and the Icon SelectObjectAndEditVertex.PNG Select Object and Edit Vertex mode by clicking on the drawing area with the right mouse button.

Right mouse click change between drawing and editing

This option is only activated if the Context menu in drawing area option is deactivated.

We recommend to deactivate this option when drawing on a tablet with a pen. In this case OCAD ignores the right click during drawing.

Wider splitter between drawing area and symbol box

If this option is enabled, the splitter between the symbol box and the drawing area appears wider as usual. This feature may improve the user-friendliness.
WiderSplitter.PNG

Toolbars

Show or Hide the following toolbars in this field:

Click the Customize button to add or remove icons to/from the toolbars.

Status bar

Choose the format of the coordinates appearing in the Status Bar in this box.
StatusBarSettings.PNG

Style

Change the virtual appearance of the GUI by choosing one in the dropdown list.

File

Auto file load when opening OCAD

Check this box to load the last map you worked on automatically when OCAD is started. Otherwise no map will be loaded.

Auto file save

This option is not enabled when a map is loaded. Please close all maps before opening OCAD Preferences.

Check this box to save all changes to the original file automatically.
When this box is not checked, all changes are saved in a temporary file. When you close the file you will be asked if you want to save the changes to the original file.
This option has no effect for untitled files (new files which have never been saved to disk).

Hint.jpg In the mode of permanent automatic saving, the file is considered as "read only". If you want to save it, you are re-directed to the Save as procedure requesting a new name for the file.

Clear file history

Click this button to clear the file history from Recently Exported Documents and Recently Used OCAD Files. If a drive from the file history files does not exist anymore, e.g. disconnected network drives, it may needs more time to open the File menu. This function solves the problem.

Temporary OCAD Folder

While working on an open file OCAD is saving all changes to temporary file(s) in a tmp folder. This folder can be changed here. As an example for Win 7 it is C:\Users\[USERNAME]\AppData\Roaming\OCAD\tmp by default.

Ghostscript File Path

OCAD using Ghostscript to converting a pdf background map to a jpg file when opening the pdf file.

Download and install Ghostscript.

Click the Choose button to set the file path of the Ghostscript exe file (e.g. C:\Program Files (x86)\gs\gs9.08\bin\gswin32.exe).

View

User defined zoom in menu item

Enter a value to specify the User Defined Zoom. Choose User Defined in the View menu to apply the specified zoom to the map.

View mode loop

With the View mode loop tool you can easily switch between different view modes. Select the view modes you want to switch between in the View mode loop box in the View category of OCAD Preferences.
To use the View mode loop you have to define a Shortcut for View - View Mode Loop. Afterwards you can switch between the set view modes using the Shortcut.

Visit the View Mode Loop article to get more information about this function.

Color Correction

On some monitors colors and gamma of the map are not displayed correctly. Use the controller to regulate the color and gamma manually. Click on the Standard button to set the Color Correction back to default.

Redraw background automatically

If this option is enabled, the map is redrawn after every single modification of the map (This may reduce the performance of OCAD). Otherwise you have to press the F5 key or select Redraw in the View menu to redraw the map.

RedrawBackgroundAutomatically.PNG

Faster text rendering

Enable the Faster text rendering option to render text faster and less precisely. This may increase the performance of OCAD.

FasterTextRendering.PNG

Screen Grid

OCADPreferencesScreenGrid.PNG

In this section of the OCAD Preferences the color and the appearance of the Screen Grid can be changed.

Change the Color by clicking the Icon Setup.PNG Setup icon.

Click the Default button to reload the default gray color.

Choose a Style from the dropdown menu. The Screen Grid can either be Solid, Dashed or Dotted.

Select

You can choose between two modes to select multiple objects:

  • All objects must be with at least one vertex in the selection.
  • All objects must be completely in the selection.
Two options to select multiple objects: All objects with at least one vertex in the selection or all objects completely in the selection

You can find more information about selecting multiple objects on this page: Select and Edit Multiple Objects.

Object

Object stretching

If this option is activated, you are able to stretch objects in the Icon SelectAndEditObject.PNG Select and Edit Object mode.
You can find more about stretching objects on this page: Select and Edit Object.

Unsymbolized objects

Choose a color for Unsymbolized Objects by clicking on the Setup Icon Setup.PNG icon. The Color Picker dialog appears and you can configure the color.

Drawing and Editing

Drawing Bézier curves

Choose the preferred mode for drawing curves.

  • In OCAD mode, only the direction of a dragged tangent is used. The distance from the normal vertices to the curve vertices is calculated automatically. This is the recommended mode.
  • In Illustrator mode, the length of the dragged tangent is used to calculate the distance of the curve vertex.

You can find more about drawing curves on the following page: Draw a Curve.

Curve mode: Change to straight line mode when clicking in drawing area

Check this box to draw straight lines also in curve mode. See more in Change to Straight Line Mode

Convert freehand to curve when drawing

Check this box to convert lines and areas to curves when drawing in freehand mode. Otherwise they remain as polygons. The settings made in the Smooth when drawing freehand dropdown list of the Tolerances field determine the smoothing level.
Freehand To Curve.PNG

Close area objects when drawing

OCAD closes area objects automatically if this option is checked. If the start and end point are different, OCAD adds an end point with the same position as the start point.

Choose Close Area Objects in the Topology part of the Object menu to close already drawn area objects.
Close Area Objects When Drawing.PNG

Move closed start and end points of line and area objects together

When this option is switched on, and the start and end points of a line or area object coincide (the line is closed), they are moved together during editing. If you move the start point, then the end point will also move.

Join affects all line symbols in symbol group

When this option is switched on then OCAD joins the ends of selected line objects that are in the same symbol group (symbol tree). Otherwise only if the line objects have the same symbol.

The option affects the Icon Join.PNG Join function and Icon AutomaticJoining.PNG Automatic Joining during drawing.

Following existing objects

Uncheck the Side lines of double lines option if side lines of double lines should not be traced when you are following existing lines. You can find more about this topic on the Following Existing Objects page.
Side Lines Of Double Lines.PNG

video available Following existing objects

Tolerances

  • Select objects: This tolerance defines the maximum distance on each side of a thin line where you can click to select it. Objects with a thicker main line than the tolerance level can be selected by clicking on the entire line width. The default value is 3 pixels.
Hint.jpg This tolerance is further used in multiple tools like Cut lines, Cut areas, Following existing objects, Reshape, Add Vertex, Remove Vertex, Change Vertex Type.
  • Snapping: If you activate the Snapping tool, moving a vertex close to an objects has a snapping effect. This tolerance defines the maximum distance you have to approach to the object, so that the vertex snaps to it. The default value is 5 pixels.
video available [Snapping]
  • Join when drawing lines: This tolerance defines the maximum distance a vertex has to approach to another line end to join it. The default value is 0.25 mm. If the line width is bigger than this tolerance then OCAD takes the line width as the tolerance. This tolerance is used for lines and areas
Joining Lines.PNG
  • Merge lines: This tolerance defines the maximum distance two line endes can be apart to still get merged.
  • Smooth when drawing freehand: There are three smoothing levels for freehand drawing mode: slightly, medium and strong. They correspond to 0, 1 and 2 in earlier OCAD versions.
Smoothing Levels.PNG
  • Change to Bezier curve: This tolerance defines the maximum distance the vertices can move away from the original position by changing from polyline to Bezier curve. The default value is 0.10 mm. Note that the distance between the curve and the polyline can be greater between the vertices.
Change To Bezier.PNG
  • Smooth (generalization): This tolerance is used by the Douglas-Peucker smoothing algorithm. Vertices that are closer to the direct line between the previous and the next vertex are removed. The default value is 0.05 mm.

This smooth tolerance is also used in the 'Change to Polyline' function.

Smooth.PNG

Cursor color

You can change the cursor color to black, red, blue, purple or yellow by selecting a color in the dropdown list.

Scale Cursor Size

Check this option to enlarge the cursor to the default size on high-DPI monitors with Windows 10 Creators Update.

Mark

Set the mark size to normal, large or very large.
Mark Size.PNG

Choose a mark color by clicking the Icon Setup.PNG Setup icon.
Mark Color.PNG

The mark color is used during drawing and to mark the selected objects.
Mark Color Drawing.PNG

The GPS cursor in GPS Real Time mode is also drawn with the choosen mark color.
Mark Color GpsCursor.PNG

Hint.jpg OCAD uses the choosen mark color only on white background. Otherwise OCAD choose a color with high contrast to the background color.
Mark Color HighContrast.PNG

Enable live preview

Enable this option to show the real line width when drawing line objects.

Auto scroll

Check this option if the map view should automatically scroll if you drag out of the drawing area. Disable Auto scroll if you have a slow PC.

Symbol

Default symbol folder

You can change the default symbol folder by clicking on the Icon Setup.PNG Browse icon. Choose a folder as default symbol folder which you want to load symbols from when you create a new map. Click on the Icon Delete2.PNG Delete icon to clear the current folder path. If no folder is selected, OCAD loads symbols from the Symbol folder in the OCAD program directory (usually: C:\Program Files\OCAD\OCAD 12\Symbol\) when you want to create a new map.

Symbol

  • Selected symbol blinks in symbol box: If you check this option, the selected symbol blinks in the symbol box. This makes it easier to recognize the selected symbol.
  • Lock symbol positions in symbol box: If you check this option, you are not able to drag and drop a symbol to a new position in the symbol box.
  • Auto select symbol when selecting object: If you check this option, the corresponding symbol is automatically selected when you select an object. This does not work when you select multiple objects.
  • Change to drawing mode when selecting a symbol: If you check this option, OCAD change to a drawing mode when selecting a symbol in the symbol box. If the symbol has a preffered drawing mode then OCAD change to this drawing mode.
  • Set symbol status visible when changing to Protected: Check this option if you prefer to have the same behaviour as in earlier OCAD versions. In this case OCAD always sets the symbol status Visible when changing to Protected.

GPS

GPS Log File

Check the Log all positions sent from gps option to save all position sent from a GPS device in real time to a log file (Text-File). Click the Icon Setup.PNG Browse icon to choose a folder, the log files are saved to. The log files are named with the date and time the real time GPS is enabled.

Warnings

Warnings for hidden symbols

These warnings can be activated when you either print, export or import a map. If you check those options, you will get a warning message if you have hidden symbols on the map and you are trying to carry out one of mentioned operations.

Moving warnings

Enable the Move multiple objects option to get a warning message when you move multiple objects. Use this option in order to guard against moving multiple objects accidentally.

Database warnings

Check these options to show Database Compatibility warnings about 32/64bit and dBase.

General

Updater

Disable the option Check for Service Updates when you start OCAD to not check for new free Service Updates when you start OCAD. Is some cases this check takes too long.

Known bugs are corrected in Service Updates. Therefore we recommend using OCAD software always with the most recent Service Update to benefit from the quality improvements. The latest Service Update is also available on our website in the Download section.

OCAD Blog

If this option is activated, new OCAD blog posts are shown when you start OCAD.