XML Script WMTS Export: Difference between revisions
Jump to navigation
Jump to search
No edit summary |
No edit summary |
||
| Line 12: | Line 12: | ||
<ExportPath>S:\O Map ZG\13_Leaflet\</ExportPath> | <ExportPath>S:\O Map ZG\13_Leaflet\</ExportPath> | ||
<Format>Leaflet</Format> | <Format>Leaflet</Format> | ||
< | <TileExtent> | ||
< | <EastingMin>2480000</EastingMin> | ||
< | <EastingMax>2825000</EastingMax> | ||
< | <NorthingMin>1075000</NorthingMin> | ||
< | <NorthingMax>1300000</NorthingMax> | ||
< | </TileExtent> | ||
< | <MapExtent> | ||
</ | <EastingMin>2590000</EastingMin> | ||
<EastingMax>2640000</EastingMax> | |||
<NorthingMin>1240000</NorthingMin> | |||
<NorthingMax>1273000</NorthingMax> | |||
</MapExtent> | |||
<MinZoom>0</MinZoom> | <MinZoom>0</MinZoom> | ||
<MaxZoom> | <MaxZoom>10</MaxZoom> | ||
<PixelSize>0.25</PixelSize> | <PixelSize>0.25</PixelSize> | ||
<TileSize>1000</TileSize> | <TileSize>1000</TileSize> | ||
Revision as of 14:42, 6 August 2020
OCAD can export map tiles for Leaflet with XML Scirpt.
<?xml version="1.0" encoding="ISO-8859-1"?>
<OcadScript>
<File.Open>
<File>S:\O Map ZG\ZG.ocd</File>
</File.Open>
<File.ExportWmts>
<ExportPath>S:\O Map ZG\13_Leaflet\</ExportPath>
<Format>Leaflet</Format>
<TileExtent>
<EastingMin>2480000</EastingMin>
<EastingMax>2825000</EastingMax>
<NorthingMin>1075000</NorthingMin>
<NorthingMax>1300000</NorthingMax>
</TileExtent>
<MapExtent>
<EastingMin>2590000</EastingMin>
<EastingMax>2640000</EastingMax>
<NorthingMin>1240000</NorthingMin>
<NorthingMax>1273000</NorthingMax>
</MapExtent>
<MinZoom>0</MinZoom>
<MaxZoom>10</MaxZoom>
<PixelSize>0.25</PixelSize>
<TileSize>1000</TileSize>
</File.ExportWmts>
<File.Save>
<Enabled>false</Enabled>
</File.Save>
<File.Close>
<Enabled>true</Enabled>
</File.Close>
</OcadScript>
OCAD Tiles displayed in Leaflet.
