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This document was produced for an OCAD Course Setting workshop.
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1 About OCAD
1.1

OCAD Editions

OCAD Mapping Solution

OCAD Mapping Solution is the OCAD edition to create topographic
maps, city maps, etc. The course setting functions are also included.

OCAD Orienteering

OCAD Orienteering is the OCAD edition to draw orienteering maps. The
course setting functions are also included.

OCAD Starter

OCAD Starter is the OCAD edition to draw maps, but with reduced
functions. The course setting functions are also included.

OCAD Course Setting

OCAD Course Setting is the OCAD edition for course setters. In the
edition are the complete course setting functions, but no function to
draw or edit orienteering maps.

OCAD Trial

OCAD Trial can be downloaded as a 21 days test version. This edition
includes all functions of OCAD Mapping Solution. However, OCAD Trial
has limited Course Setting functions.

OCAD Viewer

OCAD Viewer is a free OCAD edition to view, print and export OCAD
maps as well as OCAD course setting projects. No editing of maps and
courses is permitted.

Conclusion: You can set courses in OCAD Mapping Solution, Orienteering, Starter and Course Setting.
On the other hand, you can draw maps only in OCAD Mapping Solution, Orienteering and Starter.
OCAD Orienteering and OCAD Mapping Solution exists as a 32bit and 64bit version. Open the 32bit
version for Course Setting.

1.2

OCAD User Interface

Fig. 1: OCAD User Interface for course setting.

Copyright © 1988 – 2019 OCAD AG

page 5

Getting Started with Course Setting in OCAD

1.3

OCAD Help

OCAD Help
For help, go to the Help Menu, press the Help
button in the dialogs or the F1 key.
The Help menu includes following topics:
Contents:
Opens the OCAD Main Page.
Menu:
Opens the OCAD Wiki Menu Page.
Toolbar:
Opens the OCAD Wiki Toolbar Page.
Tutorials:
Opens the OCAD Wiki Tutorials Page.
What’s New:
See the newly added functions.
OCAD Homepage:
Open the OCAD Homepage.
OCAD Service Update:
See next chapter 1.3.
OCAD Learn Videos:
Opens the OCAD YouTube Channel with Learn
Videos.
Getting Started with OCAD: PDF in many
different languages, in which the OCAD basic
functions are described and on which this
document is based.
OCAD Blog:
Opens the OCAD Blog.
License Transfer Utility:
Opens the License Transfer Utility to transfer you
license to other people.
License Manager:
The License Manager tool shows an overview
about the OCAD licenses which are assigned to
your organization (company or association).
About OCAD:
See your license information and current version
of OCAD.

1.4

Service Update

The service updates correct minor problems and add the latest cartography tools and enhancements
to your OCAD. It is strongly recommended to keep your OCAD up to date and install the newest
Service Update.
Click on the OCAD Service Update function in the Help menu to download it.
OCAD has to be closed for installing the Service Update.
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2 Course Setting Project
For a Course Setting Project, you need two OCAD files:
- A [Course Setting File]
This is the file where manage your Course Setting Project, set courses and load a Background Map.
Like map files it has the extension .ocd, but it has a special internal mark to identify it as a course
setting file.
- A [Map File]
This is your OCAD map which will be loaded as Background Map in your [Course Setting File].

To start a New Course Setting Project, you must create a new [Course Setting File].
You have two options to do so:

2.1

A) New Course Setting Project Wizard

Choose this command from the File menu to
create a new course setting project.

This wizard guides you through the first steps
like setting an event title and loading a map
file in the background layer.

2.2

B) Start a New Course Setting Project

To start a New Course Setting Project, you
must create a new [Course Setting File].
File → New…
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Dialog New File
Map type:
orienteering

Course

setting

project

for

In the OCAD Course Setting edition there
is no other map type. The map type is here
always Course setting project for orienteering.
Load symbol set from:
Choose for a course setting in scale 1:10'000:

→ Course setting 10 000 ISCD 2018 – ISOM
2017
→ OK

2.3

Save the Course Setting Project

File → Save
Dialog Save As:
Save the Course Setting project.
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3 Open an Orienteering Map as a Background Map
Background Map → Open…
The Open Background map dialog appears.
Choose your [Map File], which is normally an
orienteering map.
→Open

The scale for the Course Setting Project (Map → Set Scale and Coordinate System) has to been
the same as the scale of the orienteering map, so that the length of the courses is correct.
When a georeferenced orienteering map is opened as a background map, the coordinates will
be used for the course setting project.
To see information to the loaded background map in the dialog Manage Background Maps
(Background Map → Manage…), click on the Info button in the last column

Encrypted OCAD files (*.eocd) or raster files (*.bmp, *.tif, *.jpg, *.gif, *.png) can also be used as
background maps for Course Setting.
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4 Courses and Classes
In OCAD you can either work with courses only or you can use classes and courses. Different classes
may use the same course, e.g. Course A -> Class W18, W16, M16; Course B -> ClassW14, M14, Open
Short.
If you have two Classes (e.g. Women Elite and Women 20) and both have the same Course, it is a
common mistake to name the Course “WE, W20” and not to create any Classes. You will get troubles
with your timing software this way.
Instead you can still name the Course “WE, W20” (or simple name it “A”), but you need to create two
Classes (“WE” and “W20”) and allocate the same Course to both of them.

4.1

Create a New Course

Menu Course Setting →
Courses or just click on
Add in the Course box.

Dialog Courses
→ Click the Add button
to create a new course
→ Enter a Course name
in the first column
→ Define the Course
type

→ OK

If every class has its own course, it is easier to name the course like the class name.
The course and class name shouldn’t contain any other special sign, except the underline
character otherwise there can be problems with the transfer of the course data in the result software.
Later – when the course is set – there can be insert information like the additional length and the
climb.
When many and similar courses has to be set it is recommended to duplicate the existing course
and modify it.
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4.2

Create a New Class

Course Setting → Classes

Dialog Classes
→Click the Add button
to create a new class
→ Enter a name in the
Class column
→ Assign a course

→ OK

If every class has its own course, choose the option Create classes automatically in the dialog.
Optionally you can define the estimated number of runners and the start number range allocated
to this class. This number of runners is used for the course statistic.
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5 Compose Course
The Compose Course tool is a very easy and intuitive tool to set and edit courses. It’s available from
version 18.2.2. onwards.
However, the following chapters Add Courses Objects (Controls etc.) on the Map and Define and Edit
Course go deeper into Course Setting.

5.1

Compose a new Course

Choose the Compose course tool from
the toolbar.
When you click on the Compose course
tool, but no Course has been defined so
far, OCAD will add a course
automatically. Enter the name and click
OK.
If there are already Courses defined, but
you have not chosen one in the Course
List, a window appears where you can
select a course.

Compose the course by clicking in the
drawing area. First click adds a start
object, each additional click adds a
control point and double click adds a
finish object to the map and the course.

5.2

Modify an existing course

Insert controls into the course
-

Choose the Compose course tool from the toolbar.

-

Initialize the Insert mode with entering and leaving a
control circle with the mouse.

-

Once the insert mode is initialized each click inserts a
control point.

-

Use ESC key to exit the insert mode.

Remove controls from the course
Use CTRL key + Click on a control to remove a control from the course.
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Move a control point
-

Enter a control circle with the mouse.

-

Press the left mouse key and drag the control point to the new position

Leave the left mouse key.
Limitations
The Compose course tool is not working for variations in Relay Courses.

5.3

Course Setting Objects Toolbar

Beside the Compose course tool, there are the most common
Course Setting Symbols in the Toolbar. Click on one of them
and a Drawing Mode is activated automatically.
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6 Add Courses Objects (Controls etc.) on the Map
6.1

Start

Select the Start symbol on the left hand in the symbol
box.

Select any drawing mode in the toolbar.
Click in the drawing area to place the object on the map.
The dialog Course Object appears. As Code is S1
suggested.
As required you can enter different code (e.g. S2)

→ OK

In the course setting box you can enter the text
and/or symbolic control description.

6.2

Control

Select the Control symbol in the symbol box.

Select a drawing mode and place the object on the map.
The Course Object dialog appears. As Code is a
number (e.g. 31) suggested.
As required you can enter different code.

→ OK
In the course setting box you can enter the text
and/or symbolic control description.
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6.3

Finish

Select the Finish symbol in the symbol box.

Select a drawing mode and place the finish object on the map.
The Course Object dialog appears. As Code is F1
suggested.
As required you can enter different code.

→ OK
For the finish it isn’t possible to define a control description.
The description of the route to the finish is inserted as a marked route from the last control to the
finish.

6.4

Marked Route

Select the Marked Route symbol in the symbol box.

Select any drawing mode in the toolbar.
Draw the marked route in running direction on the map.
The Course Object dialog appears. As Code is M1
suggested.
As required you can enter different code.

→ OK
Text Control Description
Insert a text control description box of the marked route in the course setting.
Use a semicolon as place holder for the distance to the finish.
E.g.
This is illustrated in the text control description:

Symbolic Control Description
Here you can check or uncheck the Funnel tapes:
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→

→

6.5

Course Title

Select the Course Title symbol in the symbol box.

Select a drawing mode and place the object on the map.
The Course Object dialog appears. As Code is N1
suggested.
As required you can enter different code.

→ OK
The object is shown on the map with the text “course”. This text is replaced in the course preview, at
printing and exporting with the name of the course.

6.6

Control Description

Select the Course Title symbol in the symbol box.

Select a drawing mode and place the object on the map.
The Course Object dialog appears. As Code is D1
suggested.
As required you can enter different code.

→ OK
Choose in the course setting box the control
description type: Symbol or Text
Choose in the course setting box the control
description anchor: Top left or Bottom left
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7 Edit Course Setting Objects
7.1

Delete Course Setting Objects

Select the Select and Edit Object(s) icon in the
toolbar.
Click on the object on the map.
Press the Delete key or click the button

7.2

.

Move Course Setting Objects

Select the Select and Edit Object(s) icon in the
toolbar.
Click on the object on the map and move it with the
pressed left mouse button to the new position.
Release the mouse button.
Don’t forget to update the changed control
description!

7.3

Change Code

Choose the course setting object in the list of course
setting objects.

→ Change code…
Enter a new unused code.

7.4

Cut a Control Circle

Select the Select and Edit Object(s) icon in the
toolbar.
Click on the control on the map.
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Select the Cut icon in the toolbar.
Click there where the gap starts and move it with
the pressed left mouse button to the end of the gap.
Release the left mouse button.

To close an already cut control circle, choose the Cut tool and click once in the gap.

7.5

Edit Lines or Area (e.g. Marked Route or Out-Of-Bounds Area)

Select the Select Objects and Edit Vertex icon in
the toolbar.
Click on the line or area object.
Move a vertex with the pressed left mouse button.

Add vertex to an existing object:
Select the Normal Vertex icon in the toolbar and
click on the favored position in the object to set a
new vertex.
Instead of selecting the Normal Vertex icon,
you can press the Shift and Ctrl key simultaneously
and click with the left mouse button.
If there are too many vertexes:
Select the Remove Vertex icon in the toolbar and
click on the vertex, that you want to delete.
Instead of selecting the Remove Vertex icon,
you can press the Ctrl key and click with the left
mouse button.
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8 Define and Edit Course
8.1

Define Course

Choose a course in the course setting box.

Add the Start, Controls, Marked Route(s) and Finish to the course in List of course setting objects:
the favored order. There are two possibilities:
A) Double click on the course setting object in the list of course
setting objects
B) Double click on the course setting object on the map
After adding a course setting objects the length of the course is updated.
Start, finish and marked routes have to be added separately to each course.
You can also use the Insert Course Object into Courses function (Course Setting menu).

8.2

Show Course Preview

Click on the Preview button

in the course setting box to show the course preview.

In the Preview Mode are various functions of OCAD inactive!

8.3

Insert Course Setting Objects later

Click on the correct position in the course, where the course
setting object should be insert.
A horizontal blue line shows, where the course setting object is
insert.

To insert the course setting object double click on the course setting object in the object list or on the
map.

8.4

Delete Course Object from Courses

Click on the code, that should be deleted. The number is marked
blue.
Press the Delete key to delete the course setting object from the list
of course setting objects.
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8.5

Edit Courses in the Preview Mode

The below-mentioned steps can be only done in the preview mode.

8.5.1

Move Control Numbers

Select the Select and Edit Object(s) icon in the toolbar.

Click on the control number.
Click on the little square in the left bottom with the
mouse, press the left mouse button and move the
control number in the desired place. Release the mouse
button.
The movement is only for the preview mode shown
course, except you use the function Move Control
Number for all courses.
When you move the control number there is a thin
light blue connecting line between the control circle
and the control number.

8.5.2

Cut the Connecting Line

Select the Select Objects and Edit Vertex icon in the
toolbar.
Click on the connecting line.

Select the Cut icon in the toolbar.
Click where the gap starts on the connecting line and
move the cursor with the pressed left mouse button to
the end of the gap
The gap is only for the chosen course. Use the
function Edit Connecting Line for all Courses to cut all
courses.
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9 Course Options
Course Setting → Options…
The Course Options dialog appears:

Here can be changed various options.
Graphical Help
The various options are explained with graphical help. Click on the question mark on the right-hand
side of the options.
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10 Colors and Symbols
10.1 Colors
In the Colors dialog (Map → Colors…) you can manage the colors of the symbols. You shouldn’t
change something in the list, when you don’t know what you are doing.
The order of the colors in the color list regulates the overlaying: a color covers at the printing all the
colors that are below.
The actual ISOM Symbol Sets of OCAD contains the latest CMYK color value. However, they may
change from time to time. The latest CMYK color values can be found under
https://orienteering.org/resources/mapping/

10.2 Symbols
The latest symbol set for Course Setting is ISCD 2018 – ISOM 2017 for forest maps and ISCD 2018 –
ISprOM 2019 for sprint maps (ISCD = International Specification for Control Descriptions).
The symbol sets are also delivered for Ski and Bike orienteering.

Copyright © 1988 – 2019 OCAD AG

page 22

Getting Started with Course Setting in OCAD

11 Print and Export
11.1 Print Map and Courses
Course Setting → Print → Courses

Printer: Choose printer and set options like the highest print quality
Page handling: Set Portrait or Landscape
Copies: Specify a number of copies
Print scale: Choose or enter the print scale
Print map size: Entire map, Part of map or One page; position the printing range in the drawing
area
Options: Intensity, Line width and Screen grid
Select Courses/Classes: Choose Courses or Classes that should be printed.

→ Print: Print file and save settings
→ Close: Close dialog and save settings
→ Cancel: Close dialog doesn’t save changed settings

Due to color display, we recommend you to always create a PDF first out of OCAD and print
this PDF afterwards.
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11.2 Export Map and Course as PDF
File → Export…

Choose PDF as Export format
Part of map: Random rectangle or a standard paper format
Export scale: Choose export scale
CMYK(process) colors: Select
Compress file: Check this option to reduce the pdf file size

→ Export: Export file and save option
→ Close: Close dialog and save settings
→ Cancel: Close dialog doesn’t save changed settings

Due to color display, we recommend you to always create a PDF first out of OCAD and print
this PDF afterwards.
The Select Courses/Classes dialog appears.
Choose Courses or Classes

→ OK

11.3 Print Control Descriptions
Course Setting → Print → Control Descriptions
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The Print Control Description dialog appears.
Printer: Choose printer and set options
Symbolic/Text control description: Choose symbolic or text
control description to print
Box size: Specify the size of the control description field
(standard = 6mm)
Copies: Specify the number of control descriptions
If you enter more than 1 copy, OCAD will fill entire pages
with the same course until the number of copies is reached.
Therefore, if you enter "2" you will get one page per course
filled with as many control descriptions as possible of that
course.
Select Courses/Classes: Choose courses or classes

→ OK
In Windows 10 it is possible to export the control description
in a pdf file. Choose the Microsoft Print to PDF as printer. A PDF
will be created when you click on OK.

11.4 Course Setting Export for the Result Software
Depending on the specification of the result software the definition of the course setting has to be
exported as an XML or text file:
a) Menu Course Setting → Export → Courses (XML IOF Version 2.0.3)…
Menu Course Setting → Export → Courses (XML IOF Version 3.0)…
or
b) Menu Course Setting → Export → Classes Version 8 (Text)…
a) XML IOF Version 2.0.3 /XML IOF Version 3.0
The Export Courses (XML) dialog appears.
Choose a folder and name it. → Save
b) Text File Version 8
The Export Classes Version 8 (Text) dialog appears.
Choose a folder and name it. → Save
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