Difference between revisions of "Graphical User Interface"

From OCAD 12 Wiki - English
Jump to: navigation, search
(Help Menu)
Line 412: Line 412:
 
: '''[[Graphical_User_Interface#Menu|Menu]]:''' Help for menu commands.
 
: '''[[Graphical_User_Interface#Menu|Menu]]:''' Help for menu commands.
 
: '''[[Graphical_User_Interface#Toolbars|Toolbar]]:''' Help for toolbar buttons.
 
: '''[[Graphical_User_Interface#Toolbars|Toolbar]]:''' Help for toolbar buttons.
 +
: '''[[Renewals]]:''' Click on this menu item to open the '''Renewals''' page.
 
: '''[http://www.ocad.com/en/ OCAD Home page]:''' Connect to the OCAD homepage on the Internet.
 
: '''[http://www.ocad.com/en/ OCAD Home page]:''' Connect to the OCAD homepage on the Internet.
 
: '''[http://www.ocad.com/en/downloads/ OCAD Update]:''' Connect to the OCAD download site on the Internet.
 
: '''[http://www.ocad.com/en/downloads/ OCAD Update]:''' Connect to the OCAD download site on the Internet.

Revision as of 14:14, 7 May 2012

GUI.JPG


Toolbars

The Toolbars can be moved within the graphical user interface. The buttons can be individually shown or hidden via the Options menu under OCAD Preferences, GUI (Graphical user Interface), Toolbars.

toolbars


Standard Toolbar

Standard Toolbar

new New: Create a new map.
open Open: Open an existing map.
save Save: Save changes made to the map.
print Print: Print out the map.
undo Undo: Undo previous actions.
redo Redo: Cancel the previous undo action.

Edit Functions Toolbar

Edit Functions Toolbar

find selected objects Find Selected Objects: Move screen to the selected object.
delete Delete: Delete the selected object(s).
Icon RotateEnterAngle.PNG Rotate (Enter Angle): Rotate selected object(s) by entering angle.
Icon AlignObjectsHorizontal.PNG Align Objects: Horizonal Coordinates
Icon AlignObjectsVertical.PNG Align Objects: Vertical Coordinates
Icon InterpolateObjects.PNG Interpolate Objects
duplicate object Duplicate Object: Create a copy of the selected objects.
fill or make border Fill or Make Border: Fill a line or area object(s) with area object(s) or make line border of area object(s).
merge Merge: Merge multiple line, area and text objects into one object.
reverse object Reverse Object: Reverse the direction of the selected line object(s)
Icon ChangeToPolyline.png Change to Polyline
change to Bézier curve Change To Bézier Curve: Convert the selected line or area object(s) drawn in freehand mode to curves.
convert to graphic object Convert To Graphic Object: Convert the selected object(s) to their graphic elements (lines and areas).
smooth Smooth
snapping Snapping
join Join: Move the ends of the selected line object to connect to adjoining objects.
change symbol of object Change Symbol of Object: The selected object is assigned to the symbol selected in the symbol box.
change symbol for all objects with this symbol Change Symbol For All Objects With This Symbol: Change the symbol of all objects with a symbol A to symbol B.
measure Measure: Measure the selected line or area object or the distance between 2 selected vertices objects.
automatic joining Automatic joining: Automatically join the ends of lines during the drawing process. The Join when drawing lines tolerance can be set in the OCAD Preferences. To switch off the automatic joining temporary during drawing, press the Shift key when terminating the line.
smoothing level Smoothing level: This option is used to select the required smoothing level for lines, for converting freehand lines into Bézier curves and for automatically smoothing lines drawn in freehand mode.

View Toolbar

View Toolbar

Various functions are available for increasing or reducing the size of map sections as well as repositioning them.

pan Pan: Reposition the map section
pan locked Pan locked: Reposition the map section a number of times in succession.
zoom in Zoom In: Increase the size of the map section.
zoom in locked Zoom in locked: Increase the size of the map section a number of times in succession.
zoom out Zoom Out: Reduce the size of the map section.
zoom out to previous view Zoom out to previous view: Return to last smaller map section.
zoom to previous view Zoom to previous view: Return to last map section.
zoom to next view Zoom to next view: Go to previous map section.
show entire map Show Entire Map: Display the entire map in the drawing window.
draft mode slider Draft mode slider: The upper slider (M for map) is used to fade out the map objects; the lower slider (B for background) to fade out the map background.The Draft mode slider is only visible if Draft Mode is active in the View menu.
show grid Show grid: Display the coordinate grid in the drawing window.

Editing and Drawing Toolbar

Edit and Drawing Toolbar

Edit modes

select and edit object Select and Edit Object: Select and move objects.
select object and edit vertex Select Object and Edit Vertex: Select objects or move points of objects.
normal vertex Normal Vertex: Add a vertex. This will not influence a dashed line.
corner vertex Corner Vertex: Add a corner vertex or turn a normal vertex into a dash vertex. This will affect the dashed line so that it will start with a full dash from this point and/or a symbol will appear in the corner vertex.
dash vertex Dash Vertex: Add a dash vertex or turn a normal vertex into a dash vertex. This will affect the dashed line, which will start with half a dash from this point.
remove vertex Remove Vertex
indicate direction of area pattern point or text object Indicate Direction of Area Pattern, Point or Text Object
rotate object Rotate Object: Rotate the selected object(s).
cut hole Cut hole: Cut a hole into the selected area object.
cut area Cut area: Cut the selected area object.
cut Cut: Cut the selected line object or the borderline of the selected double line or area.
video available Cutting
move parallel Move parallel: Move the selected line or area object parallel to the original object.
reshape Reshape: To shape (something) again or differently

Drawing modes

curve mode Curve mode: Draw in curve mode.
ellipse mode Ellipse mode: Draw elliptical (oval) objects.
circle mode Circle mode: Draw circular objects.
rectangular line mode Rectangular line mode: Draw rectangular line objects with any number of corners.
rectangular mode Rectangular mode: Draw rectangular area objects with any number of corners.
Stairway drawing mode Stairway drawing mode: Draw a rectangular stairway.
straight line mode Straight line mode: Draw objects with straight lines.
freehand mode Freehand mode: Draw objects in freehand mode.
drawing multiple point objects Drawing multiple point objects: Draw several point objects that are placed on a line with a constant interval.
Icon LaserDistance.PNG Laser distance drawing mode: Draw objects by distances transmitted from a laser distance meter.
numeric mode Numeric Mode: Draw objects in numeric mode.
numeric toolbar Numeric Toolbar

Server Toolbar

See here: Server Toolbar

Numeric Keypad Toolbar

Numeric Toolbar

ToDo

Mobile Toolbar

Mobile Toolbar

ToDo

Customize Toolbar Dialog Box

Choose this command to customize toolbars. The dialog box is opened by clicking Customize button in on GUI (Graphical User Interface) page in OCAD Preferences dialog box or by clicking on the right end of a toolbar. When the box above the button is checked the button will be visible otherwise it will be hidden.

CustomizeToolbars.png

hint The Numeric keypad toolbar cannot be customized.

Menu

The OCAD Professional Edition features the following 15 menus:

menu

  • File: File management, file import and export functions, printing
  • Server/Client: Functions for Server/Client
  • View: Functions for viewing the map
  • Select: Functions for selecting an object or a vertex
  • Object: Object editing functions
  • Symbol: Functions for creating and editing symbols
  • Map: Map editing functions
  • Layout: Function for layout managing
  • Database: Functions for connecting and editing databases
  • Background Map: Functions for loading and managing background maps
  • DEM: Functions for the import, export and evaluation of Digital Elevation Models
  • GPS: Functions for connecting GPS devices or importing GPS data
  • Options: Functions for customizing personal preferences
  • Window: Functions for arranging the map window
  • Help : OCAD Help


File Menu

New: Create a new map.
Open: Open an existing map file.
Open Sample Map: Open a sample map file.
Close: Close the current map file.
Save: Save changes in the current map file.
Save As: Save the current map file under a new name.
Undo: Undo the last draw or edit operation.
Redo: Reverse the effect of the Undo operation.
Print: Print a color map or color separations.
Import: Import a map file.
Export: Export the map in a different file format.
Export OCAD Internet Map: Export the map to OCAD Internet Map.
Export Encrypted File: Export the map to encrypted OCAD file format.
Send File by Email: Send current map file by email.
Execute XML Script: Execute function defined in a XML script file.
Create Backup: Make a backup copy of the current map file.
Restore Backup: Restore a map file saved with the Backup function.
Open Recently Exported Documents: Open one of the documents you have exported recently.
Open Recently Used OCAD Files: Open one of the map files you have worked on recently.
Exit OCAD: Terminate OCAD.

Server/Client Menu

Connect/Disconnect: Connect or disconnect the connection to the server
Get Objects from Current View
Import Map: Import a Map from the connected server
Delete Object in Database
Check Out Selected Objects: Check out selected objects for editing.
Check in Selected Objects: Check out selected objects after finished edited objects.
Show Checked Out Objects: Show current checked out objects.
Database Undo: Undo your last move in the database.
Database Redo: Redo your last move in the database.
Generate Map Preview Generate preview from current map.
Do Database Maintenance: Upkeep Database
Manage Server Bookmarks
Show Project Information

View Menu

Normal Mode: Normal mode view.
Spot Color Mode: Spot color view.
Draft Mode: Draft mode view. The background map can be seen behind the map.
Draft Mode Only Background Map Favorites: Map display transparent, background maps visible
Keyline: Shows a rough sketch, where objects has been placed .
Hatch Areas: Display full areas as hatched areas on the screen.
Anti-Aliasing: Anti-Aliasing view.
Redraw: Redraw the drawing window.
Pan: Move the view.
Move To: Move the view to a desired position.
Find Selected Objects: Find desired objects
Zoom In: Display the map with a higher magnification.
Zoom Out: Display a larger area of the map.
Zoom to Selected Objects: Move screen zoom to selected objects.
Show Entire Map: Display the entire map on the screen.
Zoom: Select the magnification in which the map is displayed.
User Defined: Choose this command to set view to a specified zoom factor.
Bookmarks: Create and manage bookmarks of view.
-Create: Create a new bookmark
-Manage: Manage available bookmarks
Show Screen Grid: A grey grid is shown in the drawing window.
Show Rulers: Shows up and down a ruler .
Ruler Guides: Show and manage ruler guides
-Show: Show vertically or horizontally ruler guide
-Manage: Add new ruler guide.

Select Menu

Select and Edit Object: Select, move or stretch object(s).
Select Object and Edit Vertex: Select or move vertex of object(s).
Select Objects by Symbol: Select all objects with same symbol .
Select Objects by Property: Select all objects with same properties.
Select All: Select all objects in map.
Clear Selection: Nothing is selected.
Invert Selection: Change current selection such that everything previously unselected will now be selected and vice versa
Select Next Object: Selects the next obvious object.
Save Selection: Save current selection for later use.
Reload Selection: Reload saved selection.
Edit Selection: Manage saved selection.
Select Group: Select a group of objects.

Object menu

Cut: Copy the selected object(s) to the clipboard and delete them in the current map.
Copy: Copy the selected object(s) to the clipboard.
Paste: Insert the object(s) in the clipboard into the current map.
Delete: Delete the selected object(s).
Rotate Object: Rotate object(s).
-Rotate: Rotate the selected object(s).
-Rotate Object by Angle: Rotate the selected point object(s) by specifying a rotation angle.
Align Objects: Align the selected objects horizontally or vertically.
-Horizontal Coordinate
-Vertical Coordinate
Indicate Direction of Area Pattern, Point or Text Object: Change direction of selected point object, area pattern or text.
Cut Objects: Cut hole, area or line.
-Cut hole: Cut a hole in an object.
-Cut area: Divides an area.
-Cut line: Divides a line.
Crop Objects: Crop selected Object(s).
Move Parallel: Move the selected line or area object parallel from the original object.
Move Parallel with Distance: Move the selected line or area object parallel with a distance from the original object.
Reshape: To shape a part of an object again or differently.
Interpolate Objects: Interpolate selected Objects to each other.
Duplicate: Duplicate (create a copy of) the selected object(s).
Move and Duplicate: Duplicate selected object and move it.
Mirror and Duplicate: Mirror selected object and duplicate it.
Fill, Make Border, Duplicate Identically: Fill a line or area object(s) with area object(s) or make line border of area object(s).
Merge: Merge multiple line, area and text objects into one object.
Reverse Object Direction: Reverse the direction of the selected line object(s).
Change to Polyline: Change selected object to polyline.
Change to Bézier Curve: Change selected object to a Bézier curve.
Convert to Graphic Object: Convert the selected object(s) to their graphic elements (lines and areas).
Convert to Layout Object: Convert selected object to layout object.
Smooth: Smooth selected line or area object(s) drawn in freehand mode.
Create Color Gradient
Topology
-Join: Move the ends of the selected line object to connect to adjoining objects.
-Select Duplicate Objects: Duplicate the selected object(s).
-Select Self-Intersected Objects
-Merge with Condition: Merge with conditions the selected objects into one object.
-Create Point Objects at Line Ends
-Close Area Objects
-Remove Overshoots and Undershoots
-Insert Intersections
Change Vertex Types to: Change vertex types for the selected object(s).
Change Symbol (Selected objects)
Change Symbol (All Objects with Corresponding Symbol)
Group
Ungroup
Find and Replace Text
Insert Glyphs: Insert special letters.
Measure: Measure the selected line or area object or the distance between 2 selected point objects
Object Information: Show information about selected object(s).

Symbol Menu

New: Create a new symbol.
Edit: Define or redefine the selected symbol.
Icon: Draw or edit the symbol's icon, which appears in the symbol box.
Enlarge/Reduce: Enlarge or reduce the selected symbol or all symbols.
Copy: Copy the selected symbol to the clipboard.
Paste: Copy a symbol from the clipboard to the current map.
Delete: Delete the selected symbol.
Duplicate: Make a copy of the selected symbol.
Sort Symbol Box: Sort the symbols in the symbol box.
-By Number: Sort symbol in symbol box by number.
-By Color: Sort symbol in symbol box by color.
-By Status (Normal, Protect or Hide): Sort symbol in symbol box by status.
Select: Select certain symbols in the symbol box.
-Used: Select used symbols in symbol box.
-Unused: Select unused symbols in symbol box.
-Invert: Change current selection such that everything previously unselected will now be and vice versa.
-All: Select all symbols in symbol box.
-By Color: Select all Symbols with same color.
-By Font: Select all Sybmols with same font.
Replace:
-Font
-Color
Normal: Make objects with the selected symbol(s) appear normal.
Protect: Make objects with the selected symbol(s) protected from editing.
Hide: Objects with the selected symbol(s) do not appear.
Show Unsymbolized Objects: Normal / Hide.
Show Graphic Objects: Normal / Hide.
Image Objects: Normal / Protect / Hide
-Normal: Selected Symbols are not protected and not hidden.
-Protect: Selected symbol(s) are visible but cannot be edited.
-Hide: Selected symbol(s) are not visible .
Show Symbol Favorites: Display the symbol favorites in symbol box.
Add To Favorites: Add the selected symbol(s) to symbol favorites.
Remove From Favorites: Remove the selected symbol(s) from symbol favorites.
Show Symbol Tree: Display the symbol tree in symbol box.
Remove From Symbol Tree: Remove the selected symbol(s) from symbol tree.

Map Menu

Optimize/Repair: Remove empty space in the map file and repair damaged objects.
Set Scale and Coordinate System: Set map scale and define the coordinate system.
Change Scale: Change the scale of the map and enlarge/reduce the map according to the new scale.
Create Map Grid: Create grid lines on the map.
Create WGS84 Grid: Create a WGS84 grid on your current view.
Hide: Hide the map on the screen.
Transform: Adjust the map to the background map.
-Move: Move the entire map to a different location in the coordinate system.
-Stretch / Shrink: Stretch (enlarge or reduce) the entire map horizontally or vertically.
-Mirror: Mirror the entire map horizontally or vertically.
-Rotate Map: Rotate the entire map.
-Change Coordinate System: Change current coordinate system to another.
-Affine: Adjust the whole map on background map or on grid.
-Rubbersheeting: Adjust a part of the map on a georeferenced background map.
-Center map to Drawing Area
Convert Imported Layers to Symbols: Convert the layers of an imported *.dxf or *.ai file.
Convert Area or Line Objects to Point Objects: Convert area to point object(s).
Convert Text Objects to Point Objects: Convert text to point object(s).
Convert Text Objects from OEM to Unicode: Convert text objects from OEM to Unicode.
Export Objects by Selected Symbol: Export all objects with a selected symbol to a new map file.
Export Selected Objects
Export Part of Map
Colors: Define or edit the colors of the current map.
Define Spot Colors: Define the spot colors of the current map.
Load Colors From: Load a color table from another map.
Load Colors and Symbols From: Load the symbol set from another map.
Compare Colors and Symbols: Compare two symbol sets.
Routing: Import kml file with route from Google Maps API
Map Information: Show map information.

Layout Menu

Edit Layout Objects: Draw and edit the layout objects.
Import Layout
Save Layout
Hide
Add North Arrow or Scale Bar
Add Map Legend
Add Trim and Bleed Marks
Create Graticule Name Index
Create Name Index

Database Menu

Manage Database Connections: Create and edit datasets.
Create and Update Records: Create OCAD objects out of the database.
Update Special Fields
Create Objects from Table: Create OCAD objects from database records.
Assign Symbols by Records
Add Texts by Records
Define Object Directions by Records: Assign angle information from the open dataset(s) to the objects.
Merge Objects by Records
Select Linked Objects with Corresponding Record
Select Linked Objects without Corresponding Record
Select Objects Linked to the same Record
Delete Database Record when Deleting Object: If the option is turned on and an OCAD object with a linked database record is deleted, the database record is deleted, too.
Create Database Record when Cutting Object

Background Map Menu

Scan: Scan a background map using a TWAIN interface.
-Acquire: Acquire a background map
-Select Source: Select source from which the background map acquire
Open: Open a scanned background map stored in a file.
Adjust: Adjust the background maps in horizontal and vertical directions.
Hide All: Hide the background maps temporarily.
Manage: Set options for displaying and printing the background maps.
WMS - Web Map Service: Add background map from WMS

DEM Menu

Import: Import an ASCII Grid or XYZ file to OCAD.
Open: Open an OCAD DEM file (*ocdDem).
Show Frame: Shows blue rectangle with the extent of loaded DEM.
Resize: Resize OCAD DEM file (make a subset) and save it as a new OCAD DEM file.
Info: Shows information about OCAD DEM file.
Close: Close OCAD DEM file.
Merge DEM: Merges two parts of a DEM together.
Calculate DEM Difference Calculates the difference between a surface and a terrain model.
Create Contour Lines: Calculates contour lines based on the loaded DEM.
Create Hypsometric Map: Calculates a grayscale or colored hypsometric map
Create Hill Shading: Calculates a shaded relief picture.
Calculate Slope Gradient Calculates a grayscale picture with slope gradient.
Classify Vegetation Height Calculates picture with vegetation height classes.
Create Profile: Creates a profile for the selected line object.
Export: Save loaded OCAD DEM file as ESRI ASCII Grid or as ASCII Grid XYZ.

GPS Menu

(This function is only available in OCAD Professional!)

Real Time GPS
Adjust Local GPS Position
Import Data from GPS Device
Import from File
Connect to Laser Distance Meter

Options Menu

OCAD Preferences: Options for your individual working methods.
Shortcuts: Define or change keyboard shortcuts for menu commands.
Backup and Restore Options
Language: Choose a language.

Window Menu

Tile: Arrange all open maps horizontally or vertically on the screen.
Cascade: Arrange all open maps in a way that the title of each map is visible.

Help Menu

Contents: The contents of this help file.
Menu: Help for menu commands.
Toolbar: Help for toolbar buttons.
Renewals: Click on this menu item to open the Renewals page.
OCAD Home page: Connect to the OCAD homepage on the Internet.
OCAD Update: Connect to the OCAD download site on the Internet.
OCAD Learn Videos: Connect to Learning Videos on OCAD homepage.
About OCAD: General Information about OCAD.

Using the Keyboard with the Mouse

This section provides an overview of options for using the keyboard and the mouse together.

Drawing

  • Shift shift: When starting a curve, straight line or freehand line: extend an existing object.
  • Ctrl: Trace an existing object.
  • Alt: Drawing a straight line: the line is made exactly horizontal or vertical.

Drawing a circle

  • Shift shift: Drag the radius from the center point.

Edit

  • Shift shift: Add or remove an object to/from the selected objects.
  • Ctrl: Remove a vertex.
  • Shift shift + Ctrl: Insert a normal vertex.
  • Alt: Select an object behind an object that has already been selected.
  • Alt + cut: hange to Edit mode to select next line object in between cutting lines.
  • Ctrl + cut: Cut a virtual gap into the selected line object.
  • Shift shift + cut: Cut a broken line: a gap is inserted at the vertex where the cut was made.
  • Arrow keys: Moves the selected object.

View

  • Space bar + Left Mouse Button: Move the View (pan).
  • Ctrl + Mouse Wheel: Zoom in and zoom outIncrease/reduce the size of the map section.
  • Shift shift + Mouse Wheel: Move the map section horizontally (scroll).

Status Bar

ToDo

Previous Chapter: Renewals

Next Chapter: Create a New Map

Back to Main Page