Difference between revisions of "Export Files"

From OCAD 12 Wiki - English
Jump to: navigation, search
(Export JPEG)
(Export TIFF)
Line 354: Line 354:
 
|-
 
|-
 
|}
 
|}
 
  
 
[[File:Hint.jpg|hint]] Pixel size and Create World file option are only available if Real world coordinate mode in Scale and Coordinate System from the Map menu is activated
 
[[File:Hint.jpg|hint]] Pixel size and Create World file option are only available if Real world coordinate mode in Scale and Coordinate System from the Map menu is activated
[[File:Hint.jpg]] The error message: "Not enough memory for exporting" appears if Windows cannot provide the memory needed. Choose a lower raster resolution.
+
[[File:Hint.jpg|hint]] The error message: "Not enough memory for exporting" appears if Windows cannot provide the memory needed. Choose a lower raster resolution.
 
+
[[File:Hint.jpg|hint]] The size of the exported TIFF is limited to 65535 x 65535 pixels.
  
 
==Export Encrypted File==
 
==Export Encrypted File==

Revision as of 16:56, 7 May 2012

To print out a map or use it in another desktop publishing program, export it in for example PDF format.

  1. Select Export in the File menu.
  2. Select the area to print (Entire Map, Part of Map or One page) in the Setup field. Now place the gray frame in the drawing window over the area you want to print out. If you cannot see the frame, click Zoom out in the View menu until the frame becomes visible.
  3. Click OK to export the map.
hint If you want to export the raster background map as well, enter a resolution for it.
example File Export Information


Save Files

  • Save: Select Save in File menu.
  • Save in: This box displays the present location. Press the down arrow to go back in the hierarchy or change to a different drive.
The box below displays the folders and files in the present location. To open a folder (and change to this folder) double clicks on it.
  • File Name: Enter the file name here. You do not have to enter an extension. The default extension is appended automatically. The default extension depends on the file you want to save. It is *.ocd for an OCAD map file.
hint If you do not enter an extension, you must not enter the period. If you enter a period, no extension will be appended.
  • Save as type: When the dialog box is opened, you need to choose the file type to be saved as. For map files for example, this is Map files (*.ocd). This means that all files with the extension OCD are listed in the Files list box.
You can choose All files (*.*) to list all files in the selected directory.
  • Save as: Select Save as in File menu.
Choose this command to save the current map under a new name. The Save As file dialog box is displayed.
You can use this command to save the map in a previous OCAD version (6, 7, 8 or 9). In the box Save as type you can choose the format.
hint -All changes made since the old map was saved the last time are not written to the old map. They are written to the new map only. However, if Auto Save is switched on, the changes are saved to both files. Choose OCAD Preferences from the Options menu to switch Auto Save on and off.
-Do not use this command to make a backup copy of your map. Choose Backup from the File menu for this purpose.

Setup Part of Map

This dialog box appears if you click Setup in some of the Export dialog boxes.

In this dialog box you can define the part of the map to be exported.
  • Coordinates: Select here if you want to enter the coordinates in paper coordinates or in real world coordinates. Choose Scale and Coordinate System from the Map menu to setup the real world coordinate system. If the real world coordinates are rotated, you can only use paper coordinates.
  • Left, Right, Bottom, Top: Enter here the boundaries of the desired export window.
  • Entire map: Click this button to set the boundaries to the entire map.


Export AI

(This function is not available in Draft mode. Change to Normal mode to export AI file.)

Choose this command to export the map to an AI (Adobe Illustrator) file.

After clicking OK, a file dialog box is displayed where you can enter a file name for the exported map.

The AI format is the preferred format if you want to process the map further in a graphics program. It preserves the full graphics quality of the map. The exported file contains layers corresponding to the OCAD symbols appearing on the map. The format is Adobe Illustrator version 7.


Part of Map Activate this check box to export a part of the map. The map section will be shown with a rectangle on the drawing window. You can alter the rectangle with the mouse.

Click the button Setup setup to define the part of map to be exported by coordinates. The dialog box Setup Part of Map (Export) appears.
Click the button Entire map entire map to export the entire map.
Click the button To current view to current view to export the currently on the screen displayed map.

If this check box is not active the entire map will be exported.

Export scale Enter the scale for the exported map. You can enter the scale on the keyboard, or choose one of the predefined scales.

Colors CMYK (process) colors: Select this radio button if you want to print the map using process colors. Spot colors: Select this radio button if you want to print the map using spot colors Mode. If you choose this option, the appearance must be specified for each spot color. Choose Spot color Mode from the Map menu to define the appearance for the different spot colors. Activate Combine to export all selected spot colors in the same file. This is for very special cases. Normally you should not use this option.


Export BMP

Choose this command to export the map to a BMP file. The Export BMP File dialog box is displayed. After clicking OK, a file dialog box is displayed where you can enter a file name for the exported bitmap.

  • Resolution: Enter here the desired resolution for the exported BMP file.
  • Pixel size: Enter here the size of a pixel in the real world.
  • Create World file (*.bpw): Choose this option if you want to use the exported file in a GIS (Geographical Information System). A World file with the geo-reference information is created.
  • Anti-Aliasing: Anti-Aliasing is method to make the edges of lines and texts appear soft. Normally you should activate this option.
  • Color correction: Activate this option to apply the same color correction as for the screen. Choose Color correction from the Options menu to setup the color correction.
  • Part of map
Activate this check box to export a part of the map. The map section will be shown with a rectangle on the drawing window. You can alter the rectangle with the mouse.
Click the button Setup setup to define the part of map to be exported by coordinates. The dialog box Setup Part of Map (Export) appears.
Click the button Entire map entire map to export the entire map.
Click the button To current view to current view to export the currently on the screen displayed map.
If this check box is not active the entire map will be exported.
  • Tiles
Activate this check box to export the map in tiles instead of one single file. Click the button Setup setup to define the tiles. The dialog box Setup tiles appears.
Pixel size and Create World file option are only available if Real world coordinate mode in Scale and Coordinate System from the Map menu is activated

Hint.jpg The error message: "Not enough memory for exporting" appears if Windows cannot provide the memory needed. Choose a lower raster resolution.
Hint.jpg The size of the exported BMP is limited to 32000 x 32000 pixels.

Export DXF

(This function is not available in Draft mode. Change to Normal mode to export DXF file.)
(This function is not available if the map is hidden.)

Choose this command to export the entire map to a *.dxf file. After clicking OK, a file dialog box is displayed where you can enter a filename for the exported map. The exported DXF contains only layers (corresponding to the symbols) and coordinates, but no graphics. (That is, the appearance of the symbols is lost.) If you want to process a map further in a graphics program, the AI (Adobe Illustrator) format is the preferred format. There all graphics are exported.

Export Scale

Enter the scale for the exported map. You can enter the scale on the keyboard, or choose one of the predefined scales.

Convert text from ANSI to OEM

Activate this option if text should be converted to the OEM character set. OEM character set is used by old DOS programs and concerns only accented characters (ä, à, å etc.). :Normally you should not activate this option.
If accented characters are not imported correctly in the DOS program, try this option.
Convert text from ANSI to Unicode: Activate this option if text should be converted to the Unicode character set.
Only objects with a selected symbol: Activate this option to export only objects with a selected symbol.


CRT

Choose this button to load a cross reference table. In a cross reference table you can define how the OCAD symbols are translated to DXF layers. If you do not use a cross :reference table, then the symbol numbers without decimal point are used as DXF layers (e.g. symbol 101.0 is translated to 1010). The Load Cross Reference Table file dialog box is displayed.

Export OCAD curves as DXF splines

Activate this option if OCAD Bézier curves should be converted to DXF splines. Otherwise they are converted to polylines.
  • GIS (m): Select this radio button if you want to use the *.dxf file in a Geographic Information System (GIS). 1 unit corresponds to 1 meter in the real world. The map scale is used for the transformation.
  • Paper (mm): Select this radio button if you want to use the *.dxf file in a graphics program. 1 unit corresponds to 1 mm on the map.


Export EPS

(This function is not available in Draft mode. Change to Normal mode to export EPS file.)

Choose this command to export the map (or part of it) in the EPS format. After clicking OK, a file dialog box is displayed where you can enter a filename for the exported map. *.eps files are mainly used to print maps on a color copier or to make the printing films for offset printing. EPS files can be opened in Adobe Illustrator.

Part of map

Activate this check box to export a part of the map. The map section will be shown with a rectangle on the drawing window. You can alter the rectangle with the mouse.
  • Click the button Setup setup to define the part of map to be exported by coordinates. The dialog box Setup Part of Map (Export) appears.
  • Click the button Entire map entire map to export the entire map.
  • Click the button To current view to current view to export the currently on the screen displayed map.
If this check box is not active the entire map will be exported.

Export scale

Enter the scale for the exported map. You can enter the scale on the keyboard, or choose one of the predefined scales.

Colors

  • Color EPS (CMYK): Select this radio button to export a colored map. The color EPS contains CMYK colors. At the service bureau color copies or films for CMYK printing can be made.
  • Spot color separations: Select this option to export spot color separations. Choose Spot color Mode from the View menu to define spot colors. When this radio button is activated and spot colors are defined, you can select one or more of the defined spot colors in the Spot colors list box. Normally you export an EPS file for each of these spot colors.

Export GIF

Choose this command to export the map as a GIF file. After clicking OK, a file dialog box is displayed where you can enter a filename for the exported map. GIF files are used to publish small maps in the Internet. For large maps the OIM (OCAD Internet) file format is recommended. For maps GIF offers the better compression than JPEG and therefore gives smaller files.

  • Resolution: Enter here the desired resolution for the exported GIF file.
  • Pixel size: Enter here the size of a pixel in the real world.
  • Create World file (*.gfw): Choose this option if you want to use the exported file in a GIS (Geographical Information System). A World file with the geo-reference information is created.

Anti-Aliasing Anti-Aliasing is method to make the edges of lines and texts appear soft. Normally you should activate this option.

Color correction Activate this option to apply the same color correction as for the screen.

Part of map Activate this check box to export a part of the map. The map section will be shown with a rectangle on the drawing window. You can alter the rectangle with the mouse.

  • Click the button Setup setup to define the part of map to be exported by coordinates.
  • Click the button Entire map entire map to export the entire map.
  • Click the button To current view to current view to export the currently on the screen displayed map.

If this check box is not active the entire map will be exported.

Tiles Activate this check box to export the map in tiles instead of one single file. Click the button Setup setup to define the tiles.

hint Pixel size and Create World file option are only available if Real world coordinate mode in Scale and Coordinate System from the Map menu is activated.
Hint.jpg The error message: "Not enough memory for exporting" appears if Windows cannot provide the memory needed. Choose a lower raster resolution.
Hint.jpg The size of the exported GIF is limited to 65535 x 65535 pixels.

Export GPX

(This function is not available if the map is hidden.)

Choose GPX file format to export OCAD objects as waypoints, tracks or routes that can be loaded to GPS devices.

hint -Only the selected map objects are exported.
-Only point, line, text and line text objects are exported. Area objects cannot be exported to GPX.

Metadata

  • Description: A description of the contents of the GPX file.
  • Author: The person or organization who created the GPX file.
  • Keywords: Keywords associated with the file. Search engines or databases can use this information.

Export line objects as

  • Routes: Line objects are exported as routes: <rte>. A route is an ordered list of waypoints leading to a destination.
  • Tracks: Line objects are exported as tracks: <trk>. A track is an ordered list of points describing a path.
After clicking OK, the file dialog box is displayed where you can enter a filename.

Export JPEG

Choose this command to export the map as a JPEG file. After clicking OK, a file dialog box is displayed where you can enter a file name for the exported map. JPEG files are used to publish small maps in the Internet. For large maps the OIM (OCAD Internet) file format is recommended. For maps GIF offers the better compression than JPEG and therefore gives smaller files.

  • Resolution: Enter here the desired resolution for the exported JPEG file.
  • Pixel size: Enter here the size of a pixel in the real world.
  • Create World file (*.jgw): Choose this option if you want to use the exported file in a GIS (Geographical Information System). A World file with the geo-reference information is created.

Anti-Aliasing: Anti-Aliasing is method to make the edges of lines and texts appear soft. Normally you should activate this option. Color correction: Activate this option to apply the same color correction as for the screen. Choose Color correction from the Options menu to setup the color correction.

Part of map: Activate this check box to export a part of the map. The map section will be shown with a rectangle on the drawing window. You can alter the rectangle with the mouse.

Click the button Setup to define the part of map to be exported by coordinates. The dialog box Setup Part of Map (Export) appears.
Click the button Entire map to export the entire map.
Click the button To current view to export the currently on the screen displayed map.

If this check box is not active the entire map will be exported.

Tiles: Activate this check box to export the map in tiles instead of one single file. Click the button Setup to define the tiles. The dialog box Setup tiles appears.

hint Pixel size and Create World file option are only available if Real world coordinate mode in Scale and Coordinate System from the Map menu is activated.
hint The error message: "Not enough memory for exporting" appears if Windows cannot provide the memory needed. Choose a lower raster resolution.
hint The size of the exported JPEG is limited to 65535 x 65535 pixels.

Export KML

(This function is not available if the map is hidden.)

Choose KML (Google Earth) file format if you want to view the export map objects in a Earth Viewer.

hint -Only the selected map objects are exported.
-Only point, line and area objects are exported. Text object cannot be exported to KML.
  • Name: This is the name of the place folder in the places panel of Google Earth.
  • Screen overlay: Define what an icon should be shown in top left corner of the Earth Viewer window when the KML file is opened. This icon is not included in the KML file. An URL must be entered. The screen overlay name is the name shown in the places panel of Google Earth
  • Look at (longitude, latitude and range): Geographical coordinates and height above sea level where the viewer should start navigating by opening Google Earth.
  • Height for area objects: Set a height value for area objects to make them looking three-dimensional.
  • Placemark default name: Set a default name that is shown in the places panel of Google Earth.
  • Default icon for point objects: Point objects are converted to placemarks. A placemark needs an icon (small picture). This icon is not included in the KML file. An URL must be entered. Google Earth loads the icon dynamically when the KML file is opened.

After clicking OK, a file dialog box is displayed where you can enter a filename.


Export KMZ

(This function is only available in OCAD 10.2.0 and later.)

Choose this command to export the map as a raster KMZ file. It is possible to open the exported KMZ file in Google Earth or upload this file on a Garmin GPS which supports 'Garmin Custom Maps'.

Tiles: Choose here between no tiles, 'Garmin Custom Maps' optimized tiles (max 1024x1024 pixels) or user-defined tiles. After clicking OK, a file dialog box is displayed where you can enter a filename.


Export PDF

(This function is not available in Draft mode. Change to Normal mode to export PDF file.)

Choose this command to export the map to a PDF-file. After clicking OK, a file dialog box is displayed where you can enter a filename for the exported map. You can open and print PDF files with Adobe Acrobat Reader.

Part of map Activate this check box to export a part of the map. The map section will be shown with a rectangle on the drawing window. You can alter the rectangle with the mouse.

  • Click the button Setup setup to define the part of map to be exported by coordinates. The dialog box Setup Part of Map (Export) appears.
  • Click the button Entire map entire map to export the entire map.
  • Click the button To current view to current view to export the currently on the screen displayed map.

If this check box is not active the entire map will be exported.

Export scale Enter the scale for the exported map. You can enter the scale on the keyboard, or choose one of the predefined scales.

Colors

Color EPS (CMYK): Select this radio button to export a color map. The color PDF contains CMYK colors. At the service bureau color copies or films for CMYK printing can be made.
Spot color separations: Select this option to export spot color separations. Choose Spot color mode from the View menu to define spot colors. When this radio button is activated and spot colors are defined, you can select one or more of the defined spot colors in the Spot colors list box. Normally you export a PDF file for each of these spot colors. Activate Combine to export all selected spot colors in the same file. This is for very special cases. Normally you should not use this option.
Compress file: Activate this box to compress the export file. The compression does not influence the print quality.


Export Shape

(This function is only available in OCAD Professional!)
(This function is not available in Draft mode. Change to Normal mode to export Shape file.)
(This function is not available if the map is hidden.)

Choose this command to export the map in the shape format.

The shape format consists of 3 files

  • *.shp: the shape file
  • *.shx: the shape index
  • *.dbf: a dBase file

Point, line, area and texts objects must be exported separately. If you export all types totally 12 files will be produced.

Objects In this box you select which object types should be exported. You can select one or more types by using the shift and Ctrl keys. Initially all types are selected.

Dataset Select here if all objects should be exported or only objects linked to a specified dataset. If you select All objects the dBase file will contain an ID, the symbol number, the angle and for texts the text. If you select Objects in dataset the dBase file will contain the information of the corresponding table.


Export SVG

(This function is only available in OCAD Professional!)
(This function is not available in Draft mode. Change to Normal mode to export SVG file.)

Choose this command to export the map to a SVG (Scalable Vector Graphics) file. After clicking OK, a file dialog box is displayed where you can enter a filename for the exported map. Part of map Activate this check box to export a part of the map. The map section will be shown with a rectangle on the drawing window. You can alter the rectangle with the mouse.

  • Click the button Setup setup to define the part of map to be exported by coordinates. The dialog box Setup Part of Map (Export) appears.
  • Click the button Entire map entire map to export the entire map.
  • Click the button To current view to current view to export the currently on the screen displayed map.

If this check box is not active the entire map will be exported.

Export scale Enter the scale for the exported map. You can enter the scale on the keyboard, or choose one of the predefined scales.

Compress file Activate this box to compress the export file.


Export TIFF

Choose this command to export the map as a TIFF file After clicking OK, a file dialog box is displayed where you can enter a filename for the exported map.

  • Resolution: Enter here the desired resolution for the exported TIFF file.
  • Pixel size: Enter here the size of a pixel in the real world.
  • Create World file (*.tfw): Choose this option if you want to use the exported file in a GIS (Geographical Information System). A World file with the geo-reference information is created.

Anti-Aliasing Anti-Aliasing is method to make the edges of lines and text appear soft. Normally you should activate this option.

Color correction Activate this option to apply the same color correction as for the screen.

Part of map Activate this check box to export a part of the map. The map section will be shown with a rectangle on the drawing window. You can alter the rectangle with the mouse.

  • Click the button Setup setup to define the part of map to be exported by coordinates. The dialog box Setup Part of Map (Export) appears.
  • Click the button Entire map entire map to export the entire map.
  • Click the button To current view to current view to export the currently on the screen displayed map.

If this check box is not active the entire map will be exported.

Tiles Activate this check box to export the map in tiles instead of one single file. Click the button Setup setup to define the tiles. The dialog box Setup tiles appears.

Setup Tiles This dialog box appears if you click the Setup button for Tiles in the Export panel. If you choose the Tiles option, the map is divided into small rectangular fields (tiles) and one file is exported for each tile. The tiles start from the lower left corner. To number the files, the number of the column and the number of the row are appended to the file name.

"filename_0_0.tif" is the tile in the lower left corner.
"filename_1_0.tif" is the tile to the right of the first tile.

All tiles have the same size, even if they extend beyond the map size or the part of map defined.

Tile size: Enter here the size of a tile.

Color

Color TIFF (RGB): Select this option to export a color map.
Compression: Choose LZW to compress the export file.
Spot color separations: Select this option to export spot color separations. Choose Spot colors Mode from the View menu to define spot colors. When this radio button is activated and spot colors are defined, you can select one or more of the defined spot colors in the Spot colors list box. Normally you export a TIFF file for each of these spot colors. Activate Combine to export all selected spot colors in the same file. This is for very special cases. Normally you should not use this option.
Color depth: Select the color depth (number of different colors to export):
CMYK (32 Bits): 4295 million colors.
RGB (24 Bits): 16 million colors.
256 colors: 8 bits with 256 colors.
Grayscale: 8 bits with 256 gray scales
Black/White: 1 bit with black or white.
Halftone screen: 1 bit with black or white.

hint Pixel size and Create World file option are only available if Real world coordinate mode in Scale and Coordinate System from the Map menu is activated hint The error message: "Not enough memory for exporting" appears if Windows cannot provide the memory needed. Choose a lower raster resolution. hint The size of the exported TIFF is limited to 65535 x 65535 pixels.

Export Encrypted File

Choose this command to export encrypted OCAD files (EOCD). EOCD files are read only files. OCAD can open them as background maps only.

Export encrypted command provides the following settings:

  • Document open password: Protect the EOCD file with a password.
  • Allow to print and export: Set this option if print/export should be allowed.
  • Only valid for license number: Set this option to restrict file opening for a limited number (1-16) of OCAD users.
  • Map owner name: Set a map owner name.


OIM Export Assistent

Read more about this topic here: OCAD Internet Map


Previous Chapter: Layout

Next Chapter: Printing Maps

Back to Main Page