XML Script

Aus OCAD 11 Wiki - Deutsch
Wechseln zu: Navigation, Suche

This function is available in OCAD 11 Professional.

Wählen Sie diesen Befehl, um Funktionen, deren Einstellungen in einer XML-Datei definiert sind, auszuführen.


Einleitung

Wählen Sie XML Script ausführen aus dem Datei-Menü oder ziehen Sie eine XML-Datei in das OCAD-Fenster.

XML Script Allgemein

Datei

Knoten <OcadScript> Parameter Datentyp Werte / Beschreibung
File.New File String ocd Dateiname
File.Open File String ocd Dateiname
File.Close Enabled Boolean true, false
File.Save Enabled Boolean true, false
File.SaveAs File String ocd Dateiname
File.Import.Ocd File
SymbolOption
ColorOption
String
Integer
Integer
Dateiname
[0..3]
[0, 1]
File.MultipleFileImport Directory
CoordinateSystem

NewOffset
Horizontally
Vertically
Angle
MapScale
GridDistance
LayerField
String
Integer

Boolean
Integer
Integer
Double
Integer
Double
String
Verzeichnis der Importdateien
-1 = WGS 84, 1000 = exisiterendes Gitter der OCAD-Datei
true, false
 
 
 
 
 
 
File.Exit Enabled Boolean true, false
OCAD schliessen

Ansicht

Knoten <OcadScript> Parameter Datentyp Werte / Beschreibung
View.Mode Enum types normalMode, spotColorMode, draftMode
View.EntireMap Enabled Boolean true, false
View.MoveTo X
Y
Double
Double
 
View.Zoom   Double  

Karte

Knoten <OcadScript> Parameter Datentyp Werte / Beschreibung
Map.OptimizeRepair Enabled Boolean true, false
Map.ChangeScale NewScale Integer z.B. 10 000
  EnlargeReduceSymbols Boolean true, false
Map.ConvertLayer CrtFile String crt Dateiname
Map.LoadSymbolsFrom File String ocd Dateiname (mit den zu ladenden Symbolen)
Die Option Bestehende Farben ersetzen wird verwendet
Map.Routing FromCoordinateEasting
FromCoordinateNorthing
ToCoordinateEasting
ToCoordinateNorthing
TemplateFile
AddDrivingDirections
Double
Double
Double
Double
String
Boolean
 
 
 
 
 

Datenbank

Knoten <OcadScript> Parameter Datentyp Werte / Beschreibung
Database.Dataset.New DatasetName
DBaseFile
OdbcDataSource
Table
KeyField
SymbolField
TextField
SizeField
LengthUnit
AreaUnit
Decimals
HorizontalCoordinate
VerticalCoordinate
Username
Passwort
String
String
String
String
String
String
String
String
String
String
Integer
String
String
String
String
obligatorisch
 
 
obligatorisch
obligatorisch
 
 
 
 
 
 
 
 
 
 
Database.Dataset.Remove Dataset String/Integer all für alle Datenbanken
3, 2, 1, ... für eine einzige oder mehrere
Database.Assign.Symbols Dataset
 
CntFile
String/Integer
 
String
all für alle Datenbanken
1, 2, 3, ... für eine einzelne Datenbank
Konditionstabellen-Datei
Database.Assign.Texts Dataset
 
TextField
Symbol
ReplaceExistingObjects
String/Integer
 
String
String
Boolean
all für alle Datenbanken
1, 2, 3, ... für eine einzelne Datenbank
 
ex. 101.0
true, false (Default)
Database.Assign.Angles Dataset
 
AngleField
String/Integer
 
String
all für alle Datenbanken
1, 2, 3, ... für eine einzelne Datenbank
 
Database.CreateObjects Dataset
SelectSymbol
Condition
HorizontalCoordinate
VerticalCoordinate
Unit
TextField
HorizontalOffset
VerticalOffset
Integer
Double
String
String
String
Enum types
String
Double
Double
1, 2, 3, ... Nummer der Datenbank-Verbindung
Symbolnummer z.B. 207,0
SQL String (z.B. SYMBOL LIKE 207,0)
Datenbank-Feldname
Datenbank-Feldname
m, km
Datenbank-Feldname
 
 

Hintergrundkarte

Knoten <OcadScript> Parameter Datentyp Werte / Beschreibung
BackgroundMap.Open FileName
Visible
VisibleInFavorites
Dimm
Transparent
SpotColor
Blockout
Infrared
String
Boolean
Boolean
Integer
Boolean
String
Boolean
Integer
 
Default = true
 
 
 
 
 
 

xml-Beispieldatei:

<?xml version="1.0" encoding="ISO-8859-1"?>
<!-- OCAD XML Script für den Import von mehreren Shape-Dateien und die Zuordnung der Symbole anhand einer Datenbank -->

<OcadScript>

  <File.New>
    <!-- Dieses Verzeichnis muss vor der Verwendung des Skriptes angepasst werden! Wählen Sie eine Vorlagedatei. -->
    <File>C:\Export\Chlosterwald.ocd</File>
  </File.New>

  <File.MultipleFileImport>
    <!-- Dieses Verzeichnis muss vor der Verwendung des Skriptes angepasst werden! -->
    <Directory>C:\Export\Files</Directory>
    <CoordinateSystem>1000</CoordinateSystem>
    <NewOffset>true</NewOffset>
    <Horizontally>600000</Horizontally>
    <Vertically>200000</Vertically>
    <Angle>0</Angle>
    <MapScale>10000</MapScale>
    <GridDistance>500</GridDistance>
    <LayerField>OBJECTVAL</LayerField>
  </File.MultipleFileImport>

  <Database.Assign.Texts>
    <Dataset>all</Dataset>
    <TextField>TEXT</TextField>
    <Symbol>902.000</Symbol>
    <ReplaceExistingObjects>false</ReplaceExistingObjects>
  </Database.Assign.Texts>

  <Database.Assign.Angles>
    <Dataset>all</Dataset>  
    <AngleField>ANGLE</AngleField>
  </Database.Assign.Angles>

  <Database.Assign.Symbols>
    <Dataset>all</Dataset>
    <CntFile>C:\Export\Chlosterwald.cnt</CntFile>
  </Database.Assign.Symbols>

  <Database.Dataset.Remove>
    <Dataset>all</Dataset>
  </Database.Dataset.Remove>

  <Map.OptimizeRepair>
    <Enabled>true</Enabled>
  </Map.OptimizeRepair>

  <View.EntireMap>
    <Enabled>true</Enabled>
  </View.EntireMap>

  <File.Save>
    <Enabled>false</Enabled>
  </File.Save>

  <File.SaveAs>
    <File>C:\Export\Chlosterwald_Example.ocd</File>
  </File.SaveAs>

  <File.Close>
    <Enabled>true</Enabled>
  </File.Close>

  <File.Exit>
    <Enabled>false</Enabled>
  </File.Exit>

</OcadScript>

Mit XML Script Teilkarte exportieren

Knoten <OcadScript> Parameter Datentyp Werte / Beschreibung
export file String z.B.: ‚ c:\export\PartialMap1.ocd ‘
OCAD erstellt die Dateien PartialMap1_1_1.ocd,
PartialMap1_1_2.ocd,
export coordSystem Enum types mm (Papier), m (Landeskoordinaten)
export T, L, B, R Float top, left, bottom, right
export.loop enabled
horizontalPages
verticalpages
horizontalOverlap
verticalOverlap
Boolean
Integer
Integer
Float
Float
true, false
Anzahl Seiten in horizontaler Richtung
Anzahl Seiten in vertikaler Richtung
horizontale Überlappung in mm oder m
vertikale Überlappung in mm oder m

xml-Beispieldatei:

<ocadScript>                                               // Kommentar
<partialMapScript>
   <export id="0">                                         // Erster Exportschritt
    <file>c:\export\PartialMap1.ocd</file>                 // Datei exportieren
    <coordSystem>mm</coordSystem>                          // Papier- oder Landeskoordinaten
    <T>100</T>                                             // Export-Rechteck mit Punkten oben links und unten rechts
    <L>0</L>
    <B>50</B>
    <R>50</R>
      <loop>                                               // Die Schlaufe exportiert mehrere OCD-Dateien. In diesem Beispiel sind es 21 Dateien.
      <enabled>true</enabled>
      <horizontalPages>7</horizontalPages>              
      <verticalPages>3</verticalPages>
      <horizontalOverlap>10</horizontalOverlap>            // horizontale und vertikale Überlappung
      <verticalOverlap>10</verticalOverlap>
    </loop>
    </export>                                              // Zweiter Exportschritt
    <export id="1">
    <file>c:\export\PartialMap2.ocd</file>
    <coordSystem>mm</coordSystem>
    <L>0</L>
    <R>50</R>
    <B>50</B>
    <T>100</T>
      <loop>
      <enabled>false</enabled>
    </loop>                                                // nur eine ocd-Datei exportieren
    </export>
  </partialMapScript>
</ocadScript>

Mit XML Script Drucken

Druckeinstellungen können in einem XML-Skript gespeichert werden.

Knoten <OcadScript> Parameter Datentyp Werte / Beschreibung
File.Print.Printer Name
DmPaperSize
DmDefaultSource
DmPrintQuality
DmColor
DmMediaType
String
Integer
Integer
Integer
Integer
Integer
z.B. ,HP Color LaserJet 2840 PCL'
9
15
600
2
272
File.Print.Portrait Enabled Bool true, false
File.Print.SpotColor Enabled Bool true, false
File.Print.PartialMap Range
L, R, B, T
Integer
Float
1
Left, Right, Bottom, Top
File.Print.HorizontalOverlap   Float -12,74
File.Print.VerticalOverlap   Float 8.74
File.Print.PrintScale   Integer z.B. 25000
File.Print.Copies   Integer Anzahl Kopien
File.Print.Intensity   Integer  
File.Print.LineWidth   Integer  
File.Print.PrintScreenGrid Enabled Bool true, false
File.Print.PrintScreenGridColor   Integer Farbnummer

Mit XML Script exportieren

AI (Adobe Illustrator), PDF

Knoten <OcadScript> Parameter Datentyp Werte / Beschreibung
File.Export File String z.B.: ,c:\Export\Chlosterwald.ai‘
File.Export Format Enum types AI, PDF
File.Export.PartOfMap Enabled
Coordinates
L, R, B, T
Bool
Enum types
Float
true, false
mm (Papier), m (Landeskoordinaten)
left, right, bottom, top
File.Export ExportScale Integer z.B. '10000' für den Massstab 1:10'000
File.Export Colors Enum types normal, spotColors
File.Export.SpotColors Combine Bool true, false [nur wenn Colors = spotColors]
File.Export.SpotColors Enabled Spotcolor name [nur wenn Colors = spotColors]

BMP, GIF, JPEG

Knoten <OcadScript> Parameter Datentyp Werte / Beschreibung
File.Export File String z.B.: ‚c:\Export\Chlosterwald.bmp‘
File.Export Format Enum types BMP, GIF, JPEG
File.Export Quality Integer nur für JPEG, [0..100]
File.Export Resolution Integer in dpi [40..2540]
File.Export Anti-Aliasing Boolean true, false
File.Export ColorCorrection Boolean true, false
File.Export.PartOfMap Enabled
Coordinates
L, R, B, T
Bool
Enum types
Float
true, false
mm (Papier), m (Landeskoordinaten)
left, right, bottom, top
File.Export.Tiles Enabled
Width
Height
Boolean
Integer
Integer
true, false
[nur wenn Enabled = true]
[nur wenn Enabled = true]
File.Export.GeoRef Enabled
PixelSize
CreateWorldFile
Bool
Float
Bool
true, false
in Meter [nur wenn Enabled = true]
true, false [nur wenn Enabled = true]

EPS

Knoten <OcadScript> Parameter Datentyp Werte / Beschreibung
File.Export File String z.B.: ‚c:\Export\Chlosterwald.eps ‘
File.Export Format Enum types EPS
File.Export.PartOfMap Enabled
Coordinates
L, R, B, T
Bool
Enum types
Float
true, false
mm (Papier), m (Landeskoordinaten)
left, right, bottom, top
File.Export Colors Enum types normal, spotColors
File.Export.SpotColors Enabled Spotcolor name [nur wenn Colors = spotColors]

SVG (Scalable Vector Graphics)

Knoten <OcadScript> Parameter Datentyp Werte / Beschreibung
File.Export File String z.B.: ‚c:\Export\Chlosterwald.svg ‘
File.Export Format Enum types SVG
File.Export.PartOfMap Enabled
Coordinates
L, R, B, T
Bool
Enum types
Float
true, false
mm (Papier), m (Landeskoordinaten)
left, right, bottom, top
File.Export ExportScale Integer z.B. '10000' für den Massstab 1:10'000
File.Export CompressFile Boolean true, false

TIFF

Knoten <OcadScript> Parameter Datentyp Werte / Beschreibung
File.Export File String z.B.: ‚c:\Export\Chlosterwald.tif‘
Wenn spotColors aktiviert ist und
Combine=false, ist der Dateiname
‚c:\Export\Chlosterwald.Spotcolor name.tif ‘
File.Export Format Enum types TIFF
File.Export Resolution Integer in dpi [40..2540]. Nur verwendet wenn File.Export.GeoRef -> Enabled = false
File.Export Anti-Aliasing Boolean true, false
File.Export ColorCorrection Boolean true, false
File.Export.PartOfMap Enabled
Coordinates
L, R, B, T
Boolean
Enum types
Float
true, false
mm (Papier), m (Landeskoordinaten)
left, right, bottom, top
File.Export.Tiles Enabled
Width
Height
Boolean
Integer
Integer
true, false
[nur wenn Enabled = true]
[nur wenn Enabled = true]
File.Export.GeoRef Enabled
PixelSize
CreateWorldFile
Boolean
Float
Boolean
true (->PixelSize), false (->Resolution)
in Meter [nur wenn Enabled = true]
true, false [nur wenn Enabled = true]
File.Export Colors Enum types normal, spotColors
File.Export.SpotColors Combine
Enabled
Bool
Spotcolor name
true, false [nur wenn Colors = spotColors]
[nur wenn Colors = spotColors]
File.Export ColorMode Integer 0 = 32 bit CMYK
1 = 24 bit RGB
2 = 256 Farben
3 = Graustufen
4 = 8 bit CMYK
5 = 1 bit Schwarz/Weiss
6 = Halbton-Druckraster
File.Export Compression Integer 1 = keine Komprimierung
2 = CCITT
4 = FaxG4
5 = LZW

DXF

Knoten <OcadScript> Parameter Datentyp Werte / Beschreibung
File.Export File String z.B.: ‚c:\Export\Chlosterwald.dxf ‘
File.Export Format Enum types DXF
File.Export ExportScale Integer z.B. '10000' für den Massstab 1:10'000
File.Export ConvertAnsiToOem Boolean true, false
File.Export ConvertOemToUnicode Boolean true, false
File.Export ObjectsSelectedSymbols Boolean true, false
File.Export AddSymbolDescription Boolean true, false
File.Export UseCrtFileName String z.B.: ‚c:\CRT\Chlosterwald.crt‘
File.Export ExportAsSplines Boolean true, false
File.Export Coordinates Enum types m, mm

Shape

Knoten <OcadScript> Parameter Datentyp Werte / Beschreibung
File.Export ExportPath String z.B.: ‚c:\Export‘ (Nur Verzeichnisname)
File.Export Format Enum types SHAPE
File.Export PointObjects
LineObjects
AreaObjects
TextObjects
Boolean
Boolean
Boolean
Boolean
true, false
true, false
true, false
true, false
File.Export Dataset String 'all' für alle Objekte
oder Index z.B.: 2 (Objekte in Datenbank mit Index = 2)
File.Export WordWrap Boolean true, false
File.Export ProjectionFile Boolean true, false
File.Export Utf8Encoding Boolean true, false

Beispiel

Das folgende Beispiel exportiert zwei PDF-Dateien in Echtfarben und zwei Shape-Dateien. Jedes OcadScript node can contain many children.

 <?xml version="1.0" encoding="ISO-8859-1"?>
 <OcadScript> 
   <File.Open>
     <File>M:\OCAD11\Changes\11-06xx\11-0663\Chlosterwald.ocd</File>
   </File.Open>
   <File.Export>
     <File>M:\OCAD11\Changes\11-06xx\11-0663\output\Chlosterwald.pdf</File>
     <Format>PDF</Format> 
     <PartOfMap>	
       <Enabled>true</Enabled>
       <Coordinates>mm</Coordinates>
       <L>0</L>
       <R>50</R>
      <B>50</B>
       <T>100</T>
     </PartOfMap>	
     <ExportScale>10000</ExportScale>
     <Colors>spotColors</Colors> 
     <SpotColors> 
       <Combine>false</Combine>
       <Enabled>Blau</Enabled>
       <Enabled>Gelb</Enabled>
     </SpotColors> 
   </File.Export> 
   <File.Export>
     <ExportPath>M:\OCAD11\Changes\11-06xx\11-0663\output\</ExportPath>
     <Format>SHAPE</Format>
     <PointObjects>false</PointObjects>
     <LineObjects>true</LineObjects>
     <AreaObjects>true</AreaObjects>
     <TextObjects>false</TextObjects>
     <Dataset>all</Dataset>
     <WordWrap>true</WordWrap>
     <ProjectionFile>false</ProjectionFile>
   </File.Export>
   <File.Save>
     <Enabled>true</Enabled>
   </File.Save>
   <File.Close>
     <Enabled>true</Enabled>
   </File.Close>
 </OcadScript> 

XML Script von der Kommandozeile aus ausführen

Sie können ein XML Script von der Kommandozeile oder von einer Batch-Datei aus ausführen.

Öffnen Sie die Windows Kommandozeile und geben Sie den OCAD Programmnamen und die XMLScript-Datei ein. Beispiel: "C:\Program Files\OCAD\OCAD 11\Ocad11.exe" "C:\Data\ExportScriptExample_PDF.xml"

Vergessen Sie nicht den Parameter <File.Open>, um die Datei zu öffen, <File.Close> um sie zu schliessen und <File.Exit> um OCAD zu schliessen.


Vorheriges Kapitel: Datenbank

Nächstes Kapitel: Bahnlegung für den Orientierungslauf

Zurück zur Hauptseite