Selektieren: Unterschied zwischen den Versionen

Aus OCAD 11 Wiki - Deutsch
Zur Navigation springen Zur Suche springen
(/* Select and Edit Object File:Space.PNGThis function is available in OCAD 11 Professional.|link=https://www.ocad.com/en/products/ocad-for-cartographyThis function is available in OCAD 11 Orienteering Standard.|link=https://www.ocad.com/en/products/oca…)
(/* Select Object and Edit Vertex File:Space.PNGThis function is available in OCAD 11 Professional.|link=https://www.ocad.com/en/products/ocad-for-cartographyThis function is available in OCAD 11 Orienteering Standard.|link=https://www.ocad.com/en/produ…)
Zeile 24: Zeile 24:
 
[[File:Hint.jpg|hint]] Disable '''[[OCAD_Preferences#Context_menu_in_drawing_area|Context menu in drawing area]]''' in the '''GUI (Graphical User Interface)''' category of '''[[OCAD Preferences]]''' to switch easily to the current '''Drawing''' mode and the '''Select Object and Edit Vertex''' mode by a simple click with the right mouse button on the drawing area. If this option is enabled, the context menu appears by clicking on the drawing area with the right mouse button. Read more about the context menu on the [[OCAD Preferences]] page.
 
[[File:Hint.jpg|hint]] Disable '''[[OCAD_Preferences#Context_menu_in_drawing_area|Context menu in drawing area]]''' in the '''GUI (Graphical User Interface)''' category of '''[[OCAD Preferences]]''' to switch easily to the current '''Drawing''' mode and the '''Select Object and Edit Vertex''' mode by a simple click with the right mouse button on the drawing area. If this option is enabled, the context menu appears by clicking on the drawing area with the right mouse button. Read more about the context menu on the [[OCAD Preferences]] page.
  
==Select Object and Edit Vertex [[File:Space.PNG]][[File:Pro40px.PNG|This function is available in OCAD 11 Professional.|link=https://www.ocad.com/en/products/ocad-for-cartography]][[File:Std40px.PNG|This function is available in OCAD 11 Orienteering Standard.|link=https://www.ocad.com/en/products/ocad-for-orienteering]][[File:Sta40px.PNG|This function is available in OCAD 11 Starter.|link=https://www.ocad.com/en/products/ocad-for-orienteering]][[File:CS40px.PNG|This function is available in OCAD 11 Course Setting.|link=https://www.ocad.com/en/products/ocad-for-orienteering]]==
+
==Selektiere Objekt und editiere Stützpunkt [[File:Space.PNG]][[File:Pro40px.PNG|This function is available in OCAD 11 Professional.|link=https://www.ocad.com/en/products/ocad-for-cartography]][[File:Std40px.PNG|This function is available in OCAD 11 Orienteering Standard.|link=https://www.ocad.com/en/products/ocad-for-orienteering]][[File:Sta40px.PNG|This function is available in OCAD 11 Starter.|link=https://www.ocad.com/en/products/ocad-for-orienteering]][[File:CS40px.PNG|This function is available in OCAD 11 Course Setting.|link=https://www.ocad.com/en/products/ocad-for-orienteering]]==
 
Choose '''Select Object and Edit Vertex''' in the '''Select''' menu or click the '''Select Object and Edit Vertex''' icon [[File:Icon_SelectObjectAndEditVertex.PNG]] in the '''Editing and Drawing Toolbar''' to select and edit vertices. The cursor changes to a transparent arrow like on the icon [[File:Icon_SelectObjectAndEditVertex.PNG]]. You are now in the '''Select Object and Edit Vertex''' mode.
 
Choose '''Select Object and Edit Vertex''' in the '''Select''' menu or click the '''Select Object and Edit Vertex''' icon [[File:Icon_SelectObjectAndEditVertex.PNG]] in the '''Editing and Drawing Toolbar''' to select and edit vertices. The cursor changes to a transparent arrow like on the icon [[File:Icon_SelectObjectAndEditVertex.PNG]]. You are now in the '''Select Object and Edit Vertex''' mode.
 
Click on an object to select it. The selection looks as follows:<br />
 
Click on an object to select it. The selection looks as follows:<br />

Version vom 19. Juni 2013, 07:31 Uhr

Selektiere und editiere Objekt Space.PNGThis function is available in OCAD 11 Professional.This function is available in OCAD 11 Orienteering Standard.This function is available in OCAD 11 Starter.This function is available in OCAD 11 Course Setting.

Choose Select and Edit Object in the Select menu or click the Select and Edit Object icon Icon SelectAndEditObject.PNG in the Editing and Drawing Toolbar to select and edit an object. The cursor changes to a black arrow like on the icon Icon SelectAndEditObject.PNG. You are now in the Select and Edit Object mode.
Click on an object to select it. The selection looks as follows if you have Object Stretching in the Object category in OCAD Preferences activated:
SelectandEditObjectSelection.PNG

Stretch an Area or Line Object

If you have Object Stretching in the Object category in OCAD Preferences activated, you can click and drag the black squares BlackSquare.PNG (stretching points) to stretch the object. If you want to keep the shape of the object drag a square from the corner. If you drag a square from the middle, the object is distorted in the corresponding direction. If you hold down the shift key while dragging a stretching point BlackSquare.PNG, the object is stretched relative to the center.
Stretching does not work for point and text objects. If you stretch line text objects, the line is stretched and not the text.
If Object Stretching is not enabled, the stretching points BlackSquare.PNG are not visible.

Move an Object

Click and drag one of the unfilled squares WhiteSquare.PNG (moving points) to move the object. Each square represents a vertex. If a hole is selected, you can move it in the same way.

Objects can also be moved using the arrow keys. Press additional the Shift key to move the object faster.

Select a Hole in an Area

It is possible to select a hole in an area object by clicking inside the desired hole. Only the hole will be selected. You can accomplish editing operations (e.g. Enlarge/Reduce, Fill, Rotate, Move or Delete) as for a normal area object. Find more about cutting holes on the Edit Object page.

hint If you have enabled the Auto select symbol when selecting object option in the Symbol category of OCAD Preferences, the corresponding symbol is automatically selected when selecting an object. This does not work for a selection of multiple objects. hint Disable Context menu in drawing area in the GUI (Graphical User Interface) category of OCAD Preferences to switch easily to the current Drawing mode and the Select Object and Edit Vertex mode by a simple click with the right mouse button on the drawing area. If this option is enabled, the context menu appears by clicking on the drawing area with the right mouse button. Read more about the context menu on the OCAD Preferences page.

Selektiere Objekt und editiere Stützpunkt Space.PNGThis function is available in OCAD 11 Professional.This function is available in OCAD 11 Orienteering Standard.This function is available in OCAD 11 Starter.This function is available in OCAD 11 Course Setting.

Choose Select Object and Edit Vertex in the Select menu or click the Select Object and Edit Vertex icon Icon SelectObjectAndEditVertex.PNG in the Editing and Drawing Toolbar to select and edit vertices. The cursor changes to a transparent arrow like on the icon Icon SelectObjectAndEditVertex.PNG. You are now in the Select Object and Edit Vertex mode. Click on an object to select it. The selection looks as follows:
SelectAndEditAVertexSelection.PNG
The characteristics of every vertex are visible in this selection.

Move Single Vertices

Once an object is selected you can move a single vertex of the selected object. Simply drag the desired point to the new position. If you move vertices of Bezier curves, a help line shows a preview of the new curve while dragging.

Edit a Bezier Vertex

Once an object containing Bezier vertices is selected you can edit those.

BezierCurveEditVertex.PNG

Drag a tangent endpoint O to edit the tangent.

Select a Hole in an Area

It is possible to select a hole in an area object by clicking inside the desired hole. Only the vertices of the hole will be marked. You can accomplish editing operations (e.g. Fill, Rotate, Move or Delete) as for a normal area object. Find more about cutting holes on the Edit Object page.

hint If you select an object in the Select Object and Edit Vertex Icon SelectObjectAndEditVertex.PNG mode, you can move it using the arrow keys on the keyboard.

hint If you have enabled the Auto select symbol when selecting object option in the Symbol category of OCAD Preferences, the corresponding symbol is automatically selected when selecting an object. This does not work for a selection of multiple objects.

hint Disable Context menu in drawing area in the GUI (Graphical User Interface) category of OCAD Preferences to switch easily between the current Drawing mode and the Select Object and Edit Vertex mode by a simple click with the right mouse button on the drawing area. If this option is enabled, the context menu appears by clicking on the drawing area with the right mouse button. Read more about the context menu on the OCAD Preferences page.

Select and Edit Multiple Objects Space.PNGThis function is available in OCAD 11 Professional.This function is available in OCAD 11 Orienteering Standard.This function is available in OCAD 11 Starter.This function is available in OCAD 11 Course Setting.

Drag an area in the Icon SelectAndEditObject.PNG Select and Edit Object or Icon SelectObjectAndEditVertex.PNG Select Object and Edit Vertex mode to select all objects which are in it.
You can choose between two modes to select multiple objects in the Select category of OCAD Preferences in the Options menu: Either all objects must be with at least one vertex in the selection or all objects must be completely in the selection.

Two options to select multiple objects: All objects with at least one vertex in the selection or all objects completely in the selection


Alternatively, you can select every object individually by holding the Shift key while clicking the objects.
In the Icon SelectAndEditObject.PNG Select and Edit Object mode it is possible to enlarge or reduce a selection of objects. For that purpose, drag one of the black squares BlackSquare.PNG in the desired direction.
It is also possible to move a selection of objects in both modes. If you move the mouse over the selection the cursor changes its appearance to MousePointerMove.PNG. By clicking and dragging the selection or using the arrow keys you can move it.

hint Enable the Move multiple objects option in the Warnings category of OCAD Preferences to get a warning message when you move multiple objects. Use this option in order to guard against moving multiple objects accidentally.

Select Objects by Symbol Space.PNGThis function is available in OCAD 11 Professional.This function is available in OCAD 11 Orienteering Standard.This function is available in OCAD 11 Starter.

Choose Select Objects by Symbol in the Select menu to select all objects with certain symbols or in a certain layer. As an example you can select all roads. The Select By Symbol dialog box appears.

SelectbySymbolDialog.PNG

All objects with a selected symbol

Choose this option and click on the OK button to select all objects with the selected symbol(s). Select the symbol(s) before you choose the Select Objects by Symbol command. For the example given above, select all road symbols. All roads are selected and you can for example measure their total length or make a modification to them.

All objects in layer

If you import files like PDF, DXF, Adobe Illustrator or OpenStreetMap with layer information, the layer information does not get lost, though OCAD does not support layers as they are known in Adobe Illustrator or similar applications. Choose the All objects in a layer option to select all objects which are in the same layer. Choose a layer in the dropdown list. If you have selected an object of this layer before choosing this command, the layer name will already be filled in. For example, choose the layer which contains all the roads and click the OK button to select all roads.

Unsymbolized objects

Choose this option and click on the OK button to select all Unsymbolized Objects.

Objects with unknown symbol

Choose this option and click on the OK button to select all Objects with Unknown Symbol.

Objects with invalid symbol type

Choose this option and click on the OK button to select all Objects with Invalid Symbol Type.

Graphic objects

Choose this option and click on the OK button to select all Graphic Objects.

Image objects

Choose this option and click on the OK button to select all Image Objects.

Select Objects by Property Space.PNGThis function is available in OCAD 11 Professional.This function is available in OCAD 11 Orienteering Standard.

Choose Select Objects by Property in the Select menu to select objects by particular properties. The Select by Property dialog box appears.

SelectbyPropertyDialogBox.PNG


In the Select field you can choose between two options:

  • The All Objects option means that the selection is made out of all objects on the map.
  • The Objects with a selected symbol option means that the selection is reduced to the objects with a symbol that is selected in the symbol box.


In the Condition field you can impose conditions.

  • Choose a property like Number of vertices, Length [m] in the first box.
  • Choose an operator like < > = in the second box.
  • Enter a condition value in the third box.


Click the Select button to continue.
The Object Information table dialog box appears and the desired objects are selected. The number of selected objects is shown in the header of the dialog. You have now different options:

  • Click the Save Selection button to save the selection.
  • Click the Report button to save a report in a Microsoft Excel (.xls), Text (.txt), Website (.htm) or Microsoft Word (.doc) file.
  • Click the Close button to close the dialog and return to the Select Objects by Property dialog.


Hint.jpg The Object Information and the Select Objects by Property dialog are non-modal dialogs. This means, that you can edit the map without closing the dialogs. If the Object Information dialog box is opened, you can for example select other objects on the map. The object information is refreshed automatically.

Example 1: Select all objects which are longer than 200m.

  1. Choose the All objects option in the Select Objects by Property dialog.
  2. In the Condition field choose Length [m] as the Property, > as an operator and enter the value 200.
  3. Click on the Select button to continue. The Object Information table dialog box appears. All objects longer than 200m are selected and listed in the table dialog box.


Example 2: Select all lakes and ponds with an area smaller or equal than 3000m2.

  1. Select the symbol for a lake and a pond in the symbol box. It is possible to do this even if the Select Objects by Property dialog is opened because it is a non-modal dialog.
  2. Choose the Objects with a selected symbol option in the Select Objects by Property dialog.
  3. In the Condition field choose Area [m2] as the Property, <= as an operator and enter the value 3000.
  4. Click on the Select button to continue. The Object Information table dialog box appears. All lakes and ponds with an area smaller or equal than 3000m2 are selected and listed in the table dialog box.


Select Object by Object Index Space.PNGThis function is available in OCAD 11 Professional.

With this function objects can be selected by their object index. The object index is an internal index for each object and cannot be changed. The object information is shown in the Object Information dialog which can be found in the Select menu.

Choose the Select Object by Object Index command from the Select menu. A dialog appears where you can enter the object index. Click the OK button to select the object.

The first drawn or imported object has the object index 1. The object index is a number and unique in a ocd file.

Select All Space.PNGThis function is available in OCAD 11 Professional.This function is available in OCAD 11 Orienteering Standard.

Choose Select All in the Select menu to select all symbolized (also from protected and hidden symbols), unsymbolized, graphic and image objects. Layout objects are not selected.

Clear Selection Space.PNGThis function is available in OCAD 11 Professional.This function is available in OCAD 11 Orienteering Standard.

Choose Clear Selection in the Select menu to deselect all objects.

Invert Selection Space.PNGThis function is available in OCAD 11 Professional.This function is available in OCAD 11 Orienteering Standard.

Choose Invert Selection in the Select menu to deselect all selected objects and select all unselected object. Layout objects are not selected.

Select Next Object Space.PNGThis function is available in OCAD 11 Professional.This function is available in OCAD 11 Orienteering Standard.

This menu item is only available if an object is already selected. Choose Select Next Object in the Select menu to select an object which is behind an object that is already selected.

Hint.jpg To select an object behind an already selected object you can also keep the Alt or Alt Gr key pressed and click on the already selected object.

Save Selection Space.PNGThis function is available in OCAD 11 Professional.

Choose Save Selection in the Select menu to save the current selection. The Save Selection dialog box appears.

SaveSelection.PNG

Enter the name of the selection and click on the Save button.

hint Choose Select Objects by Symbol in the Select menu to select all objects of the selected symbols.

Reload Selection Space.PNGThis function is available in OCAD 11 Professional.

Choose Reload Selection in the Select menu to select all objects from a saved selection. Choose a saved selection and the Reload Selection dialog appears.

ReloadSelection.PNG

The list of the selected objects with aditional information is shown in the dialog. The number of selected objects is shown in the caption in brackets.

Select one object in the list and OCAD selects this object in the drawing area in the edit mode.

Hint.jpg The Reload Selection function selects also symbolized objects from symbols with the status Protect or Hide.

Edit Selection Space.PNGThis function is available in OCAD 11 Professional.

Choose Edit Selection in the Select menu to rename or delete saved selections.

EditSelection.PNG

Delete a Selection

Select a selection in the Edit Selection dialog and click the Delete button to delete it. Click the Delete all button to delete all selections.

Rename a Selection

Select a selection in the Edit Selection dialog. Then enter a new name for the selection in the Selection name field. Click the Rename button to apply the new name.

Click the OK button to save and quit the Edit Selection dialog. Click the Cancel button to close the Edit Selection dialog without saving any changes.

Select Group Space.PNGThis function is available in OCAD 11 Professional.

If you have Grouped objects on your map, you can select them easily by choosing the Select Group command in the Select menu.


video available [Selection]



Previous Chapter: Drawing an Object

Next Chapter: Edit Object

Back to the Main Page.