Migration von unstrukturierten DTP-Karten: Unterschied zwischen den Versionen

Aus OCAD 11 Wiki - Deutsch
Wechseln zu: Navigation, Suche
(Export for Google Earth (KMZ Google Earth Raster))
(Flächensymbole in OCAD-Punktsymbole umwandeln und redundante Objekte löschen)
 
(21 dazwischenliegende Versionen desselben Benutzers werden nicht angezeigt)
Zeile 1: Zeile 1:
==Migration of unstructured Desktop-Publishing Maps into a GIS==
+
==Anpassung von unstrukturierten Desktop-Publishing-Karten in ein GIS==
  
  
A lot of maps are made with a Desktop Publishing (DTP) software like Macromedia Freehand, Adobe Illustrator or CorelDraw. The advantage of these software programs are that they have wide range of drawing and editing tools, a flexible layer structure creating map content and the map layout within one file and has low cost comparing to GIS (Geographic Information System). However, DTP maps are limited in order to keep the state of the art in digital cartography. The main weaknesses are:
+
Viele Karten werden mit einer Desktop-Publishing (DTP) Software, wie Macromedia Freehand, Adobe Illustrator oder CorelDraw erstellt. Der Vorteil dieser Softwareprogramme ist, dass diese eine grosse Auswahl an Zeichnungs- und Bearbeitungswerkzeugen aufweisen, sie eine flexible Ebenenstruktur für Karte und Kartenlayout besitzen und dass sie im Vergleich zu GIS (Geographic Information System) billiger sind. DTP-Karten sind jedoch limitiert, um auf dem neuesten Stand der Technik der digitalen Kartografie zu bleiben. Die grössten Nachteile sind:
  
# Distortion: DTP maps are often completely or partially distorted due of misplacement of map tiles or vectorization from poorly adjusted background maps. DTP software has no tools to dissolve the distortion according a coordinate reference system or reference points.
+
# Verzerrung: DTP-Karten sind meistens auf Grund von falsch platzierten Kacheln oder der Vektorisierung von kaum angepassten Hintergrundkarten komplett oder teilweise verzerrt. DTP-Programme haben keine Werkzeuge, um die Verzerrung mit Hilfe eines Koordinatenbezugsystems oder Referenzpunkten aufzuheben.
# No Georeferencing: DTP Software has no own coordinates reference system to exchange georeference map data. This restricts the use of georeferenced data (e.g. geodata server, geo-portals, and OpenStreetMap data) which is nowadays state of the art either to enhance the map, use the map for navigation or for GPS localization.
+
# Keine Georeferenzierung: DTP-Softwares besitzen kein eigenes Koordinatenbezugssystem, um georeferenzierte Kartendaten auszutauschen. Dies schränkt die Nutzung von georeferenzierten Daten (z.B. Geodatenserver, Geo-Portale und OpenStreetMap-Daten) ein, was heutzutage eine wichtige Funktion ist, entweder um die Karte aufzuwerten, sie für die Navigation zu verwenden oder für GPS-Lokalisierungen.
# Unstructured map set-up: The flexible layer structure and symbol definitions lead towards maps with a poor set-up. Single map objects are easily moved away from the layer where they should belong in order to achieve a better graphic representation (e.g. bridges and tunnels). Moreover, point features are represented as area features. The result is, that such maps have a lot of redundant data which are on the one side very time consuming to maintain and on the other hand do not fit into GIS properly.
+
# Unstrukturierter Kartenaufbau: Die flexible Ebenenstruktur und Symboldefinitionen führen zu einem schlechten Aufbau. Einzelne Kartenobjekte können einfach von der Ebene an einen anderen Ort verschoben werden, um eine bessere grafische Erscheinung zu erzielen (z.B. Brücken und Tunnel). Ausserdem werden Punktobjekte als Flächenobjekte dargestellt. Das Resultat ist, dass solche Karten viele überflüssige Daten aufweisen, die einerseits mühsam zu verwalten sind und andernseits nicht richtig in ein GIS passen.
# No specific cartographic drawing and editing tools: DTP Software has no own specific cartographic drawing and software tools to support efficient map production, like line tracing, automatically block out of street intersection or the influencing the dashes of lines.
+
# Keine spezifischen kartographischen Zeichnungs- und Bearbeitungswerkzeuge: DTP-Softwares besitzen keine eigenen spezifischen kartographischen Zeichnungs- und Bearbeitungswerkzeuge, wie Linienverfolgung, automatisches Blockout von Strassenkreuzungen oder Beeinflussung von gestrichelten Linien, um die effiziente Kartenproduktion zu unterstützen.
# No data base connection: DTP Software has no own data base connection to store additional information of map objects like date of capturing, issuer or last editing.  
+
# Keine Datenbankverbindungen: DTP-Softwares besitzen keine eigenen Datenbankverbindungen, um zusätzliche Informationen von Kartenobjekten, wie Datum der Aufnahme, Herausgeber oder letzte Bearbeitung, zu speichern.
  
Many map publishers have produced thousands of DTP maps from the start of the cycle of digital cartography. Nowadays, they are worried that they could get stucked in a dead end, because DTP software has obvious weakness or isn’t any more supported.
+
Viele Kartenveröffentlicher produzierten am Anfang der Zeit der digitalen Kartografie tausende von DTP-Karten. Heute fürchten sie, dass sie in eine Sackgasse geraten können, denn DTP-Softwares haben klare Nachteile und werden nicht mehr unterstützt.
  
For that reason, OCAD Inc. developed in collaboration with Huber Cartography, Munich, Germany a workflow with its cartographic software OCAD 10, to save investments in DTP maps by migrating them into its cartographic software or even into a GIS: First, the DTP map must be imported through a PDF file. Then the distortion will be dissolved and the map georeferenced. In a next step, the imported map layer will be converted into a set of symbol, which has been created by the cartographic software. The conversation has the effect that redundant will be removed. Point features which are still represented as area features must be converted into single point features. Now, all map objects can be connected to a data base, which can by edited on the fly. With this workflow the DTP map has been structured in a way that it fits into a GIS environment or could be enhanced with other geodata and maintained with specific cartographic drawing and editing tools in its migrated cartographic software as well. This workflow has been implemented by Huber Cartography successfully.
+
Aus diesem Grund entwickelte OCAD AG in Zusammenarbeit mit Huber Kartografie, München DE einen Arbeitsablauf in der OCAD-Software, um Daten von DTP-Karten durch eine Anpassung in die Kartografie-Software oder sogar in ein GIS zu erhalten: Zu erst muss die DTP-Karte als PDF-Datei importiert werden. Danach wird die Verzerrung aufgehoben und die Karte wird georeferenziert. Im nächsten Schritt werden die importierten Ebenen in Symbole eines Symbolsatzes der Kartografiesoftware umgewandelt. Diese Umwandlung hat das Resultat, dass überflüssige Daten entfernt werden. Punktobjekte, welche immer noch als Flächenobjekte abgebildet werden, müssen in einzelne Punktobjekte umgewandelt werden. Alle Kartenobjekte können nun mit einer Datenbank verbunden werden. Mit diesem Arbeitsablauf wird die DTP-Karte so strukturiert, dass sie in eine GIS-Umgebung passt oder mit weiteren Geodaten verbessert und mit spezifischen kartografischen Zeichnungs- und Bearbeitungswerkzeugen in der Software angepasst werden kann. Dieser Arbeitsablauf wurden von Huber Kartografie erfolgreich implementiert.
  
  
Read full text: http://www.ocad.com/public/2011-02-11_longTxt_icc2011_migrationDTPmaps_intoGIS.pdf
+
Ganzer Text (in Englisch): http://www.ocad.com/public/2011-02-11_longTxt_icc2011_migrationDTPmaps_intoGIS.pdf
  
==Open OCAD file==
+
==OCAD-Datei öffnen==
  
Open ''crete-emty.ocd file''.
+
Öffnen Sie die Datei ''kreta_leer.ocd''.
The file is located in the training data in the following directory ''crete_ocad''.
+
Die Datei befindet sich im Verzeichnis ''kreta_ocad''.
  
 
: [[File:WorkflowCrete_01.PNG]]
 
: [[File:WorkflowCrete_01.PNG]]
  
  
===Set Map Scale===
+
===Kartenmassstab bestimmen===
  
Set scale to 1:100 000 ('''Map''' -> '''Set Scale and Coordinate System''').
+
Setzen Sie den Kartenmassstab auf 1:100000 ('''Karte''' -> '''Massstab und Koordinatensystem''').
  
 
: [[File:WorkflowCrete_02.PNG]]
 
: [[File:WorkflowCrete_02.PNG]]
Zeile 34: Zeile 34:
  
  
==Definition of a Symbol Set==
+
==Symbolsatz definieren==
  
In the open OCAD file is already defined a symbol set. Exemplary in this document is the definition of the new point symbol ''Point of interest'' is described.
+
In der OCAD-Datei wurde bereits ein Symbolsatz definiert. In dieser Anleitung wird die Definition des Punktsymbols '''Sehenswürdigkeit''' beschrieben.
  
  
===Open scanned legend as background map===
+
===Eingescannte legende als Hintergrundkarte öffnen===
  
Open the TIFF file ''legende_crete.tif'' from the directory ''crete_backgroundmaps'' as backgroundmap ('''Backgroundmap''' -> '''Open''').
+
Öffnen Sie die TIFF-Datei ''Legende_kreta.tif'' aus dem Verzeichnis ''lrete_backgroundmaps'' als Hintergrundkarte ('''Hintergrundkarte''' -> '''Öffnen''').
  
  
===Create New Symbol===
+
===Neues Symbol erstellen===
  
'''Symbol''' -> '''New'''
+
'''Symbol''' -> '''Neu'''
  
Choose '''Point Symbol''' from '''New Symbol''' dialog box:
+
Wählen Sie im Dialog '''Neues Symbol''' die Option '''Punktsymbol''':
  
 
: [[File:WorkflowCrete_03.PNG]]
 
: [[File:WorkflowCrete_03.PNG]]
Zeile 54: Zeile 54:
 
-> '''OK'''
 
-> '''OK'''
  
Enter symbol number and symbol description. Click the button '''Edit''':
+
Geben Sie Symbolnummer und -beschreibung ein. Klicken Sie auf '''Bearbeiten''':
  
 
: [[File:WorkflowCrete_04.PNG]]
 
: [[File:WorkflowCrete_04.PNG]]
  
The symbol editor will show.
+
Der Symboleditor erscheint.
  
'''View''' -> Hide '''Show Entire Map''' and '''Show Map Grid'''
+
'''Ansicht''' -> '''Ganze Karte zeigen''' und '''Bildschirm-Gitter anzeigen'''
  
In the next step, the legend symbol must be placed into the origin of coordinates of the symbol editor (red arrow in fig):
+
: [[File:WorkflowCrete_04_01.PNG]]
  
'''Background Map''' -> '''Adjust''' (Shortcut F):
+
Im nächsten Schritt muss das Legendensymbol im Ursprung der Koordinaten des Symboleditors platziert werden (roter Pfeil in Abbildung):
# Mouse click '''Point of Interest''' in background map.
 
# Mouse click origin of coordinates from drawing area.
 
# Execute move with enter key.
 
  
: [[File:Hint.jpg|hint]] -Most of the fine-tuning is done in several adjust steps.
+
'''Hintergrundkarte''' -> '''Abstimmen''' (Shortcut F9):
:: -For fine-tuning it is recommended that the coordinate grid map [[File:Icon_ShowGrid.PNG|show grid]] is shown.
+
# Mausklick auf das Symbol '''Sehenswürdigkeit''' in der Hintergrundkarte.
 +
# Mausklick auf den Mittelpunkt der Koordinaten des Editors.
 +
# Drücken Sie '''Enter''', um den Vorgang ausuzuführen.
 +
 
 +
: [[File:Hint.jpg|hint]] -Die meisten Feinanpassungen können Sie mit mehreren Abstimm-Schritten durchführen.
 +
:: -Für Feinabstimmungen empfehlen wir Ihnen, das Bildschirmgitter [[File:Icon_ShowGrid.PNG|show grid]] anzuzeigen.
  
 
: [[File:WorkflowCrete_06.PNG]]
 
: [[File:WorkflowCrete_06.PNG]]
  
Select the geometry ''Area'' and the Color ''0: Pikto Orange'' in symbol editor:
+
Selektieren Sie die Geometrie ''Fläche'' und die Farbe ''0: Pikto Orange'' im Symbol-Editor:
  
 
: [[File:WorkflowCrete_07.PNG]]
 
: [[File:WorkflowCrete_07.PNG]]
  
Then just draw the symbol with the straight line mode [[File:Icon_StraightLineMode.PNG]] from the drawing tool.
+
Zeichnen Sie danach das Symbol mit dem Geraden-Modus [[File:Icon_StraightLineMode.PNG]] nach.
  
 
: [[File:WorkflowCrete_08.PNG]]
 
: [[File:WorkflowCrete_08.PNG]]
  
: [[File:Hint.jpg|hint]] Click '''Make screenshot for symbol icon''' rather than to design a icon.
+
: [[File:Hint.jpg|hint]] Klicken Sie auf '''Screenshot für Symbol-Icon erstellen''', um das Icon automatisch zu erstellen.
  
-> '''Close''' symbol editor
+
-> '''Schliessen''' Sie den Symboleditor.
  
The dialog box ''Point Symbol'' is shown again.
+
Die Dialogbox ''Punktsymbol'' wird wieder angezeigt.
  
-> '''Icon'''
+
-> '''Schaltfläche'''
  
  
Create an Icon:
+
Erstellen Sie ein Symbol-Icon:
  
 
: [[File:WorkflowCrete_09.PNG]]
 
: [[File:WorkflowCrete_09.PNG]]
Zeile 97: Zeile 99:
 
-> '''OK'''
 
-> '''OK'''
  
The dialog box ''Point Symbol'' is shown again.
+
Die Dialogbox ''Punktsymbol'' wird wieder angezeigt.
 
   
 
   
 
-> '''OK'''
 
-> '''OK'''
  
  
Remove background map ('''Backgroundmap''' -> '''Manage'''):
+
Entfernen Sie die Hintergrundkarte ('''Hintergrundkarte''' -> '''Verwalten'''):
  
 
: [[File:WorkflowCrete_10.PNG]]
 
: [[File:WorkflowCrete_10.PNG]]
  
-> '''Remove''' and '''Close''' the dialog
+
-> '''Entfernen''' und Dialog '''Schliessen'''.
  
  
OCAD learning videos:
+
OCAD Lernvideos:
 
: [[File:Camera.jpg|video available]][http://www.ocad.com/howtos/64.htm Different point symbols]
 
: [[File:Camera.jpg|video available]][http://www.ocad.com/howtos/64.htm Different point symbols]
 
: [[File:Camera.jpg|video available]][http://www.ocad.com/howtos/44.htm Different lines symbols]
 
: [[File:Camera.jpg|video available]][http://www.ocad.com/howtos/44.htm Different lines symbols]
Zeile 115: Zeile 117:
 
: [[File:Camera.jpg|video available]][http://www.ocad.com/howtos/62.htm Different text symbols]
 
: [[File:Camera.jpg|video available]][http://www.ocad.com/howtos/62.htm Different text symbols]
  
==Import DTP map as PDF==
+
==DTP-Karte als PDF importieren==
  
Import PDF file ''ICV_crete_Mapsheet1_West_fhd.pdf'' from the directory ''crete_fh'' ('''File''' -> '''Import''').
+
Importieren Sie die PDF-Datei ''ICV_Kreta_Blatt1_West_fhd.pdf'' aus dem Verzeichnis ''kreta_fh'' ('''Datei''' -> '''Importieren''').
  
 
: [[File:WorkflowCrete_11.PNG]]
 
: [[File:WorkflowCrete_11.PNG]]
  
-> '''Open'''
+
-> '''Öffnen'''
 
 
The import side which should be imported must be specified, because it is multi-page PDF.
 
  
 +
Da es sich um ein PDF mit mehreren Seiten handelt, muss die Importseite angegeben werden.
 
: [[File:WorkflowCrete_12.PNG]]
 
: [[File:WorkflowCrete_12.PNG]]
  
 
-> '''OK'''
 
-> '''OK'''
  
'''View''' -> '''Show Entire Map''' [[File:Icon_ShowEntireMap.PNG|show entire map]]
+
'''Ansicht''' -> '''Ganze Karte zeigen''' [[File:Icon_ShowEntireMap.PNG|show entire map]]
  
The import map is displayed. However the map is not georeferenced.
+
Die importierte Karte wird angezeigt. Die Karte ist jedoch noch nicht georeferenziert.
  
:
+
: [[File:WorkflowCrete_12_01.PNG]]
  
==Open georeferenced Background Map==
+
==Georeferenzierte Hintergrundkarte öffnen==
  
Open the georeferenced TIFF file ''crete_osm_import_100000.tif'' from the directory ''crete_osm'' as background map (''Backgroundmap'' -> ''Open'').
+
Öffnen Sie die georeferenzierte TIFF-Datei ''kreta_osm_importiert_100000.tif'' aus dem Verzeichnis ''kreta_osm'' als Hintergrundkarte (''Hintergrundkarte'' -> ''Öffnen'').
  
Because it is a georeferenced background map, a dialog box appears with the question if the new shift (horizontally and vertically according to the Easting and Northing) shall be used as the card center.
+
Da es sich um eine georeferenzierte Hintergrundkarte handelt, wird eine Dialogbox angezeigt, bei der Sie zwischen einer neuen Verschiebung (horizontal und vertikal entsprechend dem Nord- und Ostwert) und der existierenden Verschiebung wählen müssen.
  
 
: [[File:WorkflowCrete_14.PNG]]
 
: [[File:WorkflowCrete_14.PNG]]
  
-> '''Ok'''
+
-> '''OK'''
 
 
'''View''' -> '''Show Entired Map''' [[File:Icon_ShowEntireMap.PNG|show entire map]]
 
  
The Crete map the the georeferenced background map are shown. But the Crete map is still not correctly georeferenced.
+
'''Ansicht''' -> '''Ganze Karte anzeigen''' [[File:Icon_ShowEntireMap.PNG|show entire map]]
  
The interactive georeferencing from the Crete map success in the next section.
+
Die Karte von Kreta und die georeferenzierte Hintergrundkarte werden angezeigt. Die Karte von Kreta ist jedoch immer noch nicht richtig georeferenziert.
  
:
+
: [[File:WorkflowCrete_14_02.PNG]]
  
==Georeferencing and Rubbersheeting==
+
==Georeferenzierung und Rubbersheeting==
  
Change the '''View''' into '''Draft Mode''' ('''View''' -> '''Draft Mode''').
+
Wechseln Sie die '''Ansicht''' zu '''Entwurfsmodus''' ( '''Ansicht''' -> '''Entwurfsmodus''').
  
In the toolbar, a bar appears with two controllers. With the upper controller (M=Map) can adjust the transparency of the map and with the lower controller (B=Background Map) can adjust the transparency of the background map.
+
In der Werkzeugsleiste wird ein Schieberegler angezeigt. Mit dem oberen Regler (M = Map) können Sie die Transparenz der Karte und mit dem unteren (B = Background Map) die Transparenz der Hintergrundkarte einstellen.
  
 
: [[File:DraftModeSlider.png]]
 
: [[File:DraftModeSlider.png]]
  
===Coarse adjustment using Affine transformation===
+
===Grobe Abstimmung mit Affintransformation===
  
In a first step, the imported map was fitted coarse with an affine transformation in the georeferenced background map ('''Map''' -> '''Transform''' -> '''Affine''').
+
In einem ersten Schritt, muss die importierte karte mit einer Affin-Transformation verschoben werden ('''Karte''' -> '''Transformieren''' -> '''Affin''').
  
:
+
: [[File:WorkflowCrete_16.PNG]]
  
# Mouse click into the map.
+
# Klicken Sie an einen Ort in der Karte.
# Mouse click on the appropriate point on the background map.
+
# Klicken sie an denselben Standort in der Hintergrundkarte.
# Execute transformation with enter key.
+
# Führen Sie die Transformation mit der Enter-Taste aus.
  
[[File:Hint.jpg|hint]] At the affine transformation the maximum of 12 reference points can be defined, by repeating step 1 and 2 until the transformation is triggered by the enter button.
+
[[File:Hint.jpg|hint]] Für die Affin-Transformation können bis zu 12 Referenzpunkte definiert werden, indem Sie Schritt 1 und 2 immer wiederholen und ganz am Schluss mit der Enter-Taste die Transformation durchführen.
  
===Fine adjustment with Rubbersheeting===
+
===Feinabstimmung mit Rubbersheeting===
  
In the second step the map fitted as exactly as possible with rubbersheeting transformation on the georeferenced background map ('''Map''' -> '''Transform''' -> '''Rubbersheeting''')
+
Im zweiten Schritt wird die Karte so genau wie möglich mit Hilfe der Rubbersheeting-Transformation der georeferenzierten Hintergrundkarte abgestimmt. ('''Karte''' -> '''Transformieren''' -> '''Rubbersheeting''')
  
  
OCAD learning videos:
+
OCAD Lernvideos:
: [[File:Camera.jpg|video available]][http://www.ocad.com/howtos/127.htm Rubbersheeting Transformation]
+
: [[File:Camera.jpg|video available]][http://www.ocad.com/howtos/127.htm Rubbersheeting-Transformation]
  
First the rubbersheeting perimeter must be determined ('''Define''' -> Draw rubbersheeting perimeter on map)
+
Zu erst muss der Rubbersheeting Perimeter festgelegt werden ('''Festlegen''' -> den Bereich in der Karte zeichnen)
  
:
+
: [[File:WorkflowCrete_17.PNG]]
  
Perimeter is displayed as a blue frame in the drawing area:
+
Der Bereich wird mit einem blauen Rahmen im Zeichnungsfenster markiert:
  
:
+
: [[File:WorkflowCrete_18.PNG]]
  
When a perimeter is defined, rubbersheeting points can be added interactively or from loaded from a file.
+
Wenn ein Perimeter definiert ist, können Rubbersheetingpunkte interaktiv hinzugefügt oder von einer Datei geladen werden.
  
:
+
: [[File:WorkflowCrete_19.PNG]]
  
Add rubbersheeting points interactive:
+
Rubbersheetingpunkte interaktiv hinzufügen:
  
# Mouse click into the map.
+
# Mausklick auf die Karte.
# Mouse click on the appropriate point on the background map.
+
# Mausklick auf den entsprechenden Ort in der Hintergrundkarte
  
Rubbersheeting points are shown with a red and green crosshair and a blue connection line. In the transformation, the objects moved from the red to the green dot.
+
Rubbersheetingpunkte werden mit einem roten und grünen Fadenkreuz, sowie einer Verbindungslinie abgebildet. Beim Transformationsprozess wird der rote zum grünen Punkt geschoben.
  
:
+
: [[File:WorkflowCrete_20.PNG]]
  
Depending on the needs the points can be deactivated, removed or saved. The deactivation is done by mouse click on the first column in the table. Unused points are shown gray in the drawing area.
+
Punkte können deaktiviert, entfernt oder gespeichert werden. Sie können einen Punkt mit einem Klick in die erste Spalte deaktivieren. Deaktivierte Punkte werden im Zeichnungsfenster in grau angezeigt.
  
:
+
: [[File:WorkflowCrete_21.PNG]]
  
Execute the transformation by clicking the  '''Transform''' button. <br>
+
Führen Sie die Transformation mit '''Transformieren''' aus.<br>
If the result is satisfactory, the dialogue can be closed. <br> Otherwise there are the following possibilities:
+
Wenn das Resultat befriedigend ist, können Sie den Dialog schliessen.<br>  
 +
Ansonsten haben Sie die folgenden Möglichkeiten:
  
* Undo the transformation an optimize rubbersheeting points (add, deactivate, delete)
+
* Machen Sie die Transformation rückgängig und optimieren Sie die Punkte (hinzufügen, deaktivieren, entfernen)
* Use the result as a starting point for further transformation with new points.
+
* Verwenden Sie das Ergebnis als Startpunkt für weitere Transformationen mit neuen Punkten.
 +
==PDF-Bildobjekte in OCAD-Objekte transformieren==
  
==Transform PDF image objects in OCAD objects==
+
===Automatische Konvertierung===
  
===Automatic conversion===
 
  
 +
Mit der Funktion '''Importierte Ebenen in Symbole umwandeln''' ('''Karte''' -> '''Importierte Ebenen in Symbole umwandeln''') können die einzelnen Objekte automatisch in OCAD-Symbole umgewandelt werden.
  
With the function '''Convert Imported Layers to Symbols''' ('''Map''' -> '''Convert Imported Layers to Symbols''') icons can be automatically converted due to their affiliation with the appropriate symbol into OCAD objects with the appropriate symbol.
+
In der Dialogbox '''Importierte Ebenen in Symbole umwandeln''', müssen Sie die Übersetzungstabelle ''kreta.crt'' aus dem Verzeichnis ''kreta_crt'' laden.
  
In the dialog box '''Convert Imported Layers to Symbols''' the translation table crete.crt from the crete_crt directory needs to be loaded.
+
: [[File:WorkflowCrete_22.PNG]]
  
:
+
-> '''Ausführen'''
  
-> '''Execute'''
+
===Manuelle Konvertierung===
  
===Manual conversion===
+
Bei der automatischen Konvertierung wurden zum Teil Objekte, die in falschen Ebenen liegen, falschen Symbolen zugeteilt. Hier ist es zum Beispiel der griechische Name für die Attraktion '''Tilissos''', welcher fälschicherweise in schwarzer und nicht in roter Schrift erscheint.
  
In the automatic conversion wrong symbols assigned from objects lying on wrong layers.  In the example below, the Greek name of the attraction '''Tilissos''' is falsely attributed to the layer with the black instead of red font.
+
: [[File:WorkflowCrete_23.PNG]]
  
:
+
Selektieren Sie das Objekt:
  
Select object:
+
: [[File:WorkflowCrete_24.PNG]]
  
:
+
Selektieren Sie das korrekte Symbol aus der Symbolbox:
  
Select correct symbol from symbol box:
+
: [[File:WorkflowCrete_25.PNG]]
  
:
+
Klicken Sie auf '''Symbol wechseln''' in der Standard-Werkzeugleiste, um dem Objekt das richtige Symbol zuzuteilen.
  
Click '''Change Symbol''' in stadard toolbar to assign the object to the right symbol
+
: [[File:WorkflowCrete_26.PNG]]
  
:
+
==Flächensymbole in OCAD-Punktsymbole umwandeln und redundante Objekte löschen==
  
==Transform area-point objects in OCAD point objects and delete redundant objects==
+
In DTP-Programmen werden Punktobjekte oft als Flächenobjekte definiert. Diese Objekte müssen daher in Punktobjekte umgewandelt werden. Diese besitzen nur Koordinaten und können beim Tracking einfach verschoben oder gelöscht werden.
  
In DTP programms point objects are often defined as an area object. Thus make a situation worse by the map tracking. Therefore, these objects should be converted into point objects. These have only coordinates and can be easily deleted or moved at a tracking.
+
: [[File:WorkflowCrete_26_01.PNG]][[File:WorkflowCrete_27.PNG]]
  
:
+
Bei der automatischen Konvertierung wurden diese Symbole als Umgehung in Flächenobjekte umgewandelt (z.B. ''1605.1 Kapelle Fläche''). Im Symbolsatz sind diese Symbole als einzelne Punkt- und Flächensymbole definiert.
 +
Selektieren Sie zu erst alle Objekte mit dem Symbol ''1605.1 Kapelle Fläche'' (Symbolbox -> Symbol Höhenkote Fläche -> Kontextmenü ->  '''Selektieren nach Symbol''').
  
In the automatic conversion these objects have been transformed as a workaround in area objects (for example ''1601.1 chapel area''). In the symbol set they are defined as single point and area symbols.
+
: [[File:WorkflowCrete_28.PNG]]
First select all objects with the area symbol ''1601.1 chapel area'' (Symbolbox -> symbol 1601.1 chapel area -> context menu -> '''Select Objects by Symbol''').
 
  
:
+
Danach wandeln Sie die Objekte in Punktobjekte um ('''Karte''' -> '''Linien- oder Flächenobjekte zu Punktobjekten konvertieren'''), während Sie das Symbol ''1605.1 Kapelle Fläche'' selektiert haben.
  
Then the conversion occur in a point object('''Map''' -> '''Convert Area or Line Objects to Point Objects'''), while the symbol ''1601.1 chapel area'' have been selected.
+
: [[File:WorkflowCrete_29.PNG]]
  
:
+
-> '''Ausführen'''
  
-> '''Execute'''
+
[[File:Hint.jpg|hint]] Falls Sie Signaturen, die aus mehreren Flächen bestehen, importiert haben, müssen Sie vor der Konvertierung überschüssige Flächen entfernen, sodass nicht mehrere Punktobjekte am gleichen Ort erstellt werden.
  
[[File:Hint.jpg|hint]] In case of imported signatures, consisting of multiple surfaces, before the conversion the surplus areas have to be removed, so that the equivalent to only one object is created to the appropriate place.
+
Dieser Prozess wird mit dem Beispiel '''Windmühle''' erklärt. Die importierte Signatur für Windmühle besteht aus fünf Teilen: einem Turm und vier Rotorenblätter:
  
This process is explained using the example of the windmill. The imported windmill signatures are part of five faces: one tower and four rotor blades:
+
: [[File:WorkflowCrete_30.PNG]]
  
:
+
Vor der Konvertierung in ein Punktobjekt müssen zu erst alle vier Rotorenblätter selektiert und entfernt werden.
  
Befor converting into a point object the four rotor blades of all windmills have to be selected and deleted
+
Selektieren Sie das Symbol 1702.1 Windmühle Fläche in der Symbolbox. <br> Wählen Sie die Funktion '''Selektieren nach Eigenschaft''' ('''Selektieren''' -> '''Selektieren nach Eigenschaft''').
  
Select the symbol 1702.1 windmill area in sybmol box. <br> Choose the function '''Select Object by Property''' ('''Map''' -> '''Select Objects by Property''').
+
Einstellungen:<br>
 +
Selektieren: Objekte mit einem selektierten Symbol<br>
 +
Bedingung: Anzahl Stützpunkte = 4
  
Settings:
+
: [[File:WorkflowCrete_31.PNG]]
Select: Object with a selected symbol
 
Condition: Number of vertices = 4
 
  
:
+
-> '''Selektieren''' und Dialog '''Schliessen'''
  
-> '''Select''' and '''Close''' dialog box
+
Die Rotorenblätter von allen Windmühlen werden selektiert.
  
The rotor blades of all windmills were selected.
+
: [[File:WorkflowCrete_32.PNG]][[File:WorkflowCrete_32_01.PNG]]
  
:
+
Löschen Sie diese mit der '''Delete'''-Taste
  
Delete selected objects with '''Delete''' button.
+
: [[File:WorkflowCrete_33.PNG]][[File:WorkflowCrete_33_01.PNG]]
  
:
+
Die verbleibenden Flächenobjekte können nun wie beschrieben in Punktobjekte konvertiert werden.
  
The ramaining area objects can now be transformed into point objects as described in the first part of the chapter.
+
: [[File:WorkflowCrete_33_02.PNG]]
  
  
===Delete redundant objects===
+
===Redundante Objekte löschen===
  
There are redundant objects in the immported map. So, for example, streets consist of two or more geometrically identical lines. In OCAD these complex lines can be mapped with a line object. Thus the redundant objects be unnecessary  and can be deleted.
+
Die importierte Karte enthält viele redundante (überflüssige) Objekte, wie zum Beispiel Strassen, die aus zwei oder mehr geometrisch identischen Linien bestehen. In OCAD können diese komplexen Linien mit einem einzigen Linienobjekt aufgenommen werden. Daher sind diese Objekte überflüssig und können entfernt werden.
  
First select all objects ('''Symbol box''' -> ''Symbol 1.0 Skelett'' -> '''context menu''' -> '''Select Objects by Symbol''').
+
Selektieren Sie zu erst alle Objekte ('''Symbolbox''' -> ''Symbol 1.0 Skelett'' -> '''Kontextmenü''' -> '''Selektieren nach Symbol''').
  
:
+
: [[File:WorkflowCrete_34.PNG]]
  
Delete selected objects with delete button or [[File:Icon_Delete.PNG|delete]].
+
Entfernen Sie die selektierten Objekte mit der '''Delete'''-Taste oder [[File:Icon_Delete.PNG|delete]].
  
==Attach Database==
+
==Datenbank anhängen==
  
In OCAD 10 Proffesional is it possible to connect the map or its objects to a database. A new database must be define ('''Database''' -> '''Manage Database Connections''')
+
In OCAD 10 Proffesional ist es möglich, die Karte oder deren Objetke mit einer Datenbank zu verbinden. Eine neue Datenbank muss definiert werden ('''Datenbank''' -> '''Datenbankverbindungen verwalten''').
  
:
+
: [[File:WorkflowCrete_35.PNG]]
  
-> '''New'''
+
-> '''Neu'''
  
Give the connection a name and select the option '''Use existing datasource'''
+
Geben Sie den Namen der Verbindung ein und selektieren Sie die Option '''Bestehende Datenquelle benutzen'''.
  
:
+
: [[File:WorkflowCrete_36.PNG]]
  
 
-> '''OK'''
 
-> '''OK'''
  
Select a database file.
+
Selektieren Sie eine Datenbankdatei.
  
:
+
:: [[File:WorkflowCrete_37.PNG]]
  
-> '''Browse'''
+
-> '''Durchsuchen'''
  
Open the file ''crete.cls'' from the directory ''crete_db''.
+
Öffnen Sie die Datei ''kreta.xls'' aus dem Verzeichnis ''kreta_db''.
  
:
+
: [[File:WorkflowCrete_38.PNG]]
  
Select the table ''wamu§'' and the field ''ID'' as a key field.
+
Wählen Sie die Tabelle ''wamu§'' und das Schlüsselfeld ''ID''.
  
:
+
: [[File:WorkflowCrete_39.PNG]]
  
Select all water mills ('''Symboleditor''' -> '''context menu''' -> '''Select Objcts by Symobls''':
+
Selektieren Sie alle Wassermühlen ('''Symbolbox''' -> '''Kontextmenü''' -> '''Selektieren nach Symbol''')
  
:
+
: [[File:WorkflowCrete_40.PNG]]
  
Create database connection für select water mills ('''Database''' -> Create and Update Records''').
+
Erstellen Sie eine Datenbankverbindung für die selektierten Wassermühlen ('''Datenbank''' -> '''Datenbankeinträge erstellen und aktualisieren''').
  
Dataset: ''Water mills''
+
Verbindung: ''Wassermühlen''
  
:
+
: [[File:WorkflowCrete_41.PNG]]
  
 
-> '''OK'''
 
-> '''OK'''
  
Search the water-mill due to the key field ('''Find''' -> enter '''Key''')
+
Suchen Sie die Windmühle mit Hilfe des Schlüsselfeldes ('''Suchen''' -> Schlüsselwert eingeben).
  
:
+
: [[File:WorkflowCrete_42.PNG]]
  
 
->'''OK'''
 
->'''OK'''
  
Edit the corresponding database entries in the database box:
+
Bearbeiten Sie die entsprechenden Datenbankeinträge in der Datenbankbox.
  
:
+
: [[File:WorkflowCrete_43.PNG]]
  
:[[File:Camera.jpg|video available]] [http://www.ocad.com/howtos/46.htm Database Basics]
+
:[[File:Camera.jpg|video available]] [http://www.ocad.com/howtos/46.htm Databanken - Basics]
  
==Export to a GIS ( SHP or DXF)==
+
==GIS exportieren ( SHP oder DXF)==
  
The Map or parts thereof can be exported as shape file or DXF and reused in geographical information system or CAD programs.
+
Die Karte oder Teile der Karte können als Shape- oder DXF-Datei exportiert und in GIS-Systemen oder CAD-Programmen verwendet werden.
  
'''File''' -> '''Export''' -> '''Shape''' -> '''Point objects''' -> '''Objects in dataset: Water mills'''
+
'''Datei''' -> '''Exportieren''' -> '''Shape''' -> '''Punktobjekte''' -> '''Objekte in der Datenbank: Windmühlen'''
  
:
+
: [[File:WorkflowCrete_44.PNG]]
  
 
-> '''OK'''
 
-> '''OK'''
  
Save file as ''crete_wamu.shp''
+
Speichern Sie die Datei unter ''kreta_wamu.shp''
  
:
+
: [[File:WorkflowCrete_45.PNG]]
  
:[[File:Camera.jpg|video available]] [http://www.ocad.com/howtos/51.htm Export Shape File]
+
:[[File:Camera.jpg|video available]] [http://www.ocad.com/howtos/51.htm Shape exportieren]
  
==Export for Google Earth (KMZ Google Earth Raster)==
+
==Für Google Earth exportieren (KMZ Google Earth Raster)==
  
The map or parts thereof can also be exported as a KMZ file and reused in Google Earth or GPS device. For this export a coordinate system must be absolutely defined.
+
Die Karte oder Teile der Karte  können als KMZ-Datei exportiert und in Google Earth oder einem GPS-Gerät verwendet werden. Für diesen Export muss ein Koordinatensystem definiert sein.
  
'''Map''' -> '''Set Scale and Coordinate System''' -> '''Choose''' -> '''Coordinate system: UTM''' -> '''Zone: Zone 35 North'''
+
'''Karte''' -> '''Massstab und Koordinatensystem''' -> '''Auswählen''' -> '''Koordinatensystem: UTM''' -> '''Zone: Zone 35 North'''
  
'''File''' -> '''Export''' -> '''KMZ Google Earth (Raster)'''
+
'''Datei''' -> '''Exportieren''' -> '''KMZ Google Earth (Raster)'''
  
Make export settings and choose map sector:
+
Nehmen Sie Exporteinstellungen vor und wählen Sie den Kartenausschnitt:
  
:
+
: [[File:WorkflowCrete_46.PNG]]
  
 
-> '''OK'''
 
-> '''OK'''
  
Save export file as ''crete.kmz'':
+
Speichern Sie die Datei als ''kreta.kmz'':
  
:
+
: [[File:WorkflowCrete_47.PNG]]
  
-> '''Save'''
+
-> '''Speichern'''
  
:[[File:Camera.jpg|video available]] [http://www.ocad.com/howtos/125.htm KMZ Google Earth export]
+
:[[File:Camera.jpg|video available]] [http://www.ocad.com/howtos/125.htm KMZ Google Earth Export]
  
==Appendix==
+
==Anhang==
  
Settings of the PDF export from Freehand, for the best import into OCAD:
+
Einstellungen des PDF-Exports aus Freehand für das beste Resultat des Imports in OCAD:
  
 
: [[File:Freehand_ExportPDF_Settings.gif]]
 
: [[File:Freehand_ExportPDF_Settings.gif]]

Aktuelle Version vom 12. September 2013, 10:36 Uhr

Anpassung von unstrukturierten Desktop-Publishing-Karten in ein GIS

Viele Karten werden mit einer Desktop-Publishing (DTP) Software, wie Macromedia Freehand, Adobe Illustrator oder CorelDraw erstellt. Der Vorteil dieser Softwareprogramme ist, dass diese eine grosse Auswahl an Zeichnungs- und Bearbeitungswerkzeugen aufweisen, sie eine flexible Ebenenstruktur für Karte und Kartenlayout besitzen und dass sie im Vergleich zu GIS (Geographic Information System) billiger sind. DTP-Karten sind jedoch limitiert, um auf dem neuesten Stand der Technik der digitalen Kartografie zu bleiben. Die grössten Nachteile sind:

  1. Verzerrung: DTP-Karten sind meistens auf Grund von falsch platzierten Kacheln oder der Vektorisierung von kaum angepassten Hintergrundkarten komplett oder teilweise verzerrt. DTP-Programme haben keine Werkzeuge, um die Verzerrung mit Hilfe eines Koordinatenbezugsystems oder Referenzpunkten aufzuheben.
  2. Keine Georeferenzierung: DTP-Softwares besitzen kein eigenes Koordinatenbezugssystem, um georeferenzierte Kartendaten auszutauschen. Dies schränkt die Nutzung von georeferenzierten Daten (z.B. Geodatenserver, Geo-Portale und OpenStreetMap-Daten) ein, was heutzutage eine wichtige Funktion ist, entweder um die Karte aufzuwerten, sie für die Navigation zu verwenden oder für GPS-Lokalisierungen.
  3. Unstrukturierter Kartenaufbau: Die flexible Ebenenstruktur und Symboldefinitionen führen zu einem schlechten Aufbau. Einzelne Kartenobjekte können einfach von der Ebene an einen anderen Ort verschoben werden, um eine bessere grafische Erscheinung zu erzielen (z.B. Brücken und Tunnel). Ausserdem werden Punktobjekte als Flächenobjekte dargestellt. Das Resultat ist, dass solche Karten viele überflüssige Daten aufweisen, die einerseits mühsam zu verwalten sind und andernseits nicht richtig in ein GIS passen.
  4. Keine spezifischen kartographischen Zeichnungs- und Bearbeitungswerkzeuge: DTP-Softwares besitzen keine eigenen spezifischen kartographischen Zeichnungs- und Bearbeitungswerkzeuge, wie Linienverfolgung, automatisches Blockout von Strassenkreuzungen oder Beeinflussung von gestrichelten Linien, um die effiziente Kartenproduktion zu unterstützen.
  5. Keine Datenbankverbindungen: DTP-Softwares besitzen keine eigenen Datenbankverbindungen, um zusätzliche Informationen von Kartenobjekten, wie Datum der Aufnahme, Herausgeber oder letzte Bearbeitung, zu speichern.

Viele Kartenveröffentlicher produzierten am Anfang der Zeit der digitalen Kartografie tausende von DTP-Karten. Heute fürchten sie, dass sie in eine Sackgasse geraten können, denn DTP-Softwares haben klare Nachteile und werden nicht mehr unterstützt.

Aus diesem Grund entwickelte OCAD AG in Zusammenarbeit mit Huber Kartografie, München DE einen Arbeitsablauf in der OCAD-Software, um Daten von DTP-Karten durch eine Anpassung in die Kartografie-Software oder sogar in ein GIS zu erhalten: Zu erst muss die DTP-Karte als PDF-Datei importiert werden. Danach wird die Verzerrung aufgehoben und die Karte wird georeferenziert. Im nächsten Schritt werden die importierten Ebenen in Symbole eines Symbolsatzes der Kartografiesoftware umgewandelt. Diese Umwandlung hat das Resultat, dass überflüssige Daten entfernt werden. Punktobjekte, welche immer noch als Flächenobjekte abgebildet werden, müssen in einzelne Punktobjekte umgewandelt werden. Alle Kartenobjekte können nun mit einer Datenbank verbunden werden. Mit diesem Arbeitsablauf wird die DTP-Karte so strukturiert, dass sie in eine GIS-Umgebung passt oder mit weiteren Geodaten verbessert und mit spezifischen kartografischen Zeichnungs- und Bearbeitungswerkzeugen in der Software angepasst werden kann. Dieser Arbeitsablauf wurden von Huber Kartografie erfolgreich implementiert.


Ganzer Text (in Englisch): http://www.ocad.com/public/2011-02-11_longTxt_icc2011_migrationDTPmaps_intoGIS.pdf

OCAD-Datei öffnen

Öffnen Sie die Datei kreta_leer.ocd. Die Datei befindet sich im Verzeichnis kreta_ocad.

WorkflowCrete 01.PNG


Kartenmassstab bestimmen

Setzen Sie den Kartenmassstab auf 1:100000 (Karte -> Massstab und Koordinatensystem).

WorkflowCrete 02.PNG

-> OK


Symbolsatz definieren

In der OCAD-Datei wurde bereits ein Symbolsatz definiert. In dieser Anleitung wird die Definition des Punktsymbols Sehenswürdigkeit beschrieben.


Eingescannte legende als Hintergrundkarte öffnen

Öffnen Sie die TIFF-Datei Legende_kreta.tif aus dem Verzeichnis lrete_backgroundmaps als Hintergrundkarte (Hintergrundkarte -> Öffnen).


Neues Symbol erstellen

Symbol -> Neu

Wählen Sie im Dialog Neues Symbol die Option Punktsymbol:

WorkflowCrete 03.PNG

-> OK

Geben Sie Symbolnummer und -beschreibung ein. Klicken Sie auf Bearbeiten:

WorkflowCrete 04.PNG

Der Symboleditor erscheint.

Ansicht -> Ganze Karte zeigen und Bildschirm-Gitter anzeigen

WorkflowCrete 04 01.PNG

Im nächsten Schritt muss das Legendensymbol im Ursprung der Koordinaten des Symboleditors platziert werden (roter Pfeil in Abbildung):

Hintergrundkarte -> Abstimmen (Shortcut F9):

  1. Mausklick auf das Symbol Sehenswürdigkeit in der Hintergrundkarte.
  2. Mausklick auf den Mittelpunkt der Koordinaten des Editors.
  3. Drücken Sie Enter, um den Vorgang ausuzuführen.
hint -Die meisten Feinanpassungen können Sie mit mehreren Abstimm-Schritten durchführen.
-Für Feinabstimmungen empfehlen wir Ihnen, das Bildschirmgitter show grid anzuzeigen.
WorkflowCrete 06.PNG

Selektieren Sie die Geometrie Fläche und die Farbe 0: Pikto Orange im Symbol-Editor:

WorkflowCrete 07.PNG

Zeichnen Sie danach das Symbol mit dem Geraden-Modus Icon StraightLineMode.PNG nach.

WorkflowCrete 08.PNG
hint Klicken Sie auf Screenshot für Symbol-Icon erstellen, um das Icon automatisch zu erstellen.

-> Schliessen Sie den Symboleditor.

Die Dialogbox Punktsymbol wird wieder angezeigt.

-> Schaltfläche


Erstellen Sie ein Symbol-Icon:

WorkflowCrete 09.PNG

-> OK

Die Dialogbox Punktsymbol wird wieder angezeigt.

-> OK


Entfernen Sie die Hintergrundkarte (Hintergrundkarte -> Verwalten):

WorkflowCrete 10.PNG

-> Entfernen und Dialog Schliessen.


OCAD Lernvideos:

video availableDifferent point symbols
video availableDifferent lines symbols
video availableDifferent area symbols
video availableDifferent text symbols

DTP-Karte als PDF importieren

Importieren Sie die PDF-Datei ICV_Kreta_Blatt1_West_fhd.pdf aus dem Verzeichnis kreta_fh (Datei -> Importieren).

WorkflowCrete 11.PNG

-> Öffnen

Da es sich um ein PDF mit mehreren Seiten handelt, muss die Importseite angegeben werden.

WorkflowCrete 12.PNG

-> OK

Ansicht -> Ganze Karte zeigen show entire map

Die importierte Karte wird angezeigt. Die Karte ist jedoch noch nicht georeferenziert.

WorkflowCrete 12 01.PNG

Georeferenzierte Hintergrundkarte öffnen

Öffnen Sie die georeferenzierte TIFF-Datei kreta_osm_importiert_100000.tif aus dem Verzeichnis kreta_osm als Hintergrundkarte (Hintergrundkarte -> Öffnen).

Da es sich um eine georeferenzierte Hintergrundkarte handelt, wird eine Dialogbox angezeigt, bei der Sie zwischen einer neuen Verschiebung (horizontal und vertikal entsprechend dem Nord- und Ostwert) und der existierenden Verschiebung wählen müssen.

WorkflowCrete 14.PNG

-> OK

Ansicht -> Ganze Karte anzeigen show entire map

Die Karte von Kreta und die georeferenzierte Hintergrundkarte werden angezeigt. Die Karte von Kreta ist jedoch immer noch nicht richtig georeferenziert.

WorkflowCrete 14 02.PNG

Georeferenzierung und Rubbersheeting

Wechseln Sie die Ansicht zu Entwurfsmodus ( Ansicht -> Entwurfsmodus).

In der Werkzeugsleiste wird ein Schieberegler angezeigt. Mit dem oberen Regler (M = Map) können Sie die Transparenz der Karte und mit dem unteren (B = Background Map) die Transparenz der Hintergrundkarte einstellen.

DraftModeSlider.png

Grobe Abstimmung mit Affintransformation

In einem ersten Schritt, muss die importierte karte mit einer Affin-Transformation verschoben werden (Karte -> Transformieren -> Affin).

WorkflowCrete 16.PNG
  1. Klicken Sie an einen Ort in der Karte.
  2. Klicken sie an denselben Standort in der Hintergrundkarte.
  3. Führen Sie die Transformation mit der Enter-Taste aus.

hint Für die Affin-Transformation können bis zu 12 Referenzpunkte definiert werden, indem Sie Schritt 1 und 2 immer wiederholen und ganz am Schluss mit der Enter-Taste die Transformation durchführen.

Feinabstimmung mit Rubbersheeting

Im zweiten Schritt wird die Karte so genau wie möglich mit Hilfe der Rubbersheeting-Transformation der georeferenzierten Hintergrundkarte abgestimmt. (Karte -> Transformieren -> Rubbersheeting)


OCAD Lernvideos:

video availableRubbersheeting-Transformation

Zu erst muss der Rubbersheeting Perimeter festgelegt werden (Festlegen -> den Bereich in der Karte zeichnen)

WorkflowCrete 17.PNG

Der Bereich wird mit einem blauen Rahmen im Zeichnungsfenster markiert:

WorkflowCrete 18.PNG

Wenn ein Perimeter definiert ist, können Rubbersheetingpunkte interaktiv hinzugefügt oder von einer Datei geladen werden.

WorkflowCrete 19.PNG

Rubbersheetingpunkte interaktiv hinzufügen:

  1. Mausklick auf die Karte.
  2. Mausklick auf den entsprechenden Ort in der Hintergrundkarte

Rubbersheetingpunkte werden mit einem roten und grünen Fadenkreuz, sowie einer Verbindungslinie abgebildet. Beim Transformationsprozess wird der rote zum grünen Punkt geschoben.

WorkflowCrete 20.PNG

Punkte können deaktiviert, entfernt oder gespeichert werden. Sie können einen Punkt mit einem Klick in die erste Spalte deaktivieren. Deaktivierte Punkte werden im Zeichnungsfenster in grau angezeigt.

WorkflowCrete 21.PNG

Führen Sie die Transformation mit Transformieren aus.
Wenn das Resultat befriedigend ist, können Sie den Dialog schliessen.
Ansonsten haben Sie die folgenden Möglichkeiten:

  • Machen Sie die Transformation rückgängig und optimieren Sie die Punkte (hinzufügen, deaktivieren, entfernen)
  • Verwenden Sie das Ergebnis als Startpunkt für weitere Transformationen mit neuen Punkten.

PDF-Bildobjekte in OCAD-Objekte transformieren

Automatische Konvertierung

Mit der Funktion Importierte Ebenen in Symbole umwandeln (Karte -> Importierte Ebenen in Symbole umwandeln) können die einzelnen Objekte automatisch in OCAD-Symbole umgewandelt werden.

In der Dialogbox Importierte Ebenen in Symbole umwandeln, müssen Sie die Übersetzungstabelle kreta.crt aus dem Verzeichnis kreta_crt laden.

WorkflowCrete 22.PNG

-> Ausführen

Manuelle Konvertierung

Bei der automatischen Konvertierung wurden zum Teil Objekte, die in falschen Ebenen liegen, falschen Symbolen zugeteilt. Hier ist es zum Beispiel der griechische Name für die Attraktion Tilissos, welcher fälschicherweise in schwarzer und nicht in roter Schrift erscheint.

WorkflowCrete 23.PNG

Selektieren Sie das Objekt:

WorkflowCrete 24.PNG

Selektieren Sie das korrekte Symbol aus der Symbolbox:

WorkflowCrete 25.PNG

Klicken Sie auf Symbol wechseln in der Standard-Werkzeugleiste, um dem Objekt das richtige Symbol zuzuteilen.

WorkflowCrete 26.PNG

Flächensymbole in OCAD-Punktsymbole umwandeln und redundante Objekte löschen

In DTP-Programmen werden Punktobjekte oft als Flächenobjekte definiert. Diese Objekte müssen daher in Punktobjekte umgewandelt werden. Diese besitzen nur Koordinaten und können beim Tracking einfach verschoben oder gelöscht werden.

WorkflowCrete 26 01.PNGWorkflowCrete 27.PNG

Bei der automatischen Konvertierung wurden diese Symbole als Umgehung in Flächenobjekte umgewandelt (z.B. 1605.1 Kapelle Fläche). Im Symbolsatz sind diese Symbole als einzelne Punkt- und Flächensymbole definiert. Selektieren Sie zu erst alle Objekte mit dem Symbol 1605.1 Kapelle Fläche (Symbolbox -> Symbol Höhenkote Fläche -> Kontextmenü -> Selektieren nach Symbol).

WorkflowCrete 28.PNG

Danach wandeln Sie die Objekte in Punktobjekte um (Karte -> Linien- oder Flächenobjekte zu Punktobjekten konvertieren), während Sie das Symbol 1605.1 Kapelle Fläche selektiert haben.

WorkflowCrete 29.PNG

-> Ausführen

hint Falls Sie Signaturen, die aus mehreren Flächen bestehen, importiert haben, müssen Sie vor der Konvertierung überschüssige Flächen entfernen, sodass nicht mehrere Punktobjekte am gleichen Ort erstellt werden.

Dieser Prozess wird mit dem Beispiel Windmühle erklärt. Die importierte Signatur für Windmühle besteht aus fünf Teilen: einem Turm und vier Rotorenblätter:

WorkflowCrete 30.PNG

Vor der Konvertierung in ein Punktobjekt müssen zu erst alle vier Rotorenblätter selektiert und entfernt werden.

Selektieren Sie das Symbol 1702.1 Windmühle Fläche in der Symbolbox.
Wählen Sie die Funktion Selektieren nach Eigenschaft (Selektieren -> Selektieren nach Eigenschaft).

Einstellungen:
Selektieren: Objekte mit einem selektierten Symbol
Bedingung: Anzahl Stützpunkte = 4

WorkflowCrete 31.PNG

-> Selektieren und Dialog Schliessen

Die Rotorenblätter von allen Windmühlen werden selektiert.

WorkflowCrete 32.PNGWorkflowCrete 32 01.PNG

Löschen Sie diese mit der Delete-Taste

WorkflowCrete 33.PNGWorkflowCrete 33 01.PNG

Die verbleibenden Flächenobjekte können nun wie beschrieben in Punktobjekte konvertiert werden.

WorkflowCrete 33 02.PNG


Redundante Objekte löschen

Die importierte Karte enthält viele redundante (überflüssige) Objekte, wie zum Beispiel Strassen, die aus zwei oder mehr geometrisch identischen Linien bestehen. In OCAD können diese komplexen Linien mit einem einzigen Linienobjekt aufgenommen werden. Daher sind diese Objekte überflüssig und können entfernt werden.

Selektieren Sie zu erst alle Objekte (Symbolbox -> Symbol 1.0 Skelett -> Kontextmenü -> Selektieren nach Symbol).

WorkflowCrete 34.PNG

Entfernen Sie die selektierten Objekte mit der Delete-Taste oder delete.

Datenbank anhängen

In OCAD 10 Proffesional ist es möglich, die Karte oder deren Objetke mit einer Datenbank zu verbinden. Eine neue Datenbank muss definiert werden (Datenbank -> Datenbankverbindungen verwalten).

WorkflowCrete 35.PNG

-> Neu

Geben Sie den Namen der Verbindung ein und selektieren Sie die Option Bestehende Datenquelle benutzen.

WorkflowCrete 36.PNG

-> OK

Selektieren Sie eine Datenbankdatei.

WorkflowCrete 37.PNG

-> Durchsuchen

Öffnen Sie die Datei kreta.xls aus dem Verzeichnis kreta_db.

WorkflowCrete 38.PNG

Wählen Sie die Tabelle wamu§ und das Schlüsselfeld ID.

WorkflowCrete 39.PNG

Selektieren Sie alle Wassermühlen (Symbolbox -> Kontextmenü -> Selektieren nach Symbol)

WorkflowCrete 40.PNG

Erstellen Sie eine Datenbankverbindung für die selektierten Wassermühlen (Datenbank -> Datenbankeinträge erstellen und aktualisieren).

Verbindung: Wassermühlen

WorkflowCrete 41.PNG

-> OK

Suchen Sie die Windmühle mit Hilfe des Schlüsselfeldes (Suchen -> Schlüsselwert eingeben).

WorkflowCrete 42.PNG

->OK

Bearbeiten Sie die entsprechenden Datenbankeinträge in der Datenbankbox.

WorkflowCrete 43.PNG
video available Databanken - Basics

GIS exportieren ( SHP oder DXF)

Die Karte oder Teile der Karte können als Shape- oder DXF-Datei exportiert und in GIS-Systemen oder CAD-Programmen verwendet werden.

Datei -> Exportieren -> Shape -> Punktobjekte -> Objekte in der Datenbank: Windmühlen

WorkflowCrete 44.PNG

-> OK

Speichern Sie die Datei unter kreta_wamu.shp

WorkflowCrete 45.PNG
video available Shape exportieren

Für Google Earth exportieren (KMZ Google Earth Raster)

Die Karte oder Teile der Karte können als KMZ-Datei exportiert und in Google Earth oder einem GPS-Gerät verwendet werden. Für diesen Export muss ein Koordinatensystem definiert sein.

Karte -> Massstab und Koordinatensystem -> Auswählen -> Koordinatensystem: UTM -> Zone: Zone 35 North

Datei -> Exportieren -> KMZ Google Earth (Raster)

Nehmen Sie Exporteinstellungen vor und wählen Sie den Kartenausschnitt:

WorkflowCrete 46.PNG

-> OK

Speichern Sie die Datei als kreta.kmz:

WorkflowCrete 47.PNG

-> Speichern

video available KMZ Google Earth Export

Anhang

Einstellungen des PDF-Exports aus Freehand für das beste Resultat des Imports in OCAD:

Freehand ExportPDF Settings.gif