Migration von unstrukturierten DTP-Karten

Aus OCAD 11 Wiki - Deutsch
Wechseln zu: Navigation, Suche

Anpassung von unstrukturierten Desktop-Publishing-Karten in ein GIS

Viele Karten werden mit einer Desktop-Publishing (DTP) Software, wie Macromedia Freehand, Adobe Illustrator oder CorelDraw erstellt. Der Vorteil dieser Softwareprogramme ist, dass diese eine grosse Auswahl an Zeichnungs- und Bearbeitungswerkzeugen aufweisen, sie eine flexible Ebenenstruktur für Karte und Kartenlayout besitzen und dass sie im Vergleich zu GIS (Geographic Information System) billiger sind. DTP-Karten sind jedoch limitiert, um auf dem neuesten Stand der Technik der digitalen Kartografie zu bleiben. Die grössten Nachteile sind:

  1. Verzerrung: DTP-Karten sind meistens auf Grund von falsch platzierten Kacheln oder der Vektorisierung von kaum angepassten Hintergrundkarten komplett oder teilweise verzerrt. DTP-Programme haben keine Werkzeuge, um die Verzerrung mit Hilfe eines Koordinatenbezugsystems oder Referenzpunkten aufzuheben.
  2. Keine Georeferenzierung: DTP-Softwares besitzen kein eigenes Koordinatenbezugssystem, um georeferenzierte Kartendaten auszutauschen. Dies schränkt die Nutzung von georeferenzierten Daten (z.B. Geodatenserver, Geo-Portale und OpenStreetMap-Daten) ein, was heutzutage eine wichtige Funktion ist, entweder um die Karte aufzuwerten, sie für die Navigation zu verwenden oder für GPS-Lokalisierungen.
  3. Unstrukturierter Kartenaufbau: Die flexible Ebenenstruktur und Symboldefinitionen führen zu einem schlechten Aufbau. Einzelne Kartenobjekte können einfach von der Ebene an einen anderen Ort verschoben werden, um eine bessere grafische Erscheinung zu erzielen (z.B. Brücken und Tunnel). Ausserdem werden Punktobjekte als Flächenobjekte dargestellt. Das Resultat ist, dass solche Karten viele überflüssige Daten aufweisen, die einerseits mühsam zu verwalten sind und andernseits nicht richtig in ein GIS passen.
  4. Keine spezifischen kartographischen Zeichnungs- und Bearbeitungswerkzeuge: DTP-Softwares besitzen keine eigenen spezifischen kartographischen Zeichnungs- und Bearbeitungswerkzeuge, wie Linienverfolgung, automatisches Blockout von Strassenkreuzungen oder Beeinflussung von gestrichelten Linien, um die effiziente Kartenproduktion zu unterstützen.
  5. Keine Datenbankverbindungen: DTP-Softwares besitzen keine eigenen Datenbankverbindungen, um zusätzliche Informationen von Kartenobjekten, wie Datum der Aufnahme, Herausgeber oder letzte Bearbeitung, zu speichern.

Viele Kartenveröffentlicher produzierten am Anfang der Zeit der digitalen Kartografie tausende von DTP-Karten. Heute fürchten sie, dass sie in eine Sackgasse geraten können, denn DTP-Softwares haben klare Nachteile und werden nicht mehr unterstützt.

Aus diesem Grund entwickelte OCAD AG in Zusammenarbeit mit Huber Kartografie, München DE einen Arbeitsablauf in der OCAD-Software, um Daten von DTP-Karten durch eine Anpassung in die Kartografie-Software oder sogar in ein GIS zu erhalten: Zu erst muss die DTP-Karte als PDF-Datei importiert werden. Danach wird die Verzerrung aufgehoben und die Karte wird georeferenziert. Im nächsten Schritt werden die importierten Ebenen in Symbole eines Symbolsatzes der Kartografiesoftware umgewandelt. Diese Umwandlung hat das Resultat, dass überflüssige Daten entfernt werden. Punktobjekte, welche immer noch als Flächenobjekte abgebildet werden, müssen in einzelne Punktobjekte umgewandelt werden. Alle Kartenobjekte können nun mit einer Datenbank verbunden werden. Mit diesem Arbeitsablauf wird die DTP-Karte so strukturiert, dass sie in eine GIS-Umgebung passt oder mit weiteren Geodaten verbessert und mit spezifischen kartografischen Zeichnungs- und Bearbeitungswerkzeugen in der Software angepasst werden kann. Dieser Arbeitsablauf wurden von Huber Kartografie erfolgreich implementiert.


Ganzer Text (in Englisch): http://www.ocad.com/public/2011-02-11_longTxt_icc2011_migrationDTPmaps_intoGIS.pdf

OCAD-Datei öffnen

Öffnen Sie die Datei kreta_leer.ocd. Die Datei befindet sich im Verzeichnis kreta_ocad.

WorkflowCrete 01.PNG


Kartenmassstab bestimmen

Setzen Sie den Kartenmassstab auf 1:100000 (Karte -> Massstab und Koordinatensystem).

WorkflowCrete 02.PNG

-> OK


Symbolsatz definieren

In der OCAD-Datei wurde bereits ein Symbolsatz definiert. In dieser Anleitung wird die Definition des Punktsymbols Sehenswürdigkeit beschrieben.


Eingescannte legende als Hintergrundkarte öffnen

Öffnen Sie die TIFF-Datei Legende_kreta.tif aus dem Verzeichnis lrete_backgroundmaps als Hintergrundkarte (Hintergrundkarte -> Öffnen).


Neues Symbol erstellen

Symbol -> Neu

Wählen Sie im Dialog Neues Symbol die Option Punktsymbol:

WorkflowCrete 03.PNG

-> OK

Geben Sie Symbolnummer und -beschreibung ein. Klicken Sie auf Bearbeiten:

WorkflowCrete 04.PNG

Der Symboleditor erscheint.

Ansicht -> Ganze Karte zeigen und Bildschirm-Gitter anzeigen

WorkflowCrete 04 01.PNG

Im nächsten Schritt muss das Legendensymbol im Ursprung der Koordinaten des Symboleditors platziert werden (roter Pfeil in Abbildung):

Hintergrundkarte -> Abstimmen (Shortcut F9):

  1. Mausklick auf das Symbol Sehenswürdigkeit in der Hintergrundkarte.
  2. Mausklick auf den Mittelpunkt der Koordinaten des Editors.
  3. Drücken Sie Enter, um den Vorgang ausuzuführen.
hint -Die meisten Feinanpassungen können Sie mit mehreren Abstimm-Schritten durchführen.
-Für Feinabstimmungen empfehlen wir Ihnen, das Bildschirmgitter show grid anzuzeigen.
WorkflowCrete 06.PNG

Selektieren Sie die Geometrie Fläche und die Farbe 0: Pikto Orange im Symbol-Editor:

WorkflowCrete 07.PNG

Zeichnen Sie danach das Symbol mit dem Geraden-Modus Icon StraightLineMode.PNG nach.

WorkflowCrete 08.PNG
hint Klicken Sie auf Screenshot für Symbol-Icon erstellen, um das Icon automatisch zu erstellen.

-> Schliessen Sie den Symboleditor.

Die Dialogbox Punktsymbol wird wieder angezeigt.

-> Schaltfläche


Erstellen Sie ein Symbol-Icon:

WorkflowCrete 09.PNG

-> OK

Die Dialogbox Punktsymbol wird wieder angezeigt.

-> OK


Entfernen Sie die Hintergrundkarte (Hintergrundkarte -> Verwalten):

WorkflowCrete 10.PNG

-> Entfernen und Dialog Schliessen.


OCAD Lernvideos:

video availableDifferent point symbols
video availableDifferent lines symbols
video availableDifferent area symbols
video availableDifferent text symbols

DTP-Karte als PDF importieren

Importieren Sie die PDF-Datei ICV_Kreta_Blatt1_West_fhd.pdf aus dem Verzeichnis kreta_fh (Datei -> Importieren).

WorkflowCrete 11.PNG

-> Öffnen

Da es sich um ein PDF mit mehreren Seiten handelt, muss die Importseite angegeben werden.

WorkflowCrete 12.PNG

-> OK

Ansicht -> Ganze Karte zeigen show entire map

Die importierte Karte wird angezeigt. Die Karte ist jedoch noch nicht georeferenziert.

WorkflowCrete 12 01.PNG

Georeferenzierte Hintergrundkarte öffnen

Öffnen Sie die georeferenzierte TIFF-Datei kreta_osm_importiert_100000.tif aus dem Verzeichnis kreta_osm als Hintergrundkarte (Hintergrundkarte -> Öffnen).

Da es sich um eine georeferenzierte Hintergrundkarte handelt, wird eine Dialogbox angezeigt, bei der Sie zwischen einer neuen Verschiebung (horizontal und vertikal entsprechend dem Nord- und Ostwert) und der existierenden Verschiebung wählen müssen.

WorkflowCrete 14.PNG

-> OK

Ansicht -> Ganze Karte anzeigen show entire map

Die Karte von Kreta und die georeferenzierte Hintergrundkarte werden angezeigt. Die Karte von Kreta ist jedoch immer noch nicht richtig georeferenziert.

WorkflowCrete 14 02.PNG

Georeferenzierung und Rubbersheeting

Wechseln Sie die Ansicht zu Entwurfsmodus ( Ansicht -> Entwurfsmodus).

In der Werkzeugsleiste wird ein Schieberegler angezeigt. Mit dem oberen Regler (M = Map) können Sie die Transparenz der Karte und mit dem unteren (B = Background Map) die Transparenz der Hintergrundkarte einstellen.

DraftModeSlider.png

Grobe Abstimmung mit Affintransformation

In einem ersten Schritt, muss die importierte karte mit einer Affin-Transformation verschoben werden (Karte -> Transformieren -> Affin).

WorkflowCrete 16.PNG
  1. Klicken Sie an einen Ort in der Karte.
  2. Klicken sie an denselben Standort in der Hintergrundkarte.
  3. Führen Sie die Transformation mit der Enter-Taste aus.

hint Für die Affin-Transformation können bis zu 12 Referenzpunkte definiert werden, indem Sie Schritt 1 und 2 immer wiederholen und ganz am Schluss mit der Enter-Taste die Transformation durchführen.

Feinabstimmung mit Rubbersheeting

Im zweiten Schritt wird die Karte so genau wie möglich mit Hilfe der Rubbersheeting-Transformation der georeferenzierten Hintergrundkarte abgestimmt. (Karte -> Transformieren -> Rubbersheeting)


OCAD Lernvideos:

video availableRubbersheeting-Transformation

Zu erst muss der Rubbersheeting Perimeter festgelegt werden (Festlegen -> den Bereich in der Karte zeichnen)

WorkflowCrete 17.PNG

Der Bereich wird mit einem blauen Rahmen im Zeichnungsfenster markiert:

WorkflowCrete 18.PNG

Wenn ein Perimeter definiert ist, können Rubbersheetingpunkte interaktiv hinzugefügt oder von einer Datei geladen werden.

WorkflowCrete 19.PNG

Rubbersheetingpunkte interaktiv hinzufügen:

  1. Mausklick auf die Karte.
  2. Mausklick auf den entsprechenden Ort in der Hintergrundkarte

Rubbersheetingpunkte werden mit einem roten und grünen Fadenkreuz, sowie einer Verbindungslinie abgebildet. Beim Transformationsprozess wird der rote zum grünen Punkt geschoben.

WorkflowCrete 20.PNG

Punkte können deaktiviert, entfernt oder gespeichert werden. Sie können einen Punkt mit einem Klick in die erste Spalte deaktivieren. Deaktivierte Punkte werden im Zeichnungsfenster in grau angezeigt.

WorkflowCrete 21.PNG

Führen Sie die Transformation mit Transformieren aus.
Wenn das Resultat befriedigend ist, können Sie den Dialog schliessen.
Ansonsten haben Sie die folgenden Möglichkeiten:

  • Machen Sie die Transformation rückgängig und optimieren Sie die Punkte (hinzufügen, deaktivieren, entfernen)
  • Verwenden Sie das Ergebnis als Startpunkt für weitere Transformationen mit neuen Punkten.

PDF-Bildobjekte in OCAD-Objekte transformieren

Automatische Konvertierung

Mit der Funktion Importierte Ebenen in Symbole umwandeln (Karte -> Importierte Ebenen in Symbole umwandeln) können die einzelnen Objekte automatisch in OCAD-Symbole umgewandelt werden.

In der Dialogbox Importierte Ebenen in Symbole umwandeln, müssen Sie die Übersetzungstabelle kreta.crt aus dem Verzeichnis kreta_crt laden.

WorkflowCrete 22.PNG

-> Ausführen

Manuelle Konvertierung

Bei der automatischen Konvertierung wurden zum Teil Objekte, die in falschen Ebenen liegen, falschen Symbolen zugeteilt. Hier ist es zum Beispiel der griechische Name für die Attraktion Tilissos, welcher fälschicherweise in schwarzer und nicht in roter Schrift erscheint.

WorkflowCrete 23.PNG

Selektieren Sie das Objekt:

WorkflowCrete 24.PNG

Selektieren Sie das korrekte Symbol aus der Symbolbox:

WorkflowCrete 25.PNG

Klicken Sie auf Symbol wechseln in der Standard-Werkzeugleiste, um dem Objekt das richtige Symbol zuzuteilen.

WorkflowCrete 26.PNG

Flächensymbole in OCAD-Punktsymbole umwandeln und redundante Objekte löschen

In DTP-Programmen werden Punktobjekte oft als Flächenobjekte definiert. Diese Objekte müssen daher in Punktobjekte umgewandelt werden. Diese besitzen nur Koordinaten und können beim Tracking einfach verschoben oder gelöscht werden.

WorkflowCrete 26 01.PNGWorkflowCrete 27.PNG

Bei der automatischen Konvertierung wurden diese Symbole als Umgehung in Flächenobjekte umgewandelt (z.B. 1605.1 Kapelle Fläche). Im Symbolsatz sind diese Symbole als einzelne Punkt- und Flächensymbole definiert. Selektieren Sie zu erst alle Objekte mit dem Symbol 1605.1 Kapelle Fläche (Symbolbox -> Symbol Höhenkote Fläche -> Kontextmenü -> Selektieren nach Symbol).

WorkflowCrete 28.PNG

Danach wandeln Sie die Objekte in Punktobjekte um (Karte -> Linien- oder Flächenobjekte zu Punktobjekten konvertieren), während Sie das Symbol 1605.1 Kapelle Fläche selektiert haben.

WorkflowCrete 29.PNG

-> Ausführen

hint Falls Sie Signaturen, die aus mehreren Flächen bestehen, importiert haben, müssen Sie vor der Konvertierung überschüssige Flächen entfernen, sodass nicht mehrere Punktobjekte am gleichen Ort erstellt werden.

Dieser Prozess wird mit dem Beispiel Windmühle erklärt. Die importierte Signatur für Windmühle besteht aus fünf Teilen: einem Turm und vier Rotorenblätter:

WorkflowCrete 30.PNG

Vor der Konvertierung in ein Punktobjekt müssen zu erst alle vier Rotorenblätter selektiert und entfernt werden.

Selektieren Sie das Symbol 1702.1 Windmühle Fläche in der Symbolbox.
Wählen Sie die Funktion Selektieren nach Eigenschaft (Selektieren -> Selektieren nach Eigenschaft).

Einstellungen:
Selektieren: Objekte mit einem selektierten Symbol
Bedingung: Anzahl Stützpunkte = 4

WorkflowCrete 31.PNG

-> Selektieren und Dialog Schliessen

Die Rotorenblätter von allen Windmühlen werden selektiert.

WorkflowCrete 32.PNGWorkflowCrete 32 01.PNG

Löschen Sie diese mit der Delete-Taste

WorkflowCrete 33.PNGWorkflowCrete 33 01.PNG

Die verbleibenden Flächenobjekte können nun wie beschrieben in Punktobjekte konvertiert werden.

WorkflowCrete 33 02.PNG


Redundante Objekte löschen

Die importierte Karte enthält viele redundante (überflüssige) Objekte, wie zum Beispiel Strassen, die aus zwei oder mehr geometrisch identischen Linien bestehen. In OCAD können diese komplexen Linien mit einem einzigen Linienobjekt aufgenommen werden. Daher sind diese Objekte überflüssig und können entfernt werden.

Selektieren Sie zu erst alle Objekte (Symbolbox -> Symbol 1.0 Skelett -> Kontextmenü -> Selektieren nach Symbol).

WorkflowCrete 34.PNG

Entfernen Sie die selektierten Objekte mit der Delete-Taste oder delete.

Datenbank anhängen

In OCAD 10 Proffesional ist es möglich, die Karte oder deren Objetke mit einer Datenbank zu verbinden. Eine neue Datenbank muss definiert werden (Datenbank -> Datenbankverbindungen verwalten).

WorkflowCrete 35.PNG

-> Neu

Geben Sie den Namen der Verbindung ein und selektieren Sie die Option Bestehende Datenquelle benutzen.

WorkflowCrete 36.PNG

-> OK

Selektieren Sie eine Datenbankdatei.

WorkflowCrete 37.PNG

-> Durchsuchen

Öffnen Sie die Datei kreta.xls aus dem Verzeichnis kreta_db.

WorkflowCrete 38.PNG

Wählen Sie die Tabelle wamu§ und das Schlüsselfeld ID.

WorkflowCrete 39.PNG

Selektieren Sie alle Wassermühlen (Symbolbox -> Kontextmenü -> Selektieren nach Symbol)

WorkflowCrete 40.PNG

Erstellen Sie eine Datenbankverbindung für die selektierten Wassermühlen (Datenbank -> Datenbankeinträge erstellen und aktualisieren).

Verbindung: Wassermühlen

WorkflowCrete 41.PNG

-> OK

Suchen Sie die Windmühle mit Hilfe des Schlüsselfeldes (Suchen -> Schlüsselwert eingeben).

WorkflowCrete 42.PNG

->OK

Bearbeiten Sie die entsprechenden Datenbankeinträge in der Datenbankbox.

WorkflowCrete 43.PNG
video available Databanken - Basics

GIS exportieren ( SHP oder DXF)

Die Karte oder Teile der Karte können als Shape- oder DXF-Datei exportiert und in GIS-Systemen oder CAD-Programmen verwendet werden.

Datei -> Exportieren -> Shape -> Punktobjekte -> Objekte in der Datenbank: Windmühlen

WorkflowCrete 44.PNG

-> OK

Speichern Sie die Datei unter kreta_wamu.shp

WorkflowCrete 45.PNG
video available Shape exportieren

Für Google Earth exportieren (KMZ Google Earth Raster)

Die Karte oder Teile der Karte können als KMZ-Datei exportiert und in Google Earth oder einem GPS-Gerät verwendet werden. Für diesen Export muss ein Koordinatensystem definiert sein.

Karte -> Massstab und Koordinatensystem -> Auswählen -> Koordinatensystem: UTM -> Zone: Zone 35 North

Datei -> Exportieren -> KMZ Google Earth (Raster)

Nehmen Sie Exporteinstellungen vor und wählen Sie den Kartenausschnitt:

WorkflowCrete 46.PNG

-> OK

Speichern Sie die Datei als kreta.kmz:

WorkflowCrete 47.PNG

-> Speichern

video available KMZ Google Earth Export

Anhang

Einstellungen des PDF-Exports aus Freehand für das beste Resultat des Imports in OCAD:

Freehand ExportPDF Settings.gif