Difference between revisions of "XML Script"

From OCAD Wiki - English
Jump to navigation Jump to search
Line 322: Line 322:
 
| File.Export || Format|| Enum types || SVG
 
| File.Export || Format|| Enum types || SVG
 
|-
 
|-
| File.Export.PartOfMap || Enabled <br> Coordinates <br> &nbsp; <br>L, R, B, T || Bool <br> Enum types  <br> Float || true, false <br> mm (page), m (real world) <br> &nbsp; <br>left, right, bottom, top  
+
| File.Export.PartOfMap || Enabled <br> Coordinates <br>L, R, B, T || Bool <br> Enum types  <br> Float || true, false <br> mm (page), m (real world) <br>left, right, bottom, top  
 
|-
 
|-
 
| File.Export || ExportScale|| Integer || e.g. '10000' for the scale 1:10'000  
 
| File.Export || ExportScale|| Integer || e.g. '10000' for the scale 1:10'000  

Revision as of 14:38, 16 April 2012

(This function is only available in OCAD Professional!)

Choose this command to execute functions whose settings are defined in a XML file.


Introduction

Select Execute XML Script from File menu.


XML Script General

File

Node <OcadScript> Parameter Data type Values / Description
File.Open File String ocd file name
File.Close Enabled Boolean true, false
File.Save Enabled Boolean true, false
File.SaveAs File String ocd file name
File.MultipleFileImport Directory
CoordinateSystem
NewOffset
Horizontally
Vertically
Angle
MapScale
GridDistance
LayerField
String
Integer
Boolean
Integer
Integer
Double
Integer
Double
String
Directory of import files
-1 = WGS 84, 1000 = existing grid
true, false
 
 
 
 
 
 
File.ExportOIM File String html file name
File.Exit Enabled Boolean true, false Close OCAD Program

View

Node <OcadScript> Parameter Data type Values / Description
View.Mode Enum types normalMode, spotColorMode, draftMode
View.EntireMap Enabled Boolean true, false
View.MoveTo X
Y
Double
Double
 

Map

Node <OcadScript> Parameter Data type Values / Description
Map.OptimizeRepair Enabled Boolean true, false
Map.ChangeScale NewScale Integer e. g. 10 000
  EnlargeReduceSymbols Boolean true, false
Map.ConvertLayer CrtFile String crt file name
Map.LoadSymbolsFrom File String ocd file name (with symbols to be loaded)
The option replace existing colors and symbols is used
Map.Routing File String ocd file name (with symbols to be loaded)
The option replace existing colors and symbols is used

Database

Node <OcadScript> Parameter Data type Values / Description
Database.Dataset.New TODO    
Database.Dataset.Remove Dataset String
Integer
all for all databases
3, 2, 1, ... for only one or several
Database.Assign.Symbols Dataset
 
CntFile
String
Integer
String
all for all databases
1, 2, 3, ... for only one database
 
ex. 101.0
true, false (Default)
Database.Assign.Texts Dataset
 
TextField
Symbol
ReplaceExistingObjects
String
Integer
String
String
Boolean
all for all databases
1, 2, 3, ... for only one database
 
ex. 101.0
true, false (Default)
Database.Assign.Angles Dataset
 
AngleField
String
Integer
String
all for all databases
1, 2, 3, ... for only one database
 
Database.CreateObjects Dataset
SelectSymbol
Condition
HorizontalCoordinate
VerticalCoordinate
Unit
TextField
HorizontalOffset
VerticalOffset
Integer
Double
String
String
String
Enum types
String
Double
Double
1, 2, 3, ... Number of dataset
Symbol numer. ex. 207,0
SQL String (ex. SYMBOL LIKE 207,0)
Database fieldname
Database fieldname
m, km
Database fieldname
 
 


Example xml file:

<OcadScript>
 <File.Open>
   <File>C:\Albis\albis_leer.ocd</File>
</File.Open>
<File.MultipleFileImport>
   <Directory>C:\Albis\shp</Directory>
  <NewOffset>enabled</NewOffset>
  <Horizontally>670000</Horizontally>
  <Vertically>230000</Vertically>
  <Angle>20</Angle>
  <MapScale>20000</MapScale>
  <GridDistance>500</GridDistance>
   <LayerField>OBJECTVAL/LayerField>
</File.MultipleFileImport>
 <Database.Assign.Texts>
  <Dataset>all</Dataset>
   <TextField>ID</TextField>
   <Symbol>101.0</Symbol>
   <ReplaceExistingObjects>true</ReplaceExistingObjects >
 </Database.Assign.Texts>
<Database.Assign.Angles>
  <Dataset>all</Dataset>  
   <AngleField>ID</AngleField>
</Database.Assign.Angles>
 
<Database.Assign.Symbols>
  <Dataset>all</Dataset>
  <CntFile>C:\Albis\cnt\Landeskarte.cnt</CntFile>
</Database.Assign.Symbols>
 <Database.Dataset.Remove>
  <Dataset>all</Dataset>
</Database.Dataset.Remove>
 <Map.OptimizeRepair>
<Enabled>true</Enabled>
 </Map.OptimizeRepair>
 <View.EntireMap>
 <Enabled>true</Enabled>
</View.EntireMap>
<File.Save>
  <Enabled>false</Enabled>
</File.Save>
 <File.SaveAs>
  <File>C:\Albis\Albis2.ocd</File>
 </File.SaveAs>
 <File.Close>
  <Enabled>true</Enabled>
</File.Close>
 <File.Exit>
  <Enabled>false</Enabled>
 </File.Exit>
</OcadScript>

XML Script Partial Map

Node <OcadScript> Parameter Data type Values / Description
export file String eg.: ‚ c:\export\PartialMap1.ocd ‘
OCAD creates files PartialMap1_1_1.ocd,
PartialMap1_1_2.ocd,
export coordSystem Enum types mm (paper), m (real world)
export T, L, B, R Float top, left, bottom, right
export.loop enabled
horizontalPages
verticalpages
horizontalOverlap
verticalOverlap
Bool
Integer
Integer
Float
Float
true, false
number of pages in horizontal direction
number of pages in vertical direction
horizontal overlap in mm or m
vertical overlap in mm or m


Example xml file:

<ocadScript>                                               // comment   
<partialMapScript>
   <export id="0">                                         // first export section
    <file>c:\export\PartialMap1.ocd</file>                 // export file
    <coordSystem>mm</coordSystem>                          // paper oder real world coordinates
    <T>100</T>                                             // export rectangle with Top Left point and Bottom Right point 
    <L>0</L>
    <B>50</B>
    <R>50</R>
      <loop>                                               // the loop export several ocd files. For this example 21 files.
      <enabled>true</enabled>
      <horizontalPages>7</horizontalPages>              
      <verticalPages>3</verticalPages>
      <horizontalOverlap>10</horizontalOverlap>            // horizontal and vertical overlap. 
      <verticalOverlap>10</verticalOverlap>
    </loop>
    </export>                                              // second export section
    <export id="1">
    <file>c:\export\PartialMap2.ocd</file>
    <coordSystem>mm</coordSystem>
    <L>0</L>
    <R>50</R>
    <B>50</B>
    <T>100</T>
      <loop>
      <enabled>false</enabled>
    </loop>                                                // export only one ocd file
    </export>
  </partialMapScript>
</ocadScript>

XML Script Print

Print parameters can be saved in a XML script.

Node <OcadScript> Parameter Data type Values / Description
File.Print.Printer Name
DmPaperSize
DmDefaultSource
DmPrintQuality
DmColor
DmMediaType
String
Integer
Integer
Integer
Integer
Integer
Eg. ,HP Color LaserJet 2840 PCL'
9
15
600
2
272
File.Print.Portrait Enabled Bool true, false
File.Print.SpotColor Enabled Bool true, false
FilePrint.PartialMap Range
L, R, B, T
Integer
Float
1
Left, Right, Bottom, Top
File.Print.HoizontalOverlap   Float -12,74
File.Print.VerticalOverlap   Float 8.74
File.Print.PrintScale   Integer Eg. 25000
File.Print.Copies   Integer Number of copies
File.Print.Intensity   Integer  
File.Print.LineWidth   Integer  
File.Print.PrintScreenGrid Enabled Bool true, false

XML Script Export

AI (Adobe Illustrator), PDF

Node <OcadScript> Parameter Data type Values / Description
File.Export File String eg.: ,c::\Export\Chlosterwald.ai‘
File.Export Format Enum types AI, PDF
File.Export.PartOfMap Enabled
Coordinates
L, R, B, T
Bool
Enum types
Float
true, false
mm (page), m (real world)
left, right, bottom, top
File.Export ExportScale Integer e.g. '10000' for the scale 1:10'000
File.Export Colors Enum types normal, spotColors
File.Export.SpotColors Combine Bool true, false [only if Colors = spotColors]
File.Export.SpotColors Enabled Spotcolor name [only if Colors = spotColors]

BMP, GIF, JPEG

Node <OcadScript> Parameter Data type Values / Description
File.Export File String eg.: ‚c:\Export\Chlosterwald.bmp‘
File.Export Format Enum types BMP, GIF, JPEG
File.Export Quality Integer only for JPEG, [0..100]
File.Export Resolution Integer in dpi [40..2540]
File.Export Anti-Aliasing Boolean true, false
File.Export ColorCorrection Boolean true, false
File.Export.PartOfMap Enabled
Coordinates
L, R, B, T
Bool
Enum types
Float
true, false
mm (page), m (real world)
left, right, bottom, top
File.Export.Tiles Enabled
Width
Height
Boolean
Integer
Integer
true, false
[only if Enabled = true]
[only if Enabled = true]
File.Export.GeoRef Enabled
PixelSize
CreateWorldFile
Bool
Float
Bool
true, false
in meter [only if Enabled = true]
true, false [only if Enabled = true]

EPS

Node <OcadScript> Parameter Data type Values / Description
File.Export File String eg.: ‚c:\Export\Chlosterwald.eps ‘
File.Export Format Enum types EPS
File.Export.PartOfMap Enabled
Coordinates
L, R, B, T
Bool
Enum types
Float
true, false
mm (page), m (real world)
left, right, bottom, top
File.Export Colors Enum types normal, spotColors
File.Export.SpotColors Enabled Spotcolor name [only if Colors = spotColors]

SVG (Scalable Vector Graphics)

Node <OcadScript> Parameter Data type Values / Description
File.Export File String eg.: ‚c:\Export\Chlosterwald.svg ‘
File.Export Format Enum types SVG
File.Export.PartOfMap Enabled
Coordinates
L, R, B, T
Bool
Enum types
Float
true, false
mm (page), m (real world)
left, right, bottom, top
File.Export ExportScale Integer e.g. '10000' for the scale 1:10'000
File.Export CompressFile Boolean true, false

TIFF

Node <OcadScript> Parameter Data type Values / Description
File.Export File String eg.: ‚c:\Export\Chlosterwald.tif‘
If spotColors is enabled and
Combine=false then the filename is
‚c:\Export\Chlosterwald.Spotcolor name.tif ‘
File.Export Format Enum types TIFF
File.Export Resolution Integer in dpi [40..2540]
File.Export Anti-Aliasing Boolean true, false
File.Export ColorCorrection Boolean true, false
File.Export.PartOfMap Enabled
Coordinates
 
L, R, B, T
Bool
Enum types
Float
true, false
mm (page), m (real world)
 
left, right, bottom, top
File.Export.Tiles Enabled
Width
Height
Bool
Integer
Integer
true, false
[only if Enabled = true]
[only if Enabled = true]
File.Export.GeoRef Enabled
PixelSize
CreateWorldFile
Bool
Float
Bool
true, false
in meter [only if Enabled = true]
true, false [only if Enabled = true]
File.Export Colors Enum types normal, spotColors
File.Export.SpotColors Combine Bool true, false [only if Colors = spotColors]
File.Export.SpotColors Enabled Spotcolor name [only if Colors = spotColors]
File.Export ColorMode Integer 0 = 32 bit CMYK
1 = 24 bit RGB
2 = 256 colors
3 = grayscale
4 = 8 bit CMYK
5 = 1 bit black/white
6 = halftone screen
File.Export Compression Integer 1 = no compression
2 = CCITT
4 = FaxG4
5 = LZW

DXF

Node <OcadScript> Parameter Data type Values / Description
File.Export File String eg.: ‚c:\Export\Chlosterwald.dxf ‘
File.Export Format Enum types DXF
File.Export ExportScale Integer e.g. '10000' for the scale 1:10'000
File.Export ConvertAnsiToOem Boolean true, false
File.Export ConvertOemToUnicode Boolean true, false
File.Export ObjectsSelectedSymbols Boolean true, false
File.Export AddSymbolDescription Boolean true, false
File.Export ExportAsSplines Boolean true, false
File.Export Coordinates Enum types m, mm

Shape

Node <OcadScript> Parameter Data type Values / Description
File.Export ExportPath String eg.: ‚c:\Export‘ (only path name)
File.Export Format Enum types SHAPE
File.Export PointObjects
LineObjects
AreaObjects
TextObjects
Boolean
Boolean
Boolean
Boolean
true, false
true, false
true, false
true, false
File.Export Dataset String all for 'All objects'
or index eg.: 2 (Objects in dataset with index = 2)
File.Export WordWrap Boolean true, false
File.Export ProjectionFile Boolean true, false
File.Export Utf8Encoding Boolean true, false

Example

The following example exports two pdf files in spot colors and two Shape files. Each OcadScript node can contain many children.

 <?xml version="1.0" encoding="ISO-8859-1"?>
 <OcadScript> 
   <File.Open>
     <File>M:\OCAD11\Changes\11-06xx\11-0663\Chlosterwald.ocd</File>
   </File.Open>
   <File.Export>
     <File>M:\OCAD11\Changes\11-06xx\11-0663\output\Chlosterwald.pdf</File>
     <Format>PDF</Format> 
     <PartOfMap>	
       <Enabled>true</Enabled>
       <Coordinates>mm</Coordinates>
       <L>0</L>
       <R>50</R>
      <B>50</B>
       <T>100</T>
     </PartOfMap>	
     <ExportScale>10000</ExportScale>
     <Colors>spotColors</Colors> 
     <SpotColors> 
       <Combine>false</Combine>
       <Enabled>Blau</Enabled>
       <Enabled>Gelb</Enabled>
     </SpotColors> 
   </File.Export> 
   <File.Export>
     <ExportPath>M:\OCAD11\Changes\11-06xx\11-0663\output\</ExportPath>
     <Format>SHAPE</Format>
     <PointObjects>false</PointObjects>
     <LineObjects>true</LineObjects>
     <AreaObjects>true</AreaObjects>
     <TextObjects>false</TextObjects>
     <Dataset>all</Dataset>
     <WordWrap>true</WordWrap>
     <ProjectionFile>false</ProjectionFile>
   </File.Export>
   <File.Save>
     <Enabled>true</Enabled>
   </File.Save>
   <File.Close>
     <Enabled>true</Enabled>
   </File.Close>
 </OcadScript> 

Run XML Script from the Command Line

It is possible to execute a XLM script file from the command line or from batch file.

Open the Windows command and enter the OCAD program name and the xml script file. For example: "C:\Program Files\OCAD\OCAD 11\Ocad11.exe" "C:\Data\ExportScriptExample_PDF.xml"

Do not forget to use the parameter <File.Open> to open the file, <File.Close> to close it and <File.Exit> to close OCAD.


Previous Chapter: Database

Next Chapter: Course Setting for Orienteering

Back to Main Page