Difference between pages "Graphical User Interface" and "Select"

From OCAD Wiki - English
(Difference between pages)
Jump to navigation Jump to search
 
 
Line 1: Line 1:
[[File:GUI.JPG|1000x1000px]]
+
* To select single objects press '''Crtl''' while marking by clicking objects with mouse or
 +
* pressed drag the mouse pointer over the objects.
  
  
==Toolbars==
+
==Select and Edit Object==
 
+
Choose '''Select and Edit Object''' in the '''Select''' menu or click the '''Select and Edit Object''' icon in the '''Editing and Drawing Toolbar''' to select and edit an object.
The Toolbars can be moved within the graphical user interface. The buttons can be individually shown or hidden via the '''Options''' menu under '''OCAD Preferences''', '''GUI (Graphical user Interface)''', '''Toolbars'''.  
 
 
 
[[File:Toolbars.png|toolbars]]
 
  
 +
==Select Object and Edit Vertex==
 +
ToDo
  
===Standard Toolbar===
+
==Select Objects by Symbol==
[[File:StandardToolbar.png|Standard Toolbar]]
 
: [[File:Icon_New.PNG|new]] '''New:''' Create a new map.
 
: [[File:Icon_Open.PNG|open]] '''Open:''' Open an existing map.
 
: [[File:Icon_Save.PNG|save]] '''Save:''' Save changes made to the map.
 
: [[File:Icon_Print.PNG|print]] '''Print:''' Print out the map.
 
: [[File:Icon_Undo.PNG|undo]] '''Undo:''' Undo previous actions.
 
: [[File:Icon_Redo.PNG|redo]] '''Redo:''' Cancel the previous undo action.
 
  
===Edit Functions Toolbar===
+
Choose this command to select all objects with certain symbols or in a certain layer.  
[[File:EditFunctionsToolbar.png|Edit Functions Toolbar]]
 
: [[File:Icon_FindSelectedObjects.PNG|find selected objects]] '''Find Selected Objects:''' Move screen to the selected object.
 
: [[File:Icon_Delete.PNG|delete]] '''Delete:''' Delete the selected object(s).
 
: [[File:Icon_RotateEnterAngle.PNG]] '''Rotate (Enter Angle)''': Rotate selected object(s) by entering angle.
 
: [[File:Icon_AlignObjectsHorizontal.PNG]] '''Align Objects: Horizonal Coordinates'''
 
: [[File:Icon_AlignObjectsVertical.PNG]] '''Align Objects: Vertical Coordinates'''
 
: [[File:Icon_InterpolateObjects.PNG]] '''Interpolate Objects'''
 
: [[File:Icon_DuplicateObject.PNG|duplicate object]] '''Duplicate Object:''' Create a copy of the selected objects.
 
: [[File:Icon_FillOrMakeBorder.PNG|fill or make border]] '''Fill or Make Border:''' Fill a line or area object(s) with area object(s) or make line border of area object(s).
 
: [[File:Icon_Merge.PNG|merge]] '''Merge:''' Merge multiple line, area and text objects into one object.
 
: [[File:Icon_ReverseObject.PNG|reverse object]] '''Reverse Object:''' Reverse the direction of the selected line object(s)
 
: [[File:Icon_ChangeToPolyline.png]] '''Change to Polyline'''
 
: [[File:Icon_ChangeToBezierCurve.PNG|change to Bézier curve]] '''Change To Bézier Curve''': Convert the selected line or area object(s) drawn in freehand mode to curves.
 
: [[File:Icon_ConvertToGraphicObject.PNG|convert to graphic object]] '''Convert To Graphic Object:''' Convert the selected object(s) to their graphic elements (lines and areas).
 
: [[File:Icon_Smooth.PNG|smooth]] '''Smooth'''
 
: [[File:Icon_Snapping.PNG|snapping]] '''Snapping'''
 
: [[File:Icon_Join.PNG|join]] ''' Join:''' Move the ends of the selected line object to connect to adjoining objects.
 
: [[File:Icon_ChangeSymbolOfObject.PNG|change symbol of object]] '''Change Symbol of Object:''' The selected object is assigned to the symbol selected in the symbol box.
 
: [[File:Icon_ChangeSymbolForAllObjectsWithThisSymbol.PNG|change symbol for all objects with this symbol]] '''Change Symbol For All Objects With This Symbol:''' Change the symbol of all objects with a symbol A to symbol B.
 
: [[File:Icon_Measure.PNG|measure]] '''Measure:''' Measure the selected line or area object or the distance between 2 selected vertices objects.
 
  
: [[File:Icon_AutomaticJoining.PNG|automatic joining]] '''Automatic joining:''' Automatically join the ends of lines during the drawing process. The '''Join when drawing lines''' tolerance can be set in the [[OCAD_Preferences#Tolerances|OCAD Preferences]]. To switch off the automatic joining temporary during drawing, press the Shift key when terminating the line.
+
* All objects with a selected symbol
 +
* All objects ins layer
 +
* Layout objects
 +
* Unsymbolized objects
 +
* Graphic objects
 +
* Image obejcts
 +
* Objects with invalild symbol type
  
: [[File:SmoothingLvl.JPG|smoothing level]] '''Smoothing level''':  This option is used to select the required smoothing level for lines, for converting freehand lines into Bézier curves and for automatically smoothing lines drawn in freehand mode.
 
  
===View Toolbar===
+
==Select Objects by Property==
[[File:ViewToolbar.png|View Toolbar]] 
 
  
Various functions are available for increasing or reducing the size of map sections as well as repositioning them.
+
This command is activated if a map file is loaded.
: [[File:Icon_Pan.PNG|pan]] '''Pan:''' Reposition the map section
 
: [[File:Icon_PanLocked.PNG|pan locked]] '''Pan locked:''' Reposition the map section a number of times in succession.
 
: [[File:Icon_ZoomIn.PNG|zoom in]] '''Zoom In:''' Increase the size of the map section.
 
: [[File:Icon_ZoomInLocked.PNG|zoom in locked]] '''Zoom in locked:''' Increase the size of the map section a number of times in succession.
 
: [[File:Icon_ZoomOut.PNG|zoom out]] '''Zoom Out:''' Reduce the size of the map section.
 
: [[File:Icon_ZoomOutToPreviousView.PNG|zoom out to previous view]] '''Zoom out to previous view:''' Return to last smaller map section.
 
: [[File:Icon_ZoomToPreviousView.PNG|zoom to previous view]] '''Zoom to previous view:''' Return to last map section.
 
: [[File:Icon_ZoomToNextView.PNG|zoom to next view]] '''Zoom to next view:''' Go to previous map section.
 
: [[File:Icon_ShowEntireMap.PNG|show entire map]] '''Show Entire Map:''' Display the entire map in the drawing window.
 
: [[File:DraftMode.JPG|draft mode slider]] '''Draft mode slider:''' The upper slider (M for map) is used to fade out the map objects; the lower slider (B for background) to fade out the map background.The Draft mode slider is only visible if Draft Mode is active in the View menu.
 
: [[File:Icon_ShowGrid.PNG|show grid]] '''Show grid:''' Display the coordinate grid in the drawing window.
 
  
===Edit and Drawing Toolbar===
+
'''Select'''
[[File:EditAndDrawingToolbar.png|Edit and Drawing Toolbar]]
 
====Edit modes====
 
: [[File:Icon_SelectAndEditObject.PNG|select and edit object]] '''[[Select#Select and Edit Object|Select and Edit Object]]:''' Select and move objects.
 
: [[File:Icon_SelectObjectAndEditVertex.PNG|select object and edit vertex]] '''[[Select#Select Object and Edit Vertex|Select Object and Edit Vertex]]:''' Select objects or move points of objects.
 
: [[File:Icon_NormalVertex.PNG|normal vertex]] '''[[Edit Object#Add Vertices|Normal Vertex:]]''' Add a vertex. This will not influence a dashed line.
 
: [[File:Icon_CornerVertex.PNG|corner vertex]] '''[[Edit Object#Add Vertices|Corner Vertex:]]''' Add a corner vertex or turn a normal vertex into a dash vertex. This will affect the dashed line so that it will start with a full dash from this point and/or a symbol will appear in the corner vertex.
 
: [[File:Icon_DashVertex.PNG|dash vertex]] '''[[Edit Object#Add Vertices|Dash Vertex:]]''' Add a dash vertex or turn a normal vertex into a dash vertex. This will affect the dashed line, which will start with half a dash from this point.
 
: [[File:Icon_RemoveVertex.PNG|remove vertex]] '''[[Edit Object#Remove Vertex|Remove Vertex]]'''
 
: [[File:Icon_IndicateDirectionOfAreaPatternPointOrTextObject.PNG|indicate direction of area pattern point or text object]] ''' Indicate Direction of Area Pattern, Point or Text Object'''
 
: [[File:Icon_RotateObject.PNG|rotate object]] '''Rotate Object:''' Rotate the selected object(s).
 
: [[File:Icon_CutHole.PNG|cut hole]] '''Cut hole:''' Cut a hole into the selected area object.
 
: [[File:Icon_CutArea.PNG|cut area]] '''Cut area:''' Cut the selected area object.
 
: [[File:Icon_Cut.PNG|cut]] '''Cut:''' Cut the selected line object or the borderline of the selected double line or area.
 
: [[File:Camera.jpg|video available]] [http://www.ocad.com/howtos/70.htm Cutting]
 
: [[File:Icon_MoveParallel.PNG|move parallel]] '''Move parallel:''' Move the selected line or area object parallel to the original object.
 
: [[File:Icon_Reshape.PNG|reshape]] '''Reshape:''' To shape (something) again or differently
 
 
 
====Drawing modes====
 
: [[File:Icon_CurveMode.PNG|curve mode]] [[Drawing_an_Object#Draw_a_Curve|'''Curve mode:''']] Draw in curve mode.
 
: [[File:Icon_EllipseMode.PNG|ellipse mode]] [[Drawing_an_Object#Draw_an_Elliptical_Object|'''Ellipse mode:''']] Draw elliptical (oval) objects.
 
: [[File:Icon_CircleMode.PNG|circle mode]] [[Drawing_an_Object#Draw_a_Circular_Object|'''Circle mode:''']]  Draw circular objects.
 
: [[File:Icon_RectangularLineMode.PNG|rectangular line mode]] [[Drawing_an_Object#Draw_a_Rectangular_Line|'''Rectangular line mode:''']] Draw rectangular line objects with any number of corners.
 
: [[File:Icon_RectangularMode.PNG|rectangular mode]] [[Drawing_an_Object#Draw_a_Rectangular_Area|'''Rectangular mode:''']]  Draw rectangular area objects with any number of corners.
 
: [[File:DrawingModeStairway.PNG|Stairway drawing mode]] [[Drawing_an_Object#Draw_a_Stairway|'''Stairway drawing mode:''']] Draw a rectangular stairway.
 
: [[File:Icon_StraightLineMode.PNG|straight line mode]] [[Drawing_an_Object#Draw_a_Straight_Line|'''Straight line mode:''']] Draw objects with straight lines.
 
: [[File:Icon_FreehandMode.PNG|freehand mode]] [[Drawing_an_Object#Draw_a_Freehand_Line|'''Freehand mode:''']] Draw objects in freehand mode.
 
: [[File:Icon_DrawingMultiplePointObjects.PNG|drawing multiple point objects]] [[Drawing_an_Object#Draw_Multiple_Point_Objects|'''Drawing multiple point objects:''']] Draw several point objects that are placed on a line with a constant interval.
 
: [[File:Icon_LaserDistance.PNG]] [[Connect_to_Laser_Distance_Meter|'''Laser distance drawing mode:''']] Draw objects by distances transmitted from a laser distance meter.
 
: [[File:Icon_NumericMode.PNG|numeric mode]] [[Drawing_an_Object#Numerical_Drawing_Mode|'''Numeric Mode:''']] Draw objects in numeric mode.
 
 
 
: [[File:NumericToolbar.JPG|numeric toolbar]] '''Numeric Toolbar'''
 
 
 
===Server Toolbar===
 
 
 
See here: [[Server Client#The database module tool bar|Server Toolbar]]
 
 
 
===Numeric Keypad Toolbar===
 
[[File:NumericKeypadToolbar.png|Numeric Toolbar]]
 
 
 
ToDo
 
 
 
===Mobile Toolbar===
 
[[File:MobileToolbar.png|Mobile Toolbar]]
 
 
 
ToDo
 
  
===Customize Toolbar Dialog Box===
+
The first option All Objects means that the selection is made out of all objects in the map.
Choose this command to customize toolbars.
+
The second option Objects with a selected symbol means that the selection is reduced to the objects with a symbol that is selected in the symbol box.
The dialog box is opened by clicking '''Customize''' button in on '''GUI (Graphical User Interface)''' page in '''OCAD Preferences''' dialog box or by clicking on the right end of a toolbar.
 
When the box above the button is checked the button will be visible otherwise it will be hidden.
 
  
[[File:CustomizeToolbars.png|CustomizeToolbars.png]]
+
'''Condition'''
  
[[File:Hint.jpg|hint]] The Numeric keypad toolbar cannot be customized.
+
* Choose a property like Number of vertices, Length etc.
 +
* Choose an operator like < > = etc.
 +
* Enter a condition value.
  
==Menu==
+
   
The OCAD Professional Edition features the following 15 menus:
 
  
[[File:Menu.JPG|menu]]
+
'''Example 1'''
  
*'''File''': File management, file import and export functions, printing
+
Option All objects
*'''Server/Client''': Functions for Server/Client
+
Condition: Length > 200
*'''View''': Functions for viewing the map
+
'''Result:''' All map objects with a length longer than 200 m are selected and listed in a table dialog box.
*'''Select''': Functions for selecting an object or a vertex
 
*'''Object''': Object editing functions
 
*'''Symbol''': Functions for creating and editing symbols
 
*'''Map''': Map editing functions
 
*'''Layout''': Function for layout managing
 
*'''Database''': Functions for connecting and editing databases
 
*'''Background Map''': Functions for loading and managing background maps
 
*'''DEM''': Functions for the import, export and evaluation of Digital Elevation Models 
 
*'''GPS''': Functions for connecting GPS devices or importing GPS data
 
*'''Options''': Functions for customizing personal preferences
 
*'''Window''': Functions for arranging the map window
 
*''' Help ''': OCAD Help
 
  
  
===[[File|File Menu]]===
+
'''Example 2'''
: '''[[Create a New Map|New]]:''' Create a new map.
 
: '''[[File#Open|Open]]:''' Open an existing map file.
 
: '''[[File#Open Sample Map|Open Sample Map]]:''' Open a sample map file.
 
: '''[[File#Close|Close]]:''' Close the current map file.
 
: '''[[File#Save|Save]]:''' Save changes in the current map file.
 
: '''[[File#Save As|Save As]]:''' Save the current map file under a new name.
 
: '''[[Undo and Redo|Undo]]:''' Undo the last draw or edit operation.
 
: '''[[Undo and Redo|Redo]]:''' Reverse the effect of the Undo operation.
 
: '''[[Printing Maps|Print]]:''' Print a color map or color separations.
 
: '''[[Import Files|Import]]:''' Import a map file.
 
: '''[[Export Files|Export]]:''' Export the map in a different file format.
 
: '''[[Export Files#OIM Export Assistent|Export OCAD Internet Map]]:''' Export the map to OCAD Internet Map.
 
: '''[[Export Files#Export Encrypted File|Export Encrypted File]]:''' Export the map to encrypted OCAD file format.
 
: '''[[Send File by Email]]:''' Send current map file by email.
 
: '''[[XML Script|Execute XML Script]]:''' Execute function defined in a XML script file.
 
: '''[[Create Backup and Restore Backup|Create Backup]]:''' Make a backup copy of the current map file.
 
: '''[[Create Backup and Restore Backup|Restore Backup]]:''' Restore a map file saved with the Backup function.
 
: '''[[File#Open Recently Exported Documents|Open Recently Exported Documents]]:''' Open one of the documents you have exported recently.
 
: '''[[File#Open Recently Used OCAD Files|Open Recently Used OCAD Files]]:''' Open one of the map files you have worked on recently. 
 
: '''Exit OCAD:''' Terminate OCAD.
 
  
===[[Server Client|Server/Client Menu]]===
+
Select two symbols in the symbol box (ex. lake and pond)
: '''[[Server Client#Connect/Disconnect|Connect/Disconnect]]:''' Connect or disconnect the connection to the server
+
Option: Objects with a selected symbol
: '''[[Server Client#Get Objects from Current View|Get Objects from Current View]]'''
+
Condition: Area <= 3000
: '''[[Server Client#Import Map|Import Map]]:''' Import a Map from the connected server
+
'''Result:''' All lakes and ponds with an area smaller or equal than 3000 m2 are selected and their properties listed in a table dialog box.
: '''[[Server Client#Delete Object in Database|Delete Object in Database]]'''
 
: '''[[Server Client#Check Out Selected Objects|Check Out Selected Objects]]:''' Check out selected objects for editing.
 
: '''[[Server Client#Check in Selected bjects|Check in Selected Objects]]:''' Check out selected objects after finished edited objects.
 
: '''[[Server Client#Show Checked Out Objects|Show Checked Out Objects]]:''' Show current checked out objects.
 
: '''[[Server Client#Database Undo|Database Undo]]:''' Undo your last move in the database.
 
: '''[[Server Client#Database Redo|Database Redo]]:''' Redo your last move in the database.
 
: '''[[Server Client#Generate  Map Preview:|Generate  Map Preview]]''' Generate preview from current map.
 
: '''[[Server Client#Do Database Maintenance|Do Database Maintenance]]:''' Upkeep Database
 
: '''[[Server Client#Manage Server Bookmarks|Manage Server Bookmarks]]'''
 
: '''[[Server Client#Show Project Information|Show Project Information]]'''
 
  
===View Menu===
 
: '''[[View Mode#Normal Mode|Normal Mode]]:''' Normal mode view.
 
: '''[[View Mode#Spot Color Mode|Spot Color Mode]]:''' Spot color view.
 
: '''[[View Mode#Draft Mode|Draft Mode]]:''' Draft mode view. The background map can be seen behind the map.
 
: '''[[View Mode#Draft Mode Only Background Map Favorites|Draft Mode Only Background Map Favorites]]:''' Map display transparent, background maps  visible
 
: '''[[Keyline]]:''' Shows a rough sketch, where objects has been placed .
 
: '''[[Hatch Areas]]:''' Display full areas as hatched areas on the screen.
 
: '''[[Anti-Aliasing]]:''' Anti-Aliasing view.
 
: '''[[Zoom Navigation#Redraw|Redraw]]:''' Redraw the drawing window.
 
: '''[[Zoom Navigation#Pan|Pan]]:''' Move the view.
 
: '''[[Zoom Navigation#Move To|Move To]]:''' Move the view to a desired position.
 
: '''[[Zoom Navigation#Find Selected Objects|Find Selected Objects]]:''' Find desired objects
 
: '''[[Zoom Navigation#Zoom In|Zoom In]]:''' Display the map with a higher magnification.
 
: '''[[Zoom Navigation#Zoom Out|Zoom Out]]:''' Display a larger area of the map.
 
: '''[[Zoom Navigation#Zoom to Selected Objects|Zoom to Selected Objects]]:''' Move screen zoom to selected objects.
 
: '''[[Zoom Navigation#Show Entire Map|Show Entire Map]]:''' Display the entire map on the screen.
 
: '''[[Zoom Navigation#Zoom|Zoom]]:''' Select the magnification in which the map is displayed.
 
: '''[[Zoom Navigation#User Defined|User Defined]]:''' Choose this command to set view to a specified zoom factor.
 
: '''[[Zoom Navigation#Bookmarks|Bookmarks]]:''' Create and manage bookmarks of view.
 
: '''-Create:''' Create a new bookmark
 
: '''-Manage:''' Manage available bookmarks
 
: '''[[Show Screen Grid]]:''' A grey grid is shown in the drawing window.
 
: '''[[Show Rulers]]:''' Shows up and down a ruler .
 
: '''[[Ruler Guides]]:''' Show and manage ruler guides
 
: '''-Show:''' Show vertically or horizontally ruler guide
 
: '''-Manage:''' Add new ruler guide.
 
  
===[[Select]] Menu===
+
==Select All==
: '''[[Select#Select and Edit Object|Select and Edit Object]]:''' Select, move or stretch object(s).
+
Choose '''Select All''' in the '''Select''' menu to select all symbolized (also from protected and hidden symbols), unsymbolized, graphic and image objects. Layout objects are not selected.
: '''[[Select#Select Object and Edit Vertex|Select Object and Edit Vertex]]:''' Select or move vertex of object(s).
 
: '''[[Select#Select Objects by Symbol|Select Objects by Symbol]]:''' Select all objects with same symbol .
 
: '''[[Select#Select Objects by Property|Select Objects by Property]]:''' Select all objects with same properties.
 
: '''[[Select#Select All|Select All]]:''' Select all objects in map.
 
: '''[[Select#Clear Selection|Clear Selection]]:''' Nothing is selected.
 
: '''[[Select#Invert Selection|Invert Selection]]:''' Change current selection such that everything previously unselected will now be selected and vice versa
 
: '''[[Select#Select Next Object|Select Next Object]]:''' Selects the next obvious object.
 
: '''[[Select#Save Selection|Save Selection]]:''' Save current selection for later use.
 
: '''[[Select#Reload Selection|Reload Selection]]:''' Reload saved selection.
 
: '''[[Select#Edit Selection|Edit Selection]]:''' Manage saved selection.
 
: '''[[Select#Select Group|Select Group]]:''' Select a group of objects.
 
  
===Object menu===
+
==Clear Selection==
: '''[[Object#Cut|Cut]]:''' Copy the selected object(s) to the clipboard and delete them in the current map.
+
Choose '''Clear Selection''' in the '''Select''' menu to deselect all objects.
: '''[[Object#Copy|Copy]]:''' Copy the selected object(s) to the clipboard.
 
: '''[[Object#Paste|Paste]]:''' Insert the object(s) in the clipboard into the current map.
 
: '''[[Object#Delete|Delete]]:''' Delete the selected object(s).
 
: '''[[Edit Object#Rotate Object|Rotate Object]]:''' Rotate object(s).
 
: '''-[[Edit Object#Rotate an Object|Rotate]]:''' Rotate the selected object(s).
 
: '''-[[Edit Object#Rotate an Object by Angle|Rotate Object by Angle]]:''' Rotate the selected point object(s) by specifying a rotation angle.
 
: '''[[Edit Object#Align Objects|Align Objects]]:''' Align the selected objects horizontally or vertically.
 
: '''-Horizontal Coordinate'''
 
: '''-Vertical Coordinate'''
 
: '''[[Edit Object#Indicate Direction of Area Pattern or Point or Text Object|Indicate Direction of Area Pattern, Point or Text Object]]:''' Change direction of selected point object, area pattern or text.
 
: '''[[Edit Object#Cut a Hole or Area or Line|Cut Objects]]:''' Cut hole, area or line.
 
: '''-Cut hole:''' Cut a hole in an object.
 
: '''-Cut area:''' Divides an area.
 
: '''-Cut line:''' Divides a line.
 
: '''[[Crop Objects]]:''' Crop selected Object(s).
 
: '''[[Move Parallel and Move Parallel with Distance#Move Parallel|Move Parallel]]:''' Move the selected line or area object parallel from the original object.
 
: '''[[Move Parallel and Move Parallel with Distance#Move Parallel with Distance|Move Parallel with Distance]]:''' Move the selected line or area object parallel with a distance from the original object.
 
: '''[[Reshape]]:''' To shape a part of an object again or differently.
 
: '''[[Interpolate Objects]]:''' Interpolate selected Objects to each other.
 
: '''[[Duplicate and Move and Duplicate#Duplicate|Duplicate]]:''' Duplicate (create a copy of) the selected object(s).
 
: '''[[Duplicate and Move and Duplicate#Move and Duplicate|Move and Duplicate]]:''' Duplicate selected object and move it.
 
: '''[[Mirror and Duplicate]]:''' Mirror selected object and duplicate it.
 
: '''[[Edit Object#Fill or Make Border or Duplicate Identically|Fill, Make Border, Duplicate Identically]]:''' Fill a line or area object(s) with area object(s) or make line border of area object(s).
 
: '''[[Edit Object#Merge|Merge]]:''' Merge multiple line, area and text objects into one object.
 
: '''[[Edit Object#Reverse Object Direction|Reverse Object Direction]]:''' Reverse the direction of the selected line object(s).
 
: '''[[Change to Polyline and Change to Bezier Curve#Change to Polyline|Change to Polyline]]:''' Change selected object to polyline.
 
: '''[[Change to Polyline and Change to Bezier Curve#Change to Bezier Curve|Change to Bézier Curve]]:''' Change selected object to a Bézier curve.
 
: '''[[Convert to Graphic Object]]:''' Convert the selected object(s) to their graphic elements (lines and areas).
 
: '''[[Convert to Layout Object]]:''' Convert selected object to layout object.
 
: '''[[Smooth]]:''' Smooth selected line or area object(s) drawn in freehand mode.
 
: '''[[Create Color Gradient]]'''
 
: '''[[Topology]]'''
 
: '''-[[Topology#Join|Join]]:''' Move the ends of the selected line object to connect to adjoining objects.
 
: '''-[[Topology#Select Duplicate Objects|Select Duplicate Objects]]:''' Duplicate the selected object(s).
 
: '''-[[Topology#Select Self-Intersected Objects|Select Self-Intersected Objects]]'''
 
: '''-[[Topology#Merge with Condition|Merge with Condition]]:''' Merge with conditions the selected objects into one object.
 
: '''-[[Topology#Create Point Objects at Line Ends|Create Point Objects at Line Ends]]'''
 
: '''-[[Topology#Close Area Objects|Close Area Objects]]'''
 
: '''-[[Topology#Remove Overshoots and Undershoots|Remove Overshoots and Undershoots]]'''
 
: '''-[[Topology#Insert Intersections|Insert Intersections]]'''
 
: '''[[Edit Object#Change Vertex Types to|Change Vertex Types to]]:''' Change vertex types for the selected object(s).
 
: '''[[Change Symbol|Change Symbol (Selected objects)]]'''
 
: '''[[Change Symbol|Change Symbol (All Objects with Corresponding Symbol)]]'''
 
: '''[[Group and Ungroup|Group]]'''
 
: '''[[Group and Ungroup|Ungroup]]'''
 
: '''[[Edit Object#Find and Replace Text|Find and Replace Text]]'''
 
: '''[[Insert Glyphs]]''': Insert special letters.
 
: '''[[Edit Object#Measure|Measure]]:''' Measure the selected line or area object or the distance between 2 selected point objects
 
: '''[[Edit Object#Object Information|Object Information]]:''' Show information about selected object(s).
 
  
===[[Symbol]] Menu===
+
==Invert Selection==
: '''[[Symbol#New|New]]:''' Create a new symbol.
+
Choose '''Invert Selection''' in the '''Select''' menu to deselect all selected objects and select all unselected object. Layout objects are not selected.
: '''[[Symbol#Edit|Edit]]:''' Define or redefine the selected symbol.
 
: '''[[Symbol#Icon|Icon]]:''' Draw or edit the symbol's icon, which appears in the symbol box.
 
: '''[[Symbol#Enlarge Reduce|Enlarge/Reduce]]:''' Enlarge or reduce the selected symbol or all symbols.
 
: '''[[Symbol#Copy|Copy]]:''' Copy the selected symbol to the clipboard.
 
: '''[[Symbol#Paste|Paste]]:''' Copy a symbol from the clipboard to the current map.
 
: '''[[Symbol#Delete|Delete]]:''' Delete the selected symbol.
 
: '''[[Symbol#Duplicate|Duplicate]]:''' Make a copy of the selected symbol.
 
: '''[[Symbol Box#Sort Symbol Box|Sort Symbol Box]]:''' Sort the symbols in the symbol box.
 
: '''-By Number:''' Sort symbol in symbol box by number.
 
: '''-By Color:''' Sort symbol in symbol box by color.
 
: '''-By Status (Normal, Protect or Hide):''' Sort symbol in symbol box by status.
 
: '''[[Symbol Box#Select|Select]]:''' Select certain symbols in the symbol box.
 
: '''-Used:''' Select used symbols in symbol box.
 
: '''-Unused:''' Select unused symbols in symbol box.
 
: '''-Invert:''' Change current selection such that everything previously unselected will now be  and vice versa.
 
: '''-All:''' Select all symbols in symbol box.
 
: '''-By Color:''' Select all Symbols with same color.
 
: '''-By Font:''' Select all Sybmols with same font.
 
: '''[[Symbol#Replace|Replace]]:'''
 
: '''-[[Symbol#Replace Font in Symbols|Font]]'''
 
: '''-[[Symbol#Replace Color in Symbols|Color]]'''
 
: '''[[Symbol#Normal|Normal]]:''' Make objects with the selected symbol(s) appear normal.
 
: '''[[Symbol#Protect|Protect]]:''' Make objects with the selected symbol(s) protected from editing.
 
: '''[[Symbol#Hide|Hide]]:''' Objects with the selected symbol(s) do not appear.
 
: '''[[Symbol#Show Unsymbolized Objects|Show Unsymbolized Objects]]:''' Normal / Hide.
 
: '''[[Symbol#Show Graphic Objects|Show Graphic Objects]]:''' Normal / Hide.
 
: '''[[Symbol#Image Objects|Image Objects]]:''' Normal / Protect / Hide
 
: '''-Normal:''' Selected Symbols are not protected and not hidden.
 
: '''-Protect:''' Selected symbol(s) are visible but cannot be edited.
 
: '''-Hide:''' Selected symbol(s) are not visible .
 
: '''[[Symbol Box#Show Symbol Favorites|Show Symbol Favorites]]:''' Display the symbol favorites in symbol box.
 
: '''[[Symbol Box#Add to Symbol Favorites|Add To Favorites]]:''' Add the selected symbol(s) to symbol favorites.
 
: '''[[Symbol Box#Remove from Symbol Favorites|Remove From Favorites]]:''' Remove the selected symbol(s) from symbol favorites.
 
: '''[[Symbol Box#Show Symbol Tree|Show Symbol Tree]]:''' Display the symbol tree in symbol box.
 
: '''[[Symbol Box#Remove from Symbol Tree|Remove From Symbol Tree]]:''' Remove the selected symbol(s) from symbol tree.
 
  
===[[Map]] Menu===
+
==Select Next Object==
: '''[[Map#Optimize_and_Repair|Optimize/Repair]]:''' Remove empty space in the map file and repair damaged objects.
 
: '''[[Map#Set Scale and Coordinate System|Set Scale and Coordinate System]]:''' Set map scale and define the coordinate system.
 
: '''[[Map#Change Scale|Change Scale]]:''' Change the scale of the map and enlarge/reduce the map according to the new scale.
 
: '''[[Map#Create Map Grid|Create Map Grid]]:''' Create grid lines on the map.
 
: '''[[Create WGS84 Grid]]:''' Create a WGS84 grid on your current view.
 
: '''[[Map#Hide|Hide]]:''' Hide the map on the screen.
 
: '''[[Map Transform|Transform]]:''' Adjust the map to the background map.
 
: '''-[[Map Transform#Move|Move]]:''' Move the entire map to a different location in the coordinate system.
 
: '''-[[Map Transform#Stretch_or_Shrink|Stretch / Shrink]]:''' Stretch (enlarge or reduce) the entire map horizontally or vertically.
 
: '''-[[Map Transform#Mirror|Mirror]]:''' Mirror the entire map horizontally or vertically.
 
: '''-[[Map Transform#Rotate Map|Rotate Map]]:''' Rotate the entire map.
 
: '''-[[Map Transform#Change Coordinate System|Change Coordinate System]]:''' Change current coordinate system to another.
 
: '''-[[Map Transform#Affine|Affine]]:''' Adjust the whole map on background map or on grid.
 
: '''-[[Map Transform#Rubbersheeting|Rubbersheeting]]:''' Adjust a part of the map on a georeferenced background map.
 
: '''-[[Map Transform#Center Map to Drawing Area|Center map to Drawing Area]]'''
 
: '''[[Map#Convert Imported Layers to Symbols|Convert Imported Layers to Symbols]]:''' Convert the layers of an imported *.dxf or *.ai file.
 
: '''[[Map#Convert Area or Line Objects to Point Objects|Convert Area or Line Objects to Point Objects]]:''' Convert area to point object(s).
 
: '''[[Map#Convert Text Objects to Point Objects|Convert Text Objects to Point Objects]]:''' Convert text to point object(s).
 
: '''[[Map#Convert Text Objects from OEM to Unicode|Convert Text Objects from OEM to Unicode]]:''' Convert text objects from OEM to Unicode.
 
: '''[[Map#Export Objects by Selected Symbols|Export Objects by Selected Symbol]]:''' Export all objects with a selected symbol to a new map file.
 
: '''[[Map#Export Selected Objects|Export Selected Objects]]'''
 
: '''[[Map#Export Part of Map|Export Part of Map]]'''
 
: '''[[Colors]]:''' Define or edit the colors of the current map.
 
: '''[[Colors#Spot_Colors|Define Spot Colors]]:''' Define the spot colors of the current map.
 
: '''[[Colors#Load Colors From|Load Colors From]]:''' Load a color table from another map.
 
: '''[[Colors#Load Colors and Symbols From|Load Colors and Symbols From]]:''' Load the symbol set from another map.
 
: '''[[Map#Compare Symbols and Colors|Compare Colors and Symbols]]:''' Compare two symbol sets.
 
: '''[[Routing]]:''' Import kml file with route from Google Maps API
 
: '''[[Map#Map Information|Map Information]]:''' Show map information.
 
  
===Layout Menu===
+
Choose '''Select Next Object''' in the '''Select''' menu to select an object which is behind an object that is already selected.
: '''[[Layout#Edit_Layout_Objects|Edit Layout Objects]]:''' Draw and edit the layout objects.
 
: '''[[Layout#Import Layout|Import Layout]]'''
 
: '''[[Layout#Save Layout|Save Layout]]'''
 
: '''[[Layout#Hide|Hide]]'''
 
: '''[[Layout#Add North Arrow or Scale Bar|Add North Arrow or Scale Bar]]'''
 
: '''[[Layout#Add Map Legend|Add Map Legend]]'''
 
: '''[[Layout#Add Trim and Bleed Marks|Add Trim and Bleed Marks]]'''
 
: '''[[Layout#Create Graticule Name Index|Create Graticule Name Index]]'''
 
: '''[[Layout#Create Name Index|Create Name Index]]'''
 
  
===Database Menu===
+
==Save Selection ==
: '''[[Database#Manage Database Connections|Manage Database Connections]]:''' Create and edit datasets.
 
: '''[[Database#Create and Update Records|Create and Update Records]]:''' Create OCAD objects out of the database.
 
: '''[[Database#Update Special Fields|Update Special Fields]]'''
 
: '''[[Database#Create Objects from Table|Create Objects from Table]]:''' Create OCAD objects from database records.
 
: '''[[Database#Assign Symbols by Records|Assign Symbols by Records]]'''
 
: '''[[Database#Add Texts by Records|Add Texts by Records]]'''
 
: '''[[Database#Define Object Directions by Records|Define Object Directions by Records]]:''' Assign angle information from the open dataset(s) to the objects.
 
: '''[[Database#Merge Objects by Records|Merge Objects by Records]]'''
 
: '''[[Database#Select Linked Objects with Corresponding Record|Select Linked Objects with Corresponding Record]]'''
 
: '''[[Database#Select Linked Objects without Corresponding Record|Select Linked Objects without Corresponding Record]]'''
 
: '''[[Database#Select Objects Linked to the same Record|Select Objects Linked to the same Record]]'''
 
: '''[[Database#Delete Database Record when Deleting Object|Delete Database Record when Deleting Object]]:''' If the option is turned on and an OCAD object with a linked database record is deleted, the database record is deleted, too.
 
: '''[[Database#Create Database Record when Cutting Object|Create Database Record when Cutting Object]]'''
 
  
===Background Map Menu===
+
Choose '''Save Selection''' in the '''Select''' menu to save the current selection. The '''Save Selection''' dialog box appears.
: '''[[Background_Map#Scanning_a_Background_Map|Scan]]:''' Scan a background map using a TWAIN interface.
 
: '''-Acquire:''' Acquire a background map
 
: '''-Select Source:''' Select source from which the background map acquire
 
: '''[[Background_Map#Open_a_Background_Map|Open]]:''' Open a scanned background map stored in a file.
 
: '''[[Background_Map#Adjust_a_Background_Map|Adjust]]:''' Adjust the background maps in horizontal and vertical directions.
 
: '''[[Background_Map#Hide_all_Background_Maps|Hide All]]:''' Hide the background maps temporarily.
 
: '''[[Background_Map#Manage_Background_Maps|Manage]]:''' Set options for displaying and printing the background maps.
 
: '''[[WMS|WMS - Web Map Service]]:''' Add background map from WMS
 
  
===DEM Menu===
+
[[File:SaveSelection.PNG]]
: '''[[DEM#Import|Import]]:''' Import an ASCII Grid or XYZ file to OCAD.
 
: '''[[DEM#Open|Open]]:''' Open an OCAD DEM file (*ocdDem).
 
: '''[[DEM#Show Frame|Show Frame]]:''' Shows blue rectangle with the extent of loaded DEM.
 
: '''[[DEM#Resize|Resize]]:''' Resize OCAD DEM file (make a subset) and save it as a new OCAD DEM file.
 
: '''[[DEM#Info|Info]]:''' Shows information about OCAD DEM file.
 
: '''[[DEM#Close|Close]]:''' Close OCAD DEM file.
 
: '''[[DEM#Merge DEM| Merge DEM]]:''' Merges two parts of a DEM together.
 
: '''[[DEM#Calculate DEM Difference|Calculate DEM Difference]]''' Calculates the difference between a surface and a terrain model.
 
: '''[[DEM#Create Contour Lines|Create Contour Lines]]:'''  Calculates contour lines based on the loaded DEM.
 
: '''[[DEM#Create Hypsometric Map|Create Hypsometric Map]]:''' Calculates a grayscale or colored hypsometric map
 
: '''[[DEM#Create Hill Shading|Create Hill Shading]]:''' Calculates a shaded relief picture.
 
: '''[[DEM#Calculate Slope Gradient|Calculate Slope Gradient]]''' Calculates a grayscale picture with slope gradient.
 
: '''[[DEM#Classify Vegetation Height|Classify Vegetation Height]]''' Calculates picture with vegetation height classes.
 
: '''[[DEM#Create Profile|Create Profile]]:''' Creates a profile for the selected line object.
 
: '''[[DEM#Export|Export]]:''' Save loaded OCAD DEM file as ESRI ASCII Grid or as ASCII Grid XYZ.
 
  
===GPS Menu===
+
Enter the name of the selection and click on the '''Save''' button.
''(This function is only available in OCAD Professional!)''
 
: '''[[GPS#Real Time GPS|Real Time GPS]]'''
 
: '''[[GPS#Adjust Local GPS Position|Adjust Local GPS Position]]'''
 
: '''[[GPS#Import Data from GPS Device|Import Data from GPS Device]]'''
 
: '''[[GPS#Import from File|Import from File]]'''
 
: '''[[Connect to Laser Distance Meter|Connect to Laser Distance Meter]]'''
 
  
===Options Menu===
+
[[File:Hint.jpg|hint]] Choose '''[[Select#Select Objects by Symbol|Select Objects by Symbol]]''' in the '''Select''' menu to select all objects of the selected symbols.
: '''[[OCAD Preferences]]:''' Options for your individual working methods.
 
: '''[[Shortcuts]]:''' Define or change keyboard shortcuts for menu commands.
 
: '''[[Backup and Restore Options]]'''
 
: '''[[Language]]:''' Choose a language.
 
  
===[[Window]] Menu===
+
==Reload Selection==
: '''[[Window#Tile|Tile]]:''' Arrange all open maps horizontally or vertically on the screen.
 
: '''[[Window#Cascade|Cascade]]:''' Arrange all open maps in a way that the title of each map is visible.
 
  
===Help Menu===
+
Choose '''Reload Selection''' in the '''Select''' menu to select all objects from a saved selection. Choose a saved selection and the '''Reload Selection''' dialog appears.
: '''[[Main_Page|Contents]]:''' The contents of this help file.
 
: '''[[Graphical_User_Interface#Menu|Menu]]:''' Help for menu commands.
 
: '''[[Graphical_User_Interface#Toolbars|Toolbar]]:''' Help for toolbar buttons.
 
: '''[http://www.ocad.com/en/ OCAD Home page]:''' Connect to the OCAD homepage on the Internet.
 
: '''[http://www.ocad.com/en/downloads/ OCAD Update]:''' Connect to the OCAD download site on the Internet.
 
: '''[http://www.ocad.com/en/support/learn-video/ OCAD Learn Videos]:''' Connect to Learning Videos on OCAD homepage.
 
: '''[http://www.ocad.com/en/ About OCAD]:''' General Information about OCAD.
 
  
==Using the Keyboard with the Mouse==
+
[[File:ReloadSelection.PNG]]
This section provides an overview of options for using the keyboard and the mouse together.
 
  
===Drawing===
+
The list of the selected objects with aditional information is shown in the dialog. The number of selected objects is shown in the caption in brackets.  
*'''Shift''' [[File:Shift.JPG|shift]]: When starting a curve, straight line or freehand line: extend an existing object.
 
*'''Ctrl:''' Trace an existing object.
 
*'''Alt:''' Drawing a straight line: the line is made exactly horizontal or vertical.
 
  
===Drawing a circle===
+
Select one object in the list and OCAD selects this object in the drawing area in the edit mode.
*'''Shift''' [[File:Shift.JPG|shift]]: Drag the radius from the center point.
 
  
===Edit===
+
==Edit Selection==
*'''Shift''' [[File:Shift.JPG|shift]]: Add or remove an object to/from the selected objects.
+
Choose '''Edit Selection''' in the '''Select''' menu to rename or delete saved selections.
*'''Ctrl:''' Remove a vertex.
 
*'''Shift''' [[File:Shift.JPG|shift]]  '''+ Ctrl:''' Insert a normal vertex.
 
*'''Alt:''' Select an object behind an object that has already been selected.
 
*'''Alt +''' [[File:Icon_Cut.PNG|cut]]: hange to Edit mode to select next line object in between cutting lines.
 
*'''Ctrl +''' [[File:Icon_Cut.PNG|cut]]: Cut a virtual gap into the selected line object.
 
*'''Shift''' [[File:Shift.JPG|shift]]  + [[File:Icon_Cut.PNG|cut]]: Cut a broken line: a gap is inserted at the vertex where the cut was made.
 
*'''Arrow keys:''' Moves the selected object.
 
  
===View===
+
[[File:EditSelection.PNG]]
*'''Space bar + Left Mouse Button:''' Move the View (pan).
 
*'''Ctrl + Mouse Wheel:''' Zoom in and zoom outIncrease/reduce the size of the map section.
 
*'''Shift'''  [[File:Shift.JPG|shift]] '''+ Mouse Wheel:''' Move the map section horizontally (scroll).
 
  
 +
==== Delete a Selection ====
 +
Select a selection in the '''Edit Selection''' dialog and click the '''Delete''' button to delete it. Click the '''Delete all''' button to delete all selections.
 +
==== Rename a Selection ====
 +
Select a selection in the '''Edit Selection''' dialog. Then enter a new name for the selection in the '''Selection name''' field. Click the '''Rename''' button to apply the new name.
 +
<br />
 +
<br />
 +
Click the '''OK''' button to save and quit the '''Edit Selection''' dialog. Click the '''Cancel''' button to close the '''Edit Selection''' dialog without saving any changes.
  
Previous Chapter: [[Renewals]]
+
==Select Group ==
 +
If you have [[Group and Ungroup|grouped]] objects on your map, you can select them easily by choosing '''Select Group''' in the '''Select''' menu.
  
Next Chapter: [[Create a New Map]]
 
  
Back to [[Main Page]]
+
[[File:Camera.jpg|video available]] [[http://www.ocad.com/howtos/136_Selection.htm Selection]]

Revision as of 15:26, 2 May 2012

  • To select single objects press Crtl while marking by clicking objects with mouse or
  • pressed drag the mouse pointer over the objects.


Select and Edit Object

Choose Select and Edit Object in the Select menu or click the Select and Edit Object icon in the Editing and Drawing Toolbar to select and edit an object.

Select Object and Edit Vertex

ToDo

Select Objects by Symbol

Choose this command to select all objects with certain symbols or in a certain layer.

  • All objects with a selected symbol
  • All objects ins layer
  • Layout objects
  • Unsymbolized objects
  • Graphic objects
  • Image obejcts
  • Objects with invalild symbol type


Select Objects by Property

This command is activated if a map file is loaded.

Select

The first option All Objects means that the selection is made out of all objects in the map. The second option Objects with a selected symbol means that the selection is reduced to the objects with a symbol that is selected in the symbol box.

Condition

  • Choose a property like Number of vertices, Length etc.
  • Choose an operator like < > = etc.
  • Enter a condition value.


Example 1

Option All objects Condition: Length > 200 Result: All map objects with a length longer than 200 m are selected and listed in a table dialog box.


Example 2

Select two symbols in the symbol box (ex. lake and pond) Option: Objects with a selected symbol Condition: Area <= 3000 Result: All lakes and ponds with an area smaller or equal than 3000 m2 are selected and their properties listed in a table dialog box.


Select All

Choose Select All in the Select menu to select all symbolized (also from protected and hidden symbols), unsymbolized, graphic and image objects. Layout objects are not selected.

Clear Selection

Choose Clear Selection in the Select menu to deselect all objects.

Invert Selection

Choose Invert Selection in the Select menu to deselect all selected objects and select all unselected object. Layout objects are not selected.

Select Next Object

Choose Select Next Object in the Select menu to select an object which is behind an object that is already selected.

Save Selection

Choose Save Selection in the Select menu to save the current selection. The Save Selection dialog box appears.

SaveSelection.PNG

Enter the name of the selection and click on the Save button.

hint Choose Select Objects by Symbol in the Select menu to select all objects of the selected symbols.

Reload Selection

Choose Reload Selection in the Select menu to select all objects from a saved selection. Choose a saved selection and the Reload Selection dialog appears.

ReloadSelection.PNG

The list of the selected objects with aditional information is shown in the dialog. The number of selected objects is shown in the caption in brackets.

Select one object in the list and OCAD selects this object in the drawing area in the edit mode.

Edit Selection

Choose Edit Selection in the Select menu to rename or delete saved selections.

EditSelection.PNG

Delete a Selection

Select a selection in the Edit Selection dialog and click the Delete button to delete it. Click the Delete all button to delete all selections.

Rename a Selection

Select a selection in the Edit Selection dialog. Then enter a new name for the selection in the Selection name field. Click the Rename button to apply the new name.

Click the OK button to save and quit the Edit Selection dialog. Click the Cancel button to close the Edit Selection dialog without saving any changes.

Select Group

If you have grouped objects on your map, you can select them easily by choosing Select Group in the Select menu.


video available [Selection]