Create a Layout
On this page we want to give you an overview of the different possibilities to create a map layout in OCAD.
Things to Consider Before You Start
Before creating a layout, take a moment to consider the following aspects.
Layout File
You can create a layout either:
- Directly in the map file
- Easier when sharing a map project with other users.
- Map and layout are stored together in a single file.
- In a separate OCAD file
- Easier to reuse the same layout in multiple map files.
- Required when using the Canvas function for orienteering course setting projects.
Paper Format
Define the intended output before designing the layout:
- Paper size (A4, A3, etc.)
- Map scale
- Page orientation (Portrait, Landscape)
These settings influence the available space for map elements, legends, logos and additional information.
Printing Requirements
Check the capabilities of your printing provider:
- Can the printer print to the edge of the paper?
- Is a bleed area required?
- What are the minimum margins?
These factors may affect the placement of layout elements near the page border.
Define export and print extents
Use the Define Paper Size function to define a paper size. The extent will be shown in the drawing area and the area outside will be grayed out. This makes it easy to see where you need to place the layout objects.
Saved extents will later be available in the export, print and also in the Canvas dialog.
Layout with or without bleed
Neither professional printing systems nor standard home printers can print right up to the edge of the paper. They always need some empty borders of approximately 3 - 5 mm all round to guide the paper through the printer. Nevertheless, there are orienteering maps that are intended to be printed right up to the edge of the paper. This is referred to as full-bleed printing.
This gives you two options for designing the layout:
Layout without bleed
For non-bleed printing, there must be a white border of at least 5 mm all round.
This can be ensure by defining a Margin in the Define Paper Size function.
You make things easier for yourself if you create such a layout that doesn't go all the way to the edge.
The print PDF exported from OCAD has a size that corresponds to the map size, e.g.:
Map size A4 (297 x 210 mm) = print PDF size 297 x 210 mm
Layout with bleed
If the layout should last all the way to the edge, all layout elements and the print extent must be 3 - 5 mm larger on all four sides than the final map format. After printing the maps are cut to the exact size using so-called Trim marks.
If there is no so-called bleed (the area to be trimmed) on full-bleed maps, machine-related cutting tolerances can result in white edges.
The print PDF exported from OCAD is a size that is 3 - 5 mm larger on all sides than the final map format, e.g.:
Map size A4 (297 x 210 mm) = print PDF size 307 x 220 mm
Step 1: Define extent
Create and save a new extent int the Define Paper Size function.
There is no need to define a Margin.
Step 2: Add Trim marks
Add Trim marks using the Add Trim and Bleed Marks command in the Layout menu.
The Trim marks will be added as layout objects to the map.
Step 3: Save new extent
When adding the Trim marks in the previous step, OCAD automatically created a new extent.
The extent is covering the A4 map format, plus the trim marks.
You can load this extent in the Define Paper Size function and save it with a new, more meaningful name.
Step 4: Use extent for PDF Export
Use the extent for PDF export. The extent is available in the export and also in the Canvas dialog when loading the layout file as background map.
The print PDF exported from OCAD is a size that is approximately 5 mm larger on all sides than the final map format.
Create the layout file(s)
Create map layout for each export extent.
How the layout is created depends on personal preferences. Various ways and combinations are possible.
To create a layout, you can use layout objects, symbolized objects (OCAD objects), raster images, graphic or image objects. Be aware of the display order of the different layers.
When you create a layout for a course setting project, make sure you leave enough space for course setting objects such as control descriptions, course titles, ...
If the layout is done in a separate file, you can add the map file as background map to adapt the layout to the map. Remember to remove the background map again when the layout is done.
Add Frame and Text
Layout objects
Choose the Edit Layout Objects command in the Layout menu.
Here you can add raster images and vector objects like lines, areas or text objects.
The topmost layout object is displayed above the objects below it in the list.
When your layout is done, you can choose the Save command from the Layout menu to save the layout objects to a separate OCAD file.
OCAD objects
Instead of using layout objects, you can also use symbolized objects (normal OCAD objects) to create a layout.
Create a new symbol by choosing New in the Symbol menu.
Graphic and Image Objects
A Graphic Object is an object which is not assigned to a symbol. It is either a line or area object with a color from the color table.
An Image object is an imported vector graphic element. E.g. you get image objects when importing a PDF file. These are solely line and area image objects. Image objects are not connected to a color from the color table.
Image objects are also created when you Create a Color Gradient
In the Object menu, you can convert an object to a Graphic / Image / Layout object or change it to a Symbolized Object.
Add logos
In OCAD you can add raster logos in the Layout menu, or you can import a logo as a vector file.
Do not open the raster logos as a background map, as this would rasterize the entire map when exporting a PDF file!
Add raster logos
The easiest way to add a logo to the map is to embed logos as a raster images directly into the OCAD file in the Layout menu.
Ensure that the file size of the raster images is not unnecessarily large, and adjust the size of the logos if necessary.
If there are only few and distinct colors with no color gradient, the PNG format is the best choice. Please note that PNG transparency is not supported.
Save the logo in JPG format if there are color gradients.
The color model for layout images in OCAD is RGB. If you add raster logos that are saved as CMKY logos, OCAD will convert the colors.
Add vector logos
It is also possible to import logos in vector PDF format. In this case OCAD creates Image objects, which have the correct CMYK color values and can be scaled arbitrarily.
The Image objects can later be converted to OCAD symbols.
You cannot import .eps into OCAD.
Cover parts of the map
Sometimes you may want to hide certain parts of the map. You can so so by covering parts of the map with a withe color.
Option map objects
- Define a new white color (Map>Colors>Add).
- Move it to the top of the color table or to another desired position.
- Create a new area symbol (Symbol>New>Area Symbol) where you use the newly created color as Fill color.
Option layout objects
- Open the Layout menu (Layout>Edit Layout Objects).
- Add withe area objects.
- Make sure the white objects are at the bottom of the object list, if there are other layout elements in the list to not cover them.
Option White background symbol
- In Course Setting Projects, you can use the White background symbol (760.000) as a quick solution.
- However, make sure that you do not cover any course objects (controls, control numbers, connection lines, ...), as the withe color that is used in symbol 760 will cover course objects.
Cut away parts of the map
Alternatively, you can cut away parts of the map instead of just cover them.
If so, make sure you are working with a copy and not the original map.
Add further layout elements
Re-Use a Layout
Import a layout
If you have created a layout with layout objects, you can save it and import it into another file.
Choose the Import Layout command in the Layout menu and select the corresponding file.
All layout objects are imported (raster images and lines, areas or text objects).
If you have created a layout with symbolized objects, Choose the Import command in the File menu and select the desired file.
In the Position section, choose Place using the mouse. In the Symbols section, choose Import all symbols and colors and Import colors at the top of the color table.
Not only are all OCAD symbols and OCAD objects imported, but also (if available) layout objects and raster images.
Remove all unused symbols and colors from the layout file before importing the file. This will help you to keep a better overview
Adapt a layout to a different scale
For example, you have created a layout for an A4 portrait format at a scale of 1:10'000.
Now you would also like to use this layout at a scale of 1:7'500 and 1:15'000.
You can scale the layout accordingly with the following steps:
- Layout 10'000 to 7'500
Choose the Change Scale command in the Map menu and enter 13'333 as a new scale (10'000 / 7500 * 10000).

Choose the Set Scale and Coordinate System command in the Map menu and enter 10'000 as map scale and click OK.
Define a new extent for A4 portrait format at a scale of 1:7'500.
Save the file under a new name, e.g. Layout 1:7'500.
- Layout 10'000 to 15'000
Open the layout file 1:10'000
Choose the Change Scale command in the Map menu and enter 6'666 as a new scale (10'000 / 15'000 * 10000).
Choose the Set Scale and Coordinate System command in the Map menu and enter 10'000 as map scale and click OK.
Define a new extent for A4 portrait format at a scale of 1:15'000.
Save the file under a new name, e.g. Layout 1:15'000.
- Layout 15'000 to 10'000
Open the layout file 1:15'000
Choose the Change Scale command in the Map menu and enter 22'500 as a new scale (15'000 / 10'000 * 15000).
Choose the Set Scale and Coordinate System command in the Map menu and enter 15'000 as map scale and click OK.
Define a new extent for A4 portrait format at a scale of 1:10'000.
Save the file under a new name, e.g. Layout 1:10'000.
Printing Process
See the Course Setting Printing page for more information.



